Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hinting in Chromium
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Sun Sep 27, 2015 4:41 pm    Post subject: Hinting in Chromium Reply with quote

Vor einiger Zeit habe mich mal mit Hinting und Antialasing beschäftigt und seither gestochen scharfe Buchstaben und Bilder auf dem Schirm.

Seit einem nicht mehr zu ermittelnden Update, scheint sich Chromium nicht mehr um meine Einstellungen zu kümmern und zeigt sehr unscharfe, ausgefranste Buchstaben und Bilder. Eine Suche zeigt eigentlich nur alte Beiträge, meist von 2009. Lediglich der vorletzte Beitrag von https://code.google.com/p/chromium/issues/detail?id=408079 half etwas.

In meinem Homeverzeichnis existierte bisher nur eine .config/gtk-3.0/settings.ini:
Code:
[Settings]
gtk-theme-name=Raleigh
gtk-icon-theme-name=Adwaita
gtk-font-name=Liberation Sans 8
gtk-cursor-theme-size=0
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-toolbar-icon-size=GTK_ICON_SIZE_SMALL_TOOLBAR
gtk-button-images=1
gtk-menu-images=1
gtk-enable-event-sounds=1
gtk-enable-input-feedback-sounds=1
gtk-xft-antialias=1
gtk-xft-hinting=1
gtk-xft-hintstyle=hintfull
gtk-xft-rgba=none

Weiter ist wichtig:
Code:
ls /etc/fonts/conf.d/
10-autohint.conf    45-latin.conf        69-unifont.conf
11-lcdfilter-light.conf  60-latin.conf        README
30-metric-aliases.conf    60-liberation.conf

Aus der .config/gtk-3.0/settings.ini habe ich eine .fonts.conf
Code:
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
 <match target="font" >
  <edit mode="assign" name="rgba" ><const>none</const></edit>
  <edit mode="assign" name="hinting" ><bool>true</bool></edit>
  <edit mode="assign" name="hintstyle" ><const>hintfull</const></edit>
  <edit mode="assign" name="antialias" ><bool>true</bool></edit>
 </match>
</fontconfig>
und eine [b].Xresources[/b erstellt.:
Code:
Xft.antialias:  true
Xft.hinting:    true
Xft.hintstyle:  hintfull
Xft.rgba:       none

Ändern tut sich damit nichts.

Kann jemand helfen?

Vielen Dank
wuesti
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Mon Sep 28, 2015 3:04 pm    Post subject: Reply with quote

Ich glaube, ich suche an der falschen Stelle, weil auch Bilder im chromium matschig sind. Siehe diese Bildschirmausschnitte:

Blau ist von einem PNG-Bild, schwarz Schrift.
Kennt jemand das Problem?
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
Dorsai!
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 276
Location: Bavaria

PostPosted: Thu Oct 01, 2015 12:13 pm    Post subject: Reply with quote

Ist bei dir vielleicht ein fester zoom level eingerichtet? Das findet sich für alle Seiten in den erweiterten Einstellungen, aber per-Seite kannst du auch einfach im Menu button nachsehen welcher zoom level gerade aktiv ist.
Back to top
View user's profile Send private message
wuesti
Apprentice
Apprentice


Joined: 07 Mar 2009
Posts: 191

PostPosted: Thu Oct 01, 2015 12:23 pm    Post subject: Reply with quote

Die Zoomstufe ist 100%.
_________________
Linux-User seit 1999
Back to top
View user's profile Send private message
koschi
Tux's lil' helper
Tux's lil' helper


Joined: 09 Oct 2004
Posts: 118
Location: Tianjin, CN

PostPosted: Thu Oct 29, 2015 12:58 pm    Post subject: Reply with quote

Hallo,

ich kann mich dunkel daran erinnern dass ich in Chromium undeutliche Schriften hatte als der autohinter aktiviert war. Hier mein fontconfig:

Code:
mobiletux ~ # eselect fontconfig list | grep '*'
Available fontconfig .conf files (* is enabled):
  [5]   10-sub-pixel-rgb.conf *
  [9]   11-lcdfilter-default.conf *
  [20]  30-metric-aliases.conf *
  [21]  30-urw-aliases.conf *
  [27]  42-luxi-mono.conf *
  [28]  45-latin.conf *
  [29]  49-sansserif.conf *
  [32]  57-dejavu-sans-mono.conf *
  [33]  57-dejavu-sans.conf *
  [34]  57-dejavu-serif.conf *
  [36]  60-liberation.conf *
  [42]  70-no-bitmaps.conf *


Gruß
koschi
_________________
Der Digitalrechner ist ein Vollidiot mit einer einseitigen Begabung im schnellen Addieren.
Back to top
View user's profile Send private message
Helmering
n00b
n00b


Joined: 13 Dec 2011
Posts: 57
Location: Italy

PostPosted: Thu Oct 29, 2015 4:30 pm    Post subject: Reply with quote

wuesti wrote:
Ich glaube, ich suche an der falschen Stelle, weil auch Bilder im chromium matschig sind. ...
Kennt jemand das Problem?


Probier mal:
Code:
~ $ chromium-browser --force-device-scale-factor=1


War bei mir Ursache von matschigem Bild&Text.

Sollte es das gewesen sein, passt du am besten chromium-browser-chromium.desktop an.

Gruss Ralf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum