Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Plantronics headset
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Mon Sep 28, 2015 9:21 pm    Post subject: [SOLVED] Plantronics headset Reply with quote

Hi everybody,
I'm trying to use a Plantronics headset with my laptop, but I'm unable to make it work with Phonon (using KDE)
Using aplay, sound is correctly played on the device:
Code:
# aplay -D sysdefault:CARD=C620M /home/kikko/Downloads/11k16bitpcm.wav

I know this kind of headset should be seen as a sort of "usb audio device", and I (hope to) have all kernel modules loaded for it:
Code:
# lsmod | grep snd_usb_audio
snd_usb_audio         180224  2
snd_usbmidi_lib        32768  1 snd_usb_audio
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
snd_pcm               102400  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core

dmesg contains some strange messages
Code:
[11893.207785] usb 1-1.2: new full-speed USB device number 6 using ehci-pci
[11893.297520] usb 1-1.2: New USB device found, idVendor=047f, idProduct=aa01
[11893.297523] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[11893.297525] usb 1-1.2: Product: Plantronics C620-M
[11893.297527] usb 1-1.2: Manufacturer: Plantronics
[11893.313005] usb 1-1.2: 1:1: cannot get freq at ep 0x4
[11893.317996] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.529883] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.532877] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.551350] usb 1-1.2: 1:1: cannot get freq at ep 0x4
[11893.554347] usb 1-1.2: 1:1: cannot get freq at ep 0x4
[11893.560349] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.563343] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.588692] usb 1-1.2: 1:1: cannot get freq at ep 0x4
[11893.591687] usb 1-1.2: 1:1: cannot get freq at ep 0x4
[11893.601428] usb 1-1.2: 2:1: cannot get freq at ep 0x84
[11893.604421] usb 1-1.2: 2:1: cannot get freq at ep 0x84

lsusb out :
Code:
Bus 001 Device 006: ID 047f:aa01 Plantronics, Inc.

there is also this pulseaudio message in the system logs
Code:
pulseaudio[3297]: [pulseaudio] sink.c: Default and alternate sample rates are the same.

Any ideas? Could this be related to pulseaudio?

Thank you in advance, any suggestion is appreciated
Regards


Last edited by kikko on Mon Oct 05, 2015 12:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
gentoo_ram
Guru
Guru


Joined: 25 Oct 2007
Posts: 411
Location: San Diego, California USA

PostPosted: Wed Sep 30, 2015 6:03 pm    Post subject: Reply with quote

I had problems using USB headsets in the past unless there was a kernel option turned on. In kernel 4.2.0 it's called CONFIG_USB_EHCI_TT_NEWSCHED or "Improved Transaction Translator scheduling". I remember it being called something slightly different in older kernels. Look under the EHCI option under USB drivers.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Thu Oct 01, 2015 8:05 pm    Post subject: Reply with quote

Hi gentoo_ram
I've found that parameter in my kernel config:
Code:
~ $ zgrep EHCI /proc/config.gz
CONFIG_USB_EHCI_HCD=y
CONFIG_USB_EHCI_ROOT_HUB_TT=y
CONFIG_USB_EHCI_TT_NEWSCHED=y
CONFIG_USB_EHCI_PCI=y
# CONFIG_USB_EHCI_HCD_PLATFORM is not set

could it help to enable the "generic" CONFIG_USB_EHCI_HCD_PLATFORM?
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Sun Oct 04, 2015 8:21 pm    Post subject: Reply with quote

Update: CONFIG_USB_EHCI_HCD_PLATFORM doesn't solve a thing...
But at least enabling HID_PLANTRONICS in the kernel config made the volume controller to work
Any further suggestion is appreciated :D

Regards
Back to top
View user's profile Send private message
Wadlax
n00b
n00b


Joined: 12 Jan 2008
Posts: 8

PostPosted: Sun Oct 04, 2015 8:29 pm    Post subject: Reply with quote

I don't use pulseaudio, i use alsa.

I've set my Logitech headset as alsa default with

/etc/asound.conf
Code:
defaults.ctl.card 2
defaults.pcm.card 2
defaults.timer.card 2

You can get devices list with "aplay -l" command.

( May be you should try to set your headset to alsa default first. )

Hope it helps somehow.
Back to top
View user's profile Send private message
kikko
Apprentice
Apprentice


Joined: 29 Apr 2014
Posts: 256
Location: Milan, IT

PostPosted: Mon Oct 05, 2015 12:55 pm    Post subject: Reply with quote

Thank you Wadlax, in fact with plain ALSA everithing works as expected
Anyway, I've founded the issue ConsoleKit wasn't enabled, so it's all my fault :oops: :
Code:
sudo rc-update add consolekit default

This reminds me to RTFM next time :lol:

Regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum