Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-qt/qtsql-4.8.6-r1 lässt sich nicht bauen [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Oct 05, 2015 6:56 am    Post subject: dev-qt/qtsql-4.8.6-r1 lässt sich nicht bauen [solved] Reply with quote

Hallo zusammen,

hab hier auf einer Kiste dieses ziemlich nervige Problem.
Da das mitten in nem KDE Update nicht mehr ging, musste ich erst mal alles auf sqlite umbauen um überhaupt erst mal wieder einen funktionierenden KDE zu haben.

Code:
collect2: error: ld returned 1 exit status
Makefile:102: recipe for target 'mysql_r' failed
gmake: *** [mysql_r] Error 1
MySQL (thread-safe) disabled.
MySQL (thread-unsafe) auto-detection... ()
x86_64-pc-linux-gnu-g++ -m32 -c -march=corei7 -O2 -pipe -Wall -W  -I/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/mkspecs/linux-g++ -I/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/mysql -I/usr/include/mysql -I/usr/include -I/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/mysql -I. -o mysql.o /var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/config.tests/unix/mysql/mysql.cpp
x86_64-pc-linux-gnu-g++ -m32 -Wl,-O1 -Wl,--as-needed -o mysql mysql.o     -L/usr/lib32/mysql -L/usr/lib64 -lpthread -lz -lm -ldl -lbfd -lssl -lcrypto -lmysqlclient
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libpthread.so when searching for -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libpthread.a when searching for -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libz.so when searching for -lz
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libdl.so when searching for -ldl
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libdl.a when searching for -ldl
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/lib/libbfd.so when searching for -lbfd
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/binutils/x86_64-pc-linux-gnu/2.25.1/libbfd.so when searching for -lbfd
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lbfd
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libssl.so when searching for -lssl
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libcrypto.so when searching for -lcrypto
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libmysqlclient.so when searching for -lmysqlclient
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libm.so when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libm.a when searching for -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.so when searching for -lc
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libc.a when searching for -lc
collect2: error: ld returned 1 exit status
Makefile:102: recipe for target 'mysql' failed
gmake: *** [mysql] Error 1
MySQL (thread-unsafe) disabled.
MySQL support cannot be enabled due to functionality tests!
 Turn on verbose messaging (-v) to /var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/configure to see the final report.
 If you believe this message is in error you may use the continue
 switch (-continue) to /var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6/configure to continue.
 * ERROR: dev-qt/qtsql-4.8.6-r1::gentoo failed (configure phase):
 *   configure failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3166:  Called multilib-minimal_src_configure
 *   environment, line 1949:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2156:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1880:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1878:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  406:  Called multilib-minimal_abi_src_configure
 *   environment, line 1943:  Called multilib_src_configure
 *   environment, line 2373:  Called qt4_multilib_src_configure
 *   environment, line 2882:  Called die
 * The specific snippet of code:
 *       "${S}"/configure "${conf[@]}" || die "configure failed";
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtsql-4.8.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtsql-4.8.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6-abi_x86_32.x86'
 * S: '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6'

>>> Failed to emerge dev-qt/qtsql-4.8.6-r1, Log file:

>>>  '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/temp/build.log'

 * Messages for package dev-qt/qtsql-4.8.6-r1:

 * ERROR: dev-qt/qtsql-4.8.6-r1::gentoo failed (configure phase):
 *   configure failed
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_configure
 *   environment, line 3166:  Called multilib-minimal_src_configure
 *   environment, line 1949:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2156:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1880:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 1878:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  406:  Called multilib-minimal_abi_src_configure
 *   environment, line 1943:  Called multilib_src_configure
 *   environment, line 2373:  Called qt4_multilib_src_configure
 *   environment, line 2882:  Called die
 * The specific snippet of code:
 *       "${S}"/configure "${conf[@]}" || die "configure failed";
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtsql-4.8.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtsql-4.8.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6-abi_x86_32.x86'
 * S: '/var/tmp/portage/dev-qt/qtsql-4.8.6-r1/work/qt-everywhere-opensource-src-4.8.6'


Kommt das jemand bekannt vor?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes


Last edited by tazinblack on Mon Oct 05, 2015 8:37 am; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Mon Oct 05, 2015 7:19 am    Post subject: Reply with quote

libbfd kommt jetzt mit binutils-libs. Das installieren sollte helfen.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Oct 05, 2015 7:32 am    Post subject: Reply with quote

Warum zieht portage das nicht automatisch an?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Oct 05, 2015 7:58 am    Post subject: Reply with quote

Nachdem ich jetzt gdb noch auf testing hochgezogen hab, scheints zu kompilieren.
Mal abwarten was jetzt noch kommt.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Mon Oct 05, 2015 8:36 am    Post subject: Reply with quote

Danke für die schnelle Hilfe, es scheint alles zu laufen.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 216

PostPosted: Wed Oct 14, 2015 10:28 pm    Post subject: Reply with quote

Haargenau dasselbe Problem gerade auch gehabt. An binutils-libs liegt es nicht.

emerge --oneshot gdb

behebt das Problem auch nicht. Also sys-devel/gdb auf testing gesetzt und nochmal das Ganze.

Unf funktioniert wieder nicht. Definitiv mal wieder eine sehr seltsame Sache.

Also qtsql auf testing gesetzt. Mal sehen, ob das was bringt. Grrr.
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 216

PostPosted: Wed Oct 14, 2015 11:57 pm    Post subject: Reply with quote

Problem gefunden:

Eine alte mariadb bibliothek war noch mit dem normalen linker gebaut, aktuell habe ich aber schon seit ner Weile auf den gold linker umgestellt.

emerge --oneshot mariadb

hat das Ganze behoben.
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Wed Oct 21, 2015 7:44 am    Post subject: Reply with quote

gold linker?
Hab ich das was verpasst?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 216

PostPosted: Sat Oct 31, 2015 4:34 pm    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/Gold
Back to top
View user's profile Send private message
tazinblack
Veteran
Veteran


Joined: 23 Jan 2005
Posts: 1124
Location: Baden / Germany

PostPosted: Sun Nov 01, 2015 9:38 am    Post subject: Reply with quote

ok, dass das geht hab ich verstanden, aber warum könnte ich wohl den Standardlinker durch die gold Variante austauschen wollen?
Was bringt das für Vorteile?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
what's the point in being grown up if you can't be childish sometimes
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sun Nov 01, 2015 1:11 pm    Post subject: Reply with quote

tazinblack wrote:
ok, dass das geht hab ich verstanden, aber warum könnte ich wohl den Standardlinker durch die gold Variante austauschen wollen?
Was bringt das für Vorteile?

Gold braucht weniger Speicher und ist schneller. Außerdem ist er strikter (siehe z.B. "Underlinking")
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum