Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
make modules_prepare does not reinstall external modules?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
x220tux
n00b
n00b


Joined: 09 Apr 2015
Posts: 19

PostPosted: Wed Oct 14, 2015 1:30 am    Post subject: make modules_prepare does not reinstall external modules? Reply with quote

I read from WiKi, when upgrading new kernel or re-compiling current kernel, we need to rebuild external module. I have executed
Code:
make modules_prepare
before compiling the kernel source, but
Code:
make -j5
make modules_install
reminds warning:
Code:
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_iova_to_phys
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_iova_to_phys
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol kmem_cache_alloc_trace
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_present
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_detach_device
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_domain_free
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_domain_alloc
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_unmap
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_map
depmod: WARNING: /lib/modules/4.0.5-gentoo/misc/vboxpci.ko needs unknown symbol iommu_attach_device
This means that make modules_prepare does NOT help rebuild external VIrtualBox modules.

How does make modules_prepare to rebuild external modules?
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Wed Oct 14, 2015 2:05 am    Post subject: Reply with quote

Try emerge @module-rebuild
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum