Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Monitor not going into standby/suspend correctly
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Tatsh
Apprentice
Apprentice


Joined: 22 Jul 2007
Posts: 179

PostPosted: Fri Oct 16, 2015 12:03 am    Post subject: Monitor not going into standby/suspend correctly Reply with quote

My Dell U3014 connected to a GeForce 980 GTX with nvidia-drivers 352|355 (tried both) will not go to sleep correctly. I can run
Code:
xset dpms force off
and the monitor just runs the screensaver. It does not sleep/standby. My other monitor goes to sleep correctly. I disconnected the first monitor to ensure it's not a dual monitor configuration. I removed KDE settings out of the equation by using a brand new user account set up with KDE, but using xset instead of KDE to control the monitor. I do not see how KDE could conflict.

Logs like ~/.xsession-errors and journalctl (as root) are not giving any hints.

I used a Mac and set the Mac to sleep and the monitor went to sleep correctly, so it cannot be the monitor.

There is no interesting output when strace is used with xset dpms force suspend. It all seems normal, however for recv() and friends there are a lot of EAGAIN responses. This could be normal in a lot of cases.

xset q output:

Code:

Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  250    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                        fadfffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  20/10    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/OTF/,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 120
  DPMS is Enabled
  Monitor is Off


Even though this says 'Monitor is Off', the monitor is not off, nor in sleep. It is just displaying black until I interact again.
Back to top
View user's profile Send private message
russK
l33t
l33t


Joined: 27 Jun 2006
Posts: 630

PostPosted: Fri Oct 16, 2015 3:51 am    Post subject: Reply with quote

Maybe you need to drop back further to 346.96, others seem to have the same problem:
https://devtalk.nvidia.com/default/topic/791786/linux/dpms-not-working-on-gtx980-with-displayport-connection/2/
Back to top
View user's profile Send private message
Tatsh
Apprentice
Apprentice


Joined: 22 Jul 2007
Posts: 179

PostPosted: Fri Oct 16, 2015 4:32 am    Post subject: Reply with quote

Thanks. Downgrading to 346.96 solved my issue. Unfortunately, not sure if the issue will be resolved in newer versions > 355.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum