Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New kernel + same boot config = kernel panic?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Vandr0iy
n00b
n00b


Joined: 30 May 2015
Posts: 30

PostPosted: Thu Oct 29, 2015 1:14 pm    Post subject: New kernel + same boot config = kernel panic? Reply with quote

Hi, gentoomen!
I recently decided to switch kernels, but now, when I'm using a new kernel a kernel panic happens on boot saying that it is not able to find a boot device.
I was using debian 3.19 sources before, because of its stability, but then I decided to upgrade to the gentoo sources.
After downloading sources, setting up a configuration that I liked, an execution of "make install && make modules_install", initramfs generation and boot config update I try to reboot, but kernel panic happens, saying that it is unable to find a boot device at hd(0,0) (or something similar).
I then try to use my old debian 3.19 config file, but it is all vain. I thought it could be my boot config, but it is identical, except for the filenames of the kernel/initramfs to load.
here it is:
Code:
set timeout=5

  insmod part_gpt
  insmod fat
  set root=(hostdisk//dev/sdb,gpt1)
  search --no-floppy --fs-uuid --set 89EB-C906
if loadfont /grub/unifont.pf2; then
   set gfxmode=1600x900
   insmod all_video
   terminal_output gfxterm
fi

set menu_color_normal=cyan/blue
set menu_color_highlight=blue/cyan

menuentry "Funtoo Linux Debian Kernel - kernel-debian-sources-x86_64-3.19.3-1~exp1" {
  insmod part_gpt
  insmod fat
  set root=(hostdisk//dev/sdb,gpt1)
  search --no-floppy --fs-uuid --set 89EB-C906
  linux /kernel-debian-sources-x86_64-3.19.3-1~exp1 rootfstype=auto real_root=UUID=c7f653bc-414b-40c1-944f-b6b0c73ecac2 rootfstype=ext4
  initrd /initramfs-debian-sources-x86_64-3.19.3-1~exp1
  set gfxpayload=keep
}

menuentry "Funtoo Linux Gentoo Sources - vmlinuz-4.2.2-gentoo" {
  insmod part_gpt
  insmod fat
  set root=(hostdisk//dev/sdb,gpt1)
  search --no-floppy --fs-uuid --set 89EB-C906
  linux /vmlinuz-4.2.2-gentoo rootfstype=auto real_root=UUID=c7f653bc-414b-40c1-944f-b6b0c73ecac2 rootfstype=ext4
  set gfxpayload=keep
}
set default=1


What could be causing the kernel panic?

Thank you anticipately for your help.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Thu Oct 29, 2015 4:24 pm    Post subject: Reply with quote

Just friendly reminder, When you use some other distribution as gentoo. YOU HAVE TO SPECIFY IT IN THE POST.
FUNTOO is definitely not gentoo. Not even loosely based gentoo.


no support for the root file system, disc controller or disc setup.

sometimes you need an initramfs to boot a box.

If you were using gentoo, i would have suggested you, to start with a genkernel kernel and initramfs and than adapt it.

you may look for a kernel seed, reuse the sysrescue-cd kernel or config....

makes sense: rootfstype=auto <= It may be the same as removing this.


Quote:

linux /vmlinuz-4.2.2-gentoo rootfstype=auto real_root=UUID=c7f653bc-414b-40c1-944f-b6b0c73ecac2
rootfstype=ext4


makes the most sense. first you use the auto option, and than you specify it in a new line, which will be ignored. all those options have to be in the kernel line and on the same line, no line break allowed.


you may provide
Code:
blkid
sgdisk -p /dev/sda
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 499
Location: /dev/x0

PostPosted: Thu Oct 29, 2015 5:18 pm    Post subject: Reply with quote

I didn't see kernel panic in grub config
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43072
Location: 56N 3W

PostPosted: Thu Oct 29, 2015 6:52 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Unsupported Software.
Not because we won't help Funtoo users but it avoids Gentoo users following a thread that may not help them.

We need the panic message quoted verbatim, or any help is likely to be as vague as your statement of the problem.

You cannot use real_root=UUID= without an initrd and your gentoo-sources grub entry does not load an initrd.
Mounting root using UUID needs the userspace mount command but thats on the root filesystem so cannot be used to mount things until root is mounted.

There are lots of things you can try.
1. Mount root using the PARTUUID
2. Use the drive/partition for root
3. make an initrd.

The first two assume that your kernel has build in support (not modules) for all the other things needed to mount root without an initrd.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Vandr0iy
n00b
n00b


Joined: 30 May 2015
Posts: 30

PostPosted: Wed Nov 04, 2015 1:09 am    Post subject: Reply with quote

Hi again, gentoomen!
Sorry for the late reply. As always, what I did was extremely retarded, - thanks to you I saw that I did not mention the initramfs in the grub config file.
Anyways, since I managed to blow up portage tree on my funtoo install (the infamous ncurses 5.9 vs 6.0 issue + funtoo profile tool not working at all) I reinstalled, - choosing gentoo this time :lol:
Thank all of you for help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum