Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
iwl7260 Version Numbering (Help). [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
CrankyPenguin
Apprentice
Apprentice


Joined: 19 Jun 2003
Posts: 274

PostPosted: Sat Oct 31, 2015 2:20 am    Post subject: iwl7260 Version Numbering (Help). [solved] Reply with quote

I am trying to work out the version numbering for the iwl7260-ucode package. When I look in the ebuilds the most recent version appears to be sys-firmware/iwl7260-ucode-0.12.16.2. However when I look on the driver site: https://wireless.wiki.kernel.org/en/users/Drivers/iwlwifi I see version numbers ranging from 15.227938.0 (which seems to be the most recent) to 25.30.13.0 and 22.1.7.0. My questions are:

Thank you.
_________________
Linux, the OS for the obsessive-compulsive speed freak in all of us.


Last edited by CrankyPenguin on Mon Nov 16, 2015 4:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
vasettoo
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2012
Posts: 81

PostPosted: Sun Nov 01, 2015 8:36 am    Post subject: Reply with quote

Hi, there! To answer your first question - logic is irrelevant here because kernel ucode versions till 4.1+ seem to follow accending version numbers but the latest 4.2+ breaks this.
Your second assumption is correct - some time ago gentoo devs decided to do version numbering of intel ucode in reversed order. If you are willing to know why - ask them kindly :D
Onto the third question - see this and find the answer for yourself:
Code:
equery y iwl7260-ucode
Keywords for sys-firmware/iwl7260-ucode:
              |                                 | u    | 
              | a a   a         n   p r     s   | n    | 
              | l m   r h i m m i   p i s   p   | u s  | r
              | p d a m p a 6 i o p c s 3   a x | s l  | e
              | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | e o  | p
              | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | d t  | o
--------------+---------------------------------+------+-------
     0.7.1.22 | o ~ o o o o o o o o o o o o o ~ | o 7  | gentoo
--------------+---------------------------------+------+-------
    0.8.15.22 | o ~ o o o o o o o o o o o o o ~ | # 8  | gentoo
    0.8.24.22 | o ~ o o o o o o o o o o o o o ~ | o    | gentoo
--------------+---------------------------------+------+-------
   0.9.214.23 | o ~ o o o o o o o o o o o o o ~ | # 9  | gentoo
   0.9.228.25 | o ~ o o o o o o o o o o o o o ~ | o    | gentoo
--------------+---------------------------------+------+-------
   0.10.11.23 | o ~ o o o o o o o o o o o o o ~ | # 10 | gentoo
   0.10.15.23 | o ~ o o o o o o o o o o o o o ~ | o    | gentoo
--------------+---------------------------------+------+-------
[I]0.12.16.25 | o ~ o o o o o o o o o o o o o ~ | o 12 | gentoo

Best luck!
Back to top
View user's profile Send private message
CrankyPenguin
Apprentice
Apprentice


Joined: 19 Jun 2003
Posts: 274

PostPosted: Mon Nov 02, 2015 3:50 pm    Post subject: Reply with quote

Thank you, ... I think :)

From this it looks like what I need 0.12 which my system thinks is about 10 steps behind what I have installed. Cute.
_________________
Linux, the OS for the obsessive-compulsive speed freak in all of us.
Back to top
View user's profile Send private message
CrankyPenguin
Apprentice
Apprentice


Joined: 19 Jun 2003
Posts: 274

PostPosted: Mon Nov 16, 2015 4:37 pm    Post subject: Reply with quote

Yep. That worked. Thanks!
_________________
Linux, the OS for the obsessive-compulsive speed freak in all of us.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum