Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HPLIP plugin Install Fails Root Password
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Oct 31, 2015 2:07 pm    Post subject: HPLIP plugin Install Fails Root Password Reply with quote

OK, this is a little weird. I'm install HPLIP on a 64-bit unstable system.

My device requires a firmware plugin to take full advantage of the scanner. I'm trying to install the firmware and it rejects my root password.

I emerged HPLIP with USE=qt4, so I've got the gui working. I run hp-plugin as a normal user. It downloads the firmware file, but then aborts because it won't accept the root password. I tried to run the hp-plugin program as root, and it demands a normal user!


Anybody got any suggestions?
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
genoobish
n00b
n00b


Joined: 18 Feb 2015
Posts: 73

PostPosted: Sat Oct 31, 2015 3:24 pm    Post subject: Re: HPLIP plugin Install Fails Root Password Reply with quote

Do you use sudo for your user? I have just tried that, (also have an hplip scanner) and used my sudo password, and it succeeded.
if your user is a sudoer that is strange... if not, than is or it is not th that strange (i dont' know... I haven't tested. ).

more details?

edit: In the meanwhile, I tried to install it on my other machine, the banana-pi that's actually hosting the scanner and I got the same error you apparently got... I'm trying to figure out what's wrong...

edit2: Ok, the hplip versions and userflags are different.
this one is from the working setup
Code:

pingu@r2d2 ~ $ equery u hplip
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for net-print/hplip-3.15.9:
 U I
 + + X                        : Enables scanner GUI dependencies with USE="scanner" where media-gfx/xsane is preferred over
                                media-gfx/sane-frontends
 - - doc                      : Build documentation
 - - fax                      : Enable fax on multifunction devices which support it
 + + hpcups                   : Build the hpcups driver for cups (by HP)
 - - hpijs                    : Build the IJS driver for cups (Foomatic)
 - - kde                      : Enables kde-misc/skanlite as scanner GUI with USE="scanner X"
 + + libnotify                : Enables desktop notifications
 - - libusb0                  : Depend on virtual/libusb:0. Some old printers do not work with virtual/libusb:1
 - - minimal                  : Only build internal hpijs/hpcups driver (not recommended at all, make sure you know what you are
                                doing)
 - - parport                  : Enable parallel port for devices which require it
 + + policykit                : Enable PolicyKit authentication support
 + + python_targets_python2_7 : Build with Python 2.7
 - - qt4                      : Enable graphical interface using Qt 4
 + + scanner                  : Enable scanner on multifunction devices which support it
 - - snmp                     : Add support for net-analyzer/net-snmp which enables this driver to work over networks (both for
                                server and client)
 - - static-ppds              : Use statically-generated PPDs instead of Dynamic PPDs. Although this is deprecated some printers
                                may still need it to work properly. Use this flag if hp-setup fails to find/create a valid PPD
                                file


and this from the non workingsetup (actually everything works fine, it scans, but it just fails to install taht driver with hp-plugin. is that your problem too? or you have more things not working?):
Code:

monkey@banana ~ $ equery u hplip
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for net-print/hplip-3.15.9:
 U I
 + + X                        : Enables scanner GUI dependencies with USE="scanner" where media-gfx/xsane is preferred over
                                media-gfx/sane-frontends
 - - doc                      : Build documentation
 - - fax                      : Enable fax on multifunction devices which support it
 + + hpcups                   : Build the hpcups driver for cups (by HP)
 - - hpijs                    : Build the IJS driver for cups (Foomatic)
 - - kde                      : Enables kde-misc/skanlite as scanner GUI with USE="scanner X"
 + + libnotify                : Enables desktop notifications
 - - libusb0                  : Depend on virtual/libusb:0. Some old printers do not work with virtual/libusb:1
 - - minimal                  : Only build internal hpijs/hpcups driver (not recommended at all, make sure you know what you are
                                doing)
 - - parport                  : Enable parallel port for devices which require it
 - - policykit                : Enable PolicyKit authentication support
 + + python_targets_python2_7 : Build with Python 2.7
 - - qt4                      : Enable graphical interface using Qt 4
 + + scanner                  : Enable scanner on multifunction devices which support it
 - - snmp                     : Add support for net-analyzer/net-snmp which enables this driver to work over networks (both for
                                server and client)
 - - static-ppds              : Use statically-generated PPDs instead of Dynamic PPDs. Although this is deprecated some printers
                                may still need it to work properly. Use this flag if hp-setup fails to find/create a valid PPD
                                file

(post yours? and `emerge --info` could also be relevant)
I'm to reinstall it with policykit enabled and see if it works. it's probably going to take a while.
post your
Back to top
View user's profile Send private message
Vorlon
Apprentice
Apprentice


Joined: 16 May 2003
Posts: 229
Location: West Grove, PA

PostPosted: Sat Oct 31, 2015 6:00 pm    Post subject: Reply with quote

Genoobish, my equery -u hplip is the same as your working version. The only difference is that I have KDE installed.


To reiterate, I have to run hp-plugin as a regular user, but it rejects the root password. if I run it as root, it won't run at all. <sigh>


Here is my emerge --info
emerge --info
Portage 2.2.23 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r1, 4.2.5-gentoo x86_64)
=================================================================
System uname: Linux-4.2.5-gentoo-x86_64-AMD_Phenom-tm-_II_X4_940_Processor-with-gentoo-2.2
KiB Mem: 8175012 total, 3392892 free
KiB Swap: 16777212 total, 16777212 free
Timestamp of repository gentoo: Sat, 31 Oct 2015 12:30:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash: 4.3_p42::gentoo
dev-lang/perl: 5.22.0::gentoo
dev-lang/python: 2.7.10::gentoo, 3.4.3::gentoo, 3.5.0-r1::gentoo
dev-util/cmake: 3.3.2-r1::gentoo
dev-util/pkgconfig: 0.29::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.18.3::gentoo
sys-apps/sandbox: 2.9::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake: 1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 4.9.3::gentoo
sys-devel/gcc-config: 1.8::gentoo
sys-devel/libtool: 2.4.6-r1::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.2::gentoo (virtual/os-headers)
sys-libs/glibc: 2.22-r1::gentoo
Repositories:

gentoo
location: /usr/portage
sync-type: rsync
sync-uri: rsync://rsync.gentoo.org/gentoo-portage
priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.rit.edu/gentoo/ http://mirror.lug.udel.edu/pub/gentoo/"
LANG="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 apm avahi berkdb boost bzip2 cairo cdda cdr cli consolekit corefonts cracklib crypt cups cxx dbus declarative desktopglobe dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac flash foomaticdb fortran fpm gd gdbm gif git glamor gles2 gnome-keyring gpm gtk hddtemp hpcups iconv icu imaging ipv6 jpeg kde kdenlive kipi lcms ldap libnotify lm_sensors mad mdnsresponder-compat melt mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nfs nls nptl ntp ogg opengl openmp pam pango pcre pcre16 pdf phonon plasma png policykit ppds python qml qt3support qt5 readline scanner sdl seccomp semantic-desktop session snmp soap spell sqlite sse sse2 ssl startup-notification svg symlink tcpd theora tiff truetype udev udisks unicode upower usb vnc vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xrandr xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset: CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


I'm going to try it on a more stable KDE system in my basement. Oddly, I've also been having trouble installing in on a Debian Wheezy system
_________________
Casey Bralla
Chief Nerd in Residence
The NerdWorld Organisation
Back to top
View user's profile Send private message
genoobish
n00b
n00b


Joined: 18 Feb 2015
Posts: 73

PostPosted: Sat Oct 31, 2015 6:32 pm    Post subject: Reply with quote

My working system is also ~64arch
https://bpaste.net/show/ce5f2bb0b99e

Im installing the same version on the pi now to see if that helps... anyways, I don't know what this driver is for. it scans fine at 600 dpi(the max my poor scanner does) using sane over the network. (and I didnt' try to figure it out after installing it.. is it really worth the trouble?).
Back to top
View user's profile Send private message
genoobish
n00b
n00b


Joined: 18 Feb 2015
Posts: 73

PostPosted: Sun Nov 01, 2015 2:16 pm    Post subject: Reply with quote

Code:
monkey@banana ~ $ hp-plugin

HP Linux Imaging and Printing System (ver. 3.14.10)
Plugin Download and Install Utility ver. 2.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: PolicyKit support requires DBUS or PolicyKit support files missing
error: You must be root to run this utility.

ok.. so now it started giving some good error message. it seems it wants dbus active also, which I dont have on that install. https://bpaste.net/show/03c8d0a9aab5

edit: does yours say some other error message or just the fail root password?

Edit2: pastebin the output of `hp-check` - it will make a complete "health inspection" on your install. this one from the "non-working" setup https://bpaste.net/show/9c5a526c0ad0 ; and this one is fromt the working setup: https://bpaste.net/show/b7edc1385d3e
compairing them could give us some answers...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum