Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201510-06 ] Django
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Sat Oct 31, 2015 7:26 pm    Post subject: [ GLSA 201510-06 ] Django Reply with quote

Gentoo Linux Security Advisory

Title: Django: Multiple vulnerabilities (GLSA 201510-06)
Severity: normal
Exploitable: remote
Date: October 31, 2015
Bug(s): #554864
ID: 201510-06

Synopsis

Multiple vulnerabilities have been found in Django, the worst of
which may allow a remote attacker to cause Denial of Service.


Background

Django is a Python-based web framework.

Affected Packages

Package: dev-python/django
Vulnerable: < 1.8.3
Unaffected: >= 1.8.3
Unaffected: >= 1.7.9 < 1.7.10
Unaffected: >= 1.4.21 < 1.4.22
Architectures: All supported architectures


Description

Multiple vulnerabilities have been found in Django:
  • Session backends create a new record anytime request.session was
    accessed (CVE-2015-5143)
  • Built-in validators in Django do not properly sanitize input
    (CVE-2015-5144)
  • URL validation included a regular expression that was extremely slow
    (CVE-2015-5145)


Impact

A remote attacker may be able cause a Denial of Service condition,
inject arbitrary headers, and conduct HTTP response splitting attacks.


Workaround

There is no known workaround at this time.

Resolution

All Django 1.8 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-python/django-1.8.3"
   
All Django 1.7 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-python/django-1.7.9"
   
All Django 1.4 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-python/django-1.4.21"
   


References

CVE-2015-5143
CVE-2015-5144
CVE-2015-5145
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum