Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Kernel panic due to wl (broadcom-sta)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
AaylaSecura
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2011
Posts: 122

PostPosted: Wed Nov 04, 2015 12:45 am    Post subject: [SOLVED] Kernel panic due to wl (broadcom-sta) Reply with quote

Greetings! I'm having a strange issue - two days ago I installed a few updates (nothing important - xorg-server, sudo and a few others, I can get a list of them later, forgot to do it). The next day when I started the PC and issued startx the system just froze and I had to hard reset it. Afterwards the kernel kept panicking 1-2 seconds after the default runlevel was finished loading. At first I thought it may have been some file corruption due to me not cleanly shutting it down, so I:
* ran e2fsck -fc <device> - was fine
* rebuilt all system packages via emerge -e @system
* removed and reinstalled the kernel sources and rebuilt the kernel image, reinstalled all modules
nothing changed. I then created a minimal runlevel which only had sshd and syslog-ng started and it booted fine. I started each of the other services one by one and the very last one I started, dropbox, printed some PAM related error, which I could not fully read before the kernel panicked. This PAM error was not reproducible, however, the kernel always panics when dropbox is started. I rebuilt dropbox and also reverted all upgrades done two days ago. At this point everything should have been as it was 2 days ago but the problem remained. I wanted to investigate the PAM error a bit more, so I
* tried su-ing - oddly enough one time it made the kernel panic, another time it did not... su-ing from within a chrooted environment is not a problem
* tried ssh-ing into the system and although I have UsePAM no in sshd_config it paniced again
I am out of ideas as to how to "debug" this further... Any help greatly appreciated.

P.S. It's ~amd64 system, kernel version is 4.2.5 (4.3.0 does not work with the proprietry nvidia drivers, but I can nevertheless try later to see if it will panic when ssh-ing, starting dropbox, etc)


Last edited by AaylaSecura on Wed Nov 04, 2015 12:47 pm; edited 3 times in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13867

PostPosted: Wed Nov 04, 2015 2:26 am    Post subject: Reply with quote

Please post the output from the kernel panic. You mention that you cannot use 4.3 with the nVidia drivers, which suggests that you are loading out-of-tree proprietary modules. Please try to reproduce the panic with an untainted kernel.
Back to top
View user's profile Send private message
AaylaSecura
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2011
Posts: 122

PostPosted: Wed Nov 04, 2015 3:49 am    Post subject: Reply with quote

Hu wrote:
Please post the output from the kernel panic. You mention that you cannot use 4.3 with the nVidia drivers, which suggests that you are loading out-of-tree proprietary modules. Please try to reproduce the panic with an untainted kernel.

Hi and thanks for replying. I don't really know how to log a kernel panic (otherwise I'd done it)... How do I obtain a full log of it?

The only external modules that I use are the nvidia module which is not loaded until Xorg starts (hence it was not loaded during any of the times the kernel panicked) and wl provided by broadcom-sta. This one is loaded automatically - I'll try to disable it and see what happens.

Edit: would dmesg -w > <some-file> work?
Back to top
View user's profile Send private message
AaylaSecura
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2011
Posts: 122

PostPosted: Wed Nov 04, 2015 9:51 am    Post subject: Reply with quote

You were right about the tainted kernel! So I did a few tests and bottom line: ssh-ing from within the system (localhost) works fine but once I load the wl module and ssh into it from another device (or I assume do any network related task, since starting dropbox panics it too) it panics.
For now I've blacklisted the wl module and I can start Xorg just fine. In fact I just re-emerged the latest nvidia drivers for the latest kernel version - that used to fail during configure phase with an "invalid kernel configuration" but now it compiled fine and I am using kernel 4.3 with the latest nvidia drivers. Loading wl ssh-ing still crashes the system under 4.3 as well.
I did dmesg -w > log in the background but the log stops at:
Code:
[  210.554187] wl: no symbol version for module_layout
[  291.601831] wl: module license 'Mixed/Proprietary' taints kernel.
[  291.601833] Disabling lock debugging due to kernel taint
[  291.604792] systemd-udevd[332]: Network interface NamePolicy= disabled on kernel command line, ignoring.
[  291.628118] systemd-udevd[4035]: Process 'net.sh wlan0 start' failed with exit code 1.
[  291.669604] wlan0: Broadcom BCM43b1 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)

which is the output from loading wl, i.e. not what happens right before the panic.

The question remains, what changed in those two days, broadcom-sta was not updated, so I wouldn't expect re-emerging it to affect the module... At this point I can't have networking...

EDIT: I just synced the tree and saw there is a new revision of broadcom-sta which removes the application of broadcom-sta-6.30.223.271-r1-linux-3.18.patch and now ALL IS FINE. The thing two days ago during those updates, broadcom-sta was also updated and this is what had caused all of this, but I missed the fact it was updated since I did not expect it to be the root of the problem. Thanks for the help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum