Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] nano & alsamixer in qterminal?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Nov 05, 2015 8:05 am    Post subject: [gelöst] nano & alsamixer in qterminal? Reply with quote

Hallo zusammen,

ich kann seit einigen Tagen nano und alsamixer nicht mehr in qterminal mit der tastatur bedienen. Die Tastenanschläge bleiben enfach wirkungslos.

Login-Shell/Standardshell ist zsh. Da das bisher einfach immer funktioniert hat, habe ich momentan überhaupt keine Idee, wo ich suchen soll...

Code:
~/ eix zsh
[I] app-doc/zsh-lovers
     Available versions:  0.9.0
     Installed versions:  0.9.0(21:23:56 23.02.2015)
     Homepage:            http://grml.org/zsh/zsh-lovers.html
     Description:         Tips, tricks and examples for the Z shell

[I] app-shells/gentoo-zsh-completions
     Available versions:  20141115 ~20150103 **99999999
     Installed versions:  20141115(21:24:02 23.02.2015)
     Homepage:            https://github.com/radhermit/gentoo-zsh-completions
     Description:         Gentoo specific zsh completion support (includes emerge and ebuild commands)

[?] app-shells/rust-zshcomp
     Available versions:  ~1_beta20150411
     Installed versions:  1.0.0_alpha(21:24:11 23.02.2015)
     Homepage:            http://www.rust-lang.org/
     Description:         Rust zsh completions

[I] app-shells/zsh
     Available versions:  5.0.5 ~5.0.7-r1 ~5.0.7-r2 ~5.0.8 ~5.1.1 **9999 {caps debug doc examples gdbm maildir pcre static unicode}
     Installed versions:  5.0.5(21:23:41 23.02.2015)(gdbm pcre unicode -caps -debug -doc -examples -maildir -static)
     Homepage:            http://www.zsh.org/
     Description:         UNIX Shell similar to the Korn shell

[I] app-shells/zsh-completions
     Available versions:  (~)0.12.0-r2 **9999
     Installed versions:  0.12.0-r2(22:10:29 02.08.2015)
     Homepage:            https://github.com/zsh-users/zsh-completions
     Description:         Additional completion definitions for Zsh

Code:
~/ eix qterminal
[I] x11-terms/qterminal
     Available versions:  ~0.4.0 (~)0.5.0_p20140913 ~0.6.0 **9999[1] {debug qt4 qt5}
     Installed versions:  0.5.0_p20140913(18:41:34 26.12.2014)(-debug)
     Homepage:            https://github.com/qterminal/qterminal
     Description:         Qt-based multitab terminal emulator

[1] "qt" /var/lib/layman/qt

Code:
eix -I nano
[I] app-editors/nano
     Available versions:  2.3.6 ~2.4.0 ~2.4.1 ~2.4.2 **9999 {debug justify +magic minimal ncurses nls slang +spell static unicode}                         
     Installed versions:  2.3.6(21:16:40 02.11.2015)(magic ncurses nls spell unicode -debug -justify -minimal -slang)                                       
     Homepage:            http://www.nano-editor.org/ https://www.gentoo.org/doc/en/nano-basics-guide.xml                                                   
     Description:         GNU GPL'd Pico clone with more functionality


uhai

PS: Alsamixer vergisst auch immer die Soundkarte/Eisntellungen und muss nach jedem Neustart wieder manuell konfiguriert werden....
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Mon Dec 28, 2015 12:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Dec 13, 2015 1:43 pm    Post subject: Reply with quote

Hat jemand eine Idee?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sat Dec 26, 2015 3:03 pm    Post subject: Reply with quote

uhai wrote:
PS: Alsamixer vergisst auch immer die Soundkarte/Eisntellungen und muss nach jedem Neustart wieder manuell konfiguriert werden....

Hi :)

Zum abspeichern beim herunterfahren, und wiederherstellen beim boot gibt es im media-sound/alsa-utils Paket Werkzeuge/Hilfsmittel die sich darum kümmern können.
Schau dazu zb im https://wiki.gentoo.org/wiki/ALSA#Service
(für systemd ist auch ein alsa-restore.service mit dabei)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sat Dec 26, 2015 5:45 pm    Post subject: Reply with quote

Hallo Josef.95,

das habe ich heute bevor unser Besuch eintraf gerade entdeckt.

Code:
# systemctl -all --full |grep alsa     
  alsa-restore.service                                                                                                               loaded    inactive dead      Restore Sound Card State
  alsa-state.service                                                                                                                 loaded    inactive dead      Manage Sound Card State (restore and store)
  alsa-store.service                                                                                                                 loaded    inactive dead      Store Sound Card State


Allerdings habe ich noch nicht herausbekommen, warum das inactive & dead ist....

Interessant wäre auch, warum in qterminal die Tastaturbedienung für alsamixer und nano nicht funktioniert. in xterm geht es....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Dec 27, 2015 9:01 am    Post subject: Reply with quote

Hm ja, das nicht mehr funktionierende qterminal kann ich hier mit alsamixer reproduzieren wenn
die ältere =qterminal-0.5.0_p20140913 Version installiert ist (was laut deiner eix Ausgabe der Fall ist), und dann im nachhinein x11-libs/qtermwidget mit USE=qt5 statt mit USE=qt4 gebaut wurde. (ja, das sollte normal gar nicht möglich sein, und ggf im qterminal-0.5.0_p20140913.ebuild angepasst werden).
Ist das bei dir eventuell der Fall? Magst mal die Ausgabe von
Code:
eix -I qterm
dazu posten?
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Dec 27, 2015 11:08 am    Post subject: Reply with quote

Gerne:

Code:
~/ eix -I qterm
[I] x11-libs/qtermwidget
     Available versions:  ~0.4.0 (~)0.4.0.37 0.6.0 **9999[1] {debug qt4 qt5}
     Installed versions:  0.6.0(07:23:13 20.10.2015)(qt5 -debug -qt4)
     Homepage:            https://github.com/qterminal/qtermwidget
     Description:         Qt terminal emulator widget

[I] x11-terms/qterminal
     Available versions:  ~0.4.0 (~)0.5.0_p20140913 ~0.6.0 **9999[1] {debug qt4 qt5}
     Installed versions:  0.5.0_p20140913(18:41:34 26.12.2014)(-debug)
     Homepage:            https://github.com/qterminal/qterminal
     Description:         Qt-based multitab terminal emulator

[1] "qt" /var/lib/layman/qt



uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Sun Dec 27, 2015 12:43 pm    Post subject: Reply with quote

Jup, Volltreffer :)

Vorschlag: Da du nun schon x11-libs/qtermwidget mit USE=qt5 installiert hast, würde ich vorschlagen die aktuelle x11-terms/qterminal-0.6.0 Version mit USE="-qt4 qt5" zu bauen - dann sollte es wahrscheinlich wieder wie gewünscht funktionieren :)
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Sun Dec 27, 2015 8:39 pm    Post subject: Reply with quote

Danke Josegf.95, das hat geklappt. Qterminal-0.6.0 installiert und alsamixer lässt isch wieder bedienen...

Bleibt die Frage, warum die alsa-services beim booten nicht funktionieren...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum