Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Frage(n) zu etc-update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
SarahS93
Guru
Guru


Joined: 21 Nov 2013
Posts: 468

PostPosted: Wed Nov 11, 2015 10:11 am    Post subject: Frage(n) zu etc-update Reply with quote

etc-update
Code:
Scanning Configuration files...
The following is the list of files which need updating, each
configuration file is followed by a list of possible replacement files.
1) /etc/portage/package.use/iputils (1)
Please select a file to edit by entering the corresponding number.
              (don't use -3, -5, -7 or -9 if you're unsure what to do)
              (-1 to exit) (-3 to auto merge all files)
                           (-5 to auto-merge AND not use 'mv -i')
                           (-7 to discard all updates)
                           (-9 to discard all updates AND not use 'rm -i'):




1 druecken um "1) /etc/portage/package.use/iputils" auszuwaehlen


dann sehe ich dort


Code:
Showing differences between /etc/portage/package.use/iputils and /etc/portage/package.use/._cfg0000_iputils
--- /etc/portage/package.use/iputils    2015-02-22 19:06:59.312032760 +0100
+++ /etc/portage/package.use/._cfg0000_iputils  2015-11-11 10:52:33.549512020 +0100
@@ -1 +1,76 @@
 net-misc/iputils -caps -filecaps
+# required by x11-libs/libxcb-1.11-r1::gentoo
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-libs/libXdmcp-1.1.1-r1 abi_x86_32
+# required by x11-libs/libxcb-1.11-r1::gentoo
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-libs/libXau-1.0.8 abi_x86_32
+# required by x11-libs/libxcb-1.11-r1::gentoo
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/xcb-proto-1.11 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-libs/libXext-1.3.3 abi_x86_32
+# required by x11-libs/libxcb-1.11-r1::gentoo
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=dev-libs/libpthread-stubs-0.3-r1 abi_x86_32
+# required by x11-libs/libXext-1.3.3::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-libs/libX11-1.6.2 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/inputproto-2.3.1 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/xproto-7.0.27 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-libs/libxcb-1.11-r1 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/xextproto-7.3.0 abi_x86_32
+# required by x11-libs/libX11-1.6.2::gentoo
+# required by x11-drivers/nvidia-drivers-355.11-r2::gentoo[X,multilib]
+# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
+# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
+# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
+>=x11-proto/kbproto-1.0.6-r1 abi_x86_32


Mit "q" verlasse ich diese ansicht wieder, auf dem Bildschirm erscheint dann:


Code:
File: /etc/portage/package.use/._cfg0000_iputils
1) Replace original with update
2) Delete update, keeping original as is
3) Interactively merge original with update
4) Show differences again
5) Save update as example config
Please select from the menu above (-1 to ignore this update):


1 ist klar, vorhandene Datei (Original) durch die neue Datei ersetzen.
2 ist auch klar, neue Datei (Update) verwerfen, alte Datei so belassen wie sie ist.
3 vorhandene Datei (Original) mit der neuen (Update) Datei vermischen.
4 erneut betrachten.
5 neue Ddatei als beispieldatei abspeichern.


Bei Punkt 3 kriege ich es nicht hin die beiden zusammenzufügen
Es endet immer so das dass aus dem Update nicht mit übernommen wird.
Wähle ich hingegen 1, funktioniert es - was mache ich verkehrt, oder ist das normal bei etc-update?
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 197
Location: Wien

PostPosted: Thu Nov 12, 2015 10:28 am    Post subject: Reply with quote

Bin kein Experte für Gentoo und kann Dir nur folgenden Rat geben:
falls Du irgendeine Datei die unter etc-update aufgelistet wird,
bewusst manuell geändert hast und die Änderung auch beibehalten möchtest,
dann wähle
Code:
2) Delete update, keeping original as is

ansonst würde ich ohne Bedenken
Code:
1) Replace original with update

ausführen. Bin damit immer gut gefahren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum