Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Modern Thinkpad and lm_sensors - safe?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3383

PostPosted: Sun Nov 15, 2015 8:32 pm    Post subject: Modern Thinkpad and lm_sensors - safe? Reply with quote

Years back, running lm_sensors was a surefire way to brick your Thinkpad. I get the impression that that is no longer the case, but have no idea when that became true.

I've had a new T440P since this summer, but haven't taken the time to turn it into a real laptop yet. It's been a portable desktop so far, with very little time on battery. I'm sitting down to change that now, laptop-ify it, and make it generally more useful.

It would be handy to have gkrellm / lm_sensors, but I'm cautious about that latter package. Non-functional software is one thing, bricking the hardware is another.

Is it safe?
Any more info / history? (So far I haven't found it, just references that it has apparently become safe, some time in the last decade.)
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Sun Nov 15, 2015 9:34 pm    Post subject: Reply with quote

Quote:
Years back, running lm_sensors was a surefire way to brick your Thinkpad. I get the impression that that is no longer the case, but have no idea when that became true.


glad I didn't know that :)

lm_sensors ran without any problem on my T440S

here's sample output of the detected sensors:


Quote:
sensors
acpitz-virtual-0
Adapter: Virtual device
temp1: +34.0°C (crit = +200.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +35.0°C (high = +100.0°C, crit = +100.0°C)
Core 0: +34.0°C (high = +100.0°C, crit = +100.0°C)
Core 1: +33.0°C (high = +100.0°C, crit = +100.0°C)

thinkpad-isa-0000
Adapter: ISA adapter
fan1: 0 RPM

_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
nictki
n00b
n00b


Joined: 10 Jan 2007
Posts: 63
Location: somewhere else...

PostPosted: Mon Nov 16, 2015 1:02 pm    Post subject: Reply with quote

W530 here since few years and no problems noticed.
_________________
github
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum