Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compile for older webkit fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Tue Nov 17, 2015 2:10 am    Post subject: Compile for older webkit fails Reply with quote

I need an older webkit for an audio-related ebuild. I managed to scrounge up patches for this webkit and get those out of the way, but it still fails:

Code:

[ebuild  NS    ] net-libs/webkit-gtk-1.2.7:2::LocalOverlay [2.8.5:4/37::gentoo] USE="gstreamer jit (-aqua) -coverage -debug -doc -introspection {-test}" 0 KiB

Total: 1 package (1 in new slot), Size of downloads: 0 KiB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) net-libs/webkit-gtk-1.2.7::LocalOverlay
 * webkit-1.2.7.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                     [ ok ]
>>> Unpacking source...
>>> Unpacking webkit-1.2.7.tar.gz to /var/tmp/portage/net-libs/webkit-gtk-1.2.7/work
>>> Source unpacked in /var/tmp/portage/net-libs/webkit-gtk-1.2.7/work
>>> Preparing source in /var/tmp/portage/net-libs/webkit-gtk-1.2.7/work/webkit-1.2.7 ...
 * Applying webkit-gtk-1.2.5-darwin8.patch ...                                                                                  [ ok ]
 * Applying webkit-gtk-1.2.5-tests-build.patch ...                                                                              [ ok ]
 * Applying webkit-gtk-1.2.7-libpng15.patch ...                                                                                 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-libs/webkit-gtk-1.2.7/work/webkit-1.2.7' ...
 * Skipping 'gtkdocize --copy' due gtkdocize not installed
 * Running libtoolize --install --copy --force --automake ...                                                                   [ ok ]
 * Running aclocal -I autotools ...                                                                                             [ ok ]
 * Running autoconf -I autotools --force ...                                                                                    [ ok ]
 * Running autoheader -I autotools ...                                                                                          [ ok ]
 * Running automake --add-missing --copy --foreign --force-missing ...                                                          [ ok ]
 * Running elibtoolize in: webkit-1.2.7/
 * Running elibtoolize in: webkit-1.2.7/autotools/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.3 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/net-libs/webkit-gtk-1.2.7/work/webkit-1.2.7 ...
 * econf: updating webkit-1.2.7/autotools/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating webkit-1.2.7/autotools/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --disable-introspection --disable-web_sockets --disable-coverage --disable-debug --enable-video --disable-introspection --enable-jit
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for a BSD-compatible install... /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether UID '250' is supported by ustar format... yes
checking whether GID '250' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
checking whether make supports nested variables... (cached) yes
checking for native Win32... no
checking for style of include used by make... GNU
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking whether x86_64-pc-linux-gnu-gcc understands -c and -o together... yes
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for x86_64-pc-linux-gnu-g++... x86_64-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether x86_64-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of x86_64-pc-linux-gnu-g++... gcc3
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking if x86_64-pc-linux-gnu-g++ supports -fvisibility=hidden -fvisibility-inlines-hidden... yes
checking for pkg-config... /usr/bin/pkg-config
checking for perl... /usr/bin/perl
checking for bison... /usr/bin/bison
checking for mv... /bin/mv
checking for x86_64-pc-linux-gnu-gcc... (cached) x86_64-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... (cached) none needed
checking whether x86_64-pc-linux-gnu-gcc understands -c and -o together... (cached) yes
checking dependency style of x86_64-pc-linux-gnu-gcc... (cached) gcc3
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking for working volatile... yes
checking for stdbool.h that conforms to C99... yes
checking for _Bool... yes
checking how to print strings... printf
checking for a sed that does not truncate output... /bin/sed
checking for fgrep... /bin/grep -F
checking for ld used by x86_64-pc-linux-gnu-gcc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/x86_64-pc-linux-gnu-nm -B
checking the name lister (/usr/bin/x86_64-pc-linux-gnu-nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... 1572864
checking how to convert x86_64-pc-linux-gnu file names to x86_64-pc-linux-gnu format... func_convert_file_noop
checking how to convert x86_64-pc-linux-gnu file names to toolchain format... func_convert_file_noop
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for x86_64-pc-linux-gnu-objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for x86_64-pc-linux-gnu-dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for x86_64-pc-linux-gnu-ar... x86_64-pc-linux-gnu-ar
checking for archiver @FILE support... @
checking for x86_64-pc-linux-gnu-strip... x86_64-pc-linux-gnu-strip
checking for x86_64-pc-linux-gnu-ranlib... x86_64-pc-linux-gnu-ranlib
checking command to parse /usr/bin/x86_64-pc-linux-gnu-nm -B output from x86_64-pc-linux-gnu-gcc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for x86_64-pc-linux-gnu-mt... no
checking for mt... no
checking if : is a manifest tool... no
checking for dlfcn.h... yes
checking for objdir... .libs
checking if x86_64-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for x86_64-pc-linux-gnu-gcc option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-gcc PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-gcc static flag -static works... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-gcc supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-gcc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking how to run the C++ preprocessor... x86_64-pc-linux-gnu-g++ -E
checking for ld used by x86_64-pc-linux-gnu-g++... /usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) is GNU ld... yes
checking whether the x86_64-pc-linux-gnu-g++ linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking for x86_64-pc-linux-gnu-g++ option to produce PIC... -fPIC -DPIC
checking if x86_64-pc-linux-gnu-g++ PIC flag -fPIC -DPIC works... yes
checking if x86_64-pc-linux-gnu-g++ static flag -static works... yes
checking if x86_64-pc-linux-gnu-g++ supports -c -o file.o... yes
checking if x86_64-pc-linux-gnu-g++ supports -c -o file.o... (cached) yes
checking whether the x86_64-pc-linux-gnu-g++ linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for bash... /bin/bash
checking if dolt supports this host... yes, replacing libtool
checking for flex... /usr/bin/flex
checking for gawk... (cached) gawk
checking for gperf... /usr/bin/gperf
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking for jpeg_destroy_decompress in -ljpeg... yes
checking for jpeglib... yes
checking for libpng... yes
checking the target windowing system... x11
checking for Hildon UI extensions... no
checking for GLIB... yes
checking for glib-genmarshal... /usr/bin/glib-genmarshal
checking for glib-mkenums... /usr/bin/glib-mkenums
checking which Unicode backend to use... icu
checking for icu-config... /usr/bin/icu-config
checking for LIBXML... yes
checking for PANGO... yes
checking for ENCHANT... yes
checking for GAIL... yes
checking for CAIRO... yes
checking for GTK... yes
checking for XT... yes
checking whether to do a debug build... no
checking whether to enable optimized builds... yes
checking whether to enable support for 3D Transforms... no
checking whether to enable HTML5 Channel Messaging support... yes
checking whether to enable JavaScript debugger/profiler support... yes
checking whether to enable HTML5 offline web applications support... yes
checking whether to enable HTML5 client-side session and persistent storage support... yes
checking whether to enable the indexed database API... no
checking whether to enable HTML5 client-side database storage support... yes
checking whether to enable HTML5 server-sent events support... yes
checking whether to enable icon database support... yes
checking whether to enable HTML5 datalist support... yes
checking whether to enable HTML5 ruby support... yes
checking whether to enable HTML5 sandboxed iframe support...
checking whether to enable HTML5 video support... yes
checking whether to enable XHTML-MP support... no
checking whether to enable XPath support... yes
checking whether to enable XSLT support... yes
checking whether to enable geolocation support... no
checking whether to enable MathML support... no
checking whether to enable SVG support... yes
checking whether to enable WML support... no
checking whether to enable SharedWorkers support... yes
checking whether to enable Web Workers support... yes
checking whether to enable support for SVG animation... yes
checking whether to enable support for filters... yes
checking whether to enable support for SVG fonts... yes
checking whether to enable support for SVG foreign objects... yes
checking whether to enable SVG as Image support... yes
checking whether to enable support for SVG use element... yes
checking whether to enable Web Sockets support... no
checking whether to enable Blob.slice support... no
checking whether to enable Fast Mobile Scrolling... no
checking whether to enable code coverage support... no
checking whether to enable optimized memory allocator... yes
checking whether to enable JIT compilation... yes
checking whether to enable GObject introspection support... no
checking the font backend to use... freetype
checking for LIBSOUP... yes
checking for LIBSOUP_2_29_90... yes
checking for FREETYPE... yes
checking for SQLITE3... yes
checking for LIBXSLT... yes
checking for GSTREAMER... yes
checking for gtkdoc-check... no
checking for gtkdoc-rebase... /usr/bin/gtkdoc-rebase
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating GNUmakefile
config.status: creating WebKit/gtk/webkit-1.0.pc
config.status: creating WebKit/gtk/webkit/webkitversion.h
config.status: creating WebKit/gtk/docs/GNUmakefile
config.status: creating WebKit/gtk/docs/version.xml
config.status: creating autotoolsconfig.h
config.status: executing depfiles commands
config.status: executing libtool commands

WebKit was configured with the following options:

Build configuration:
 Enable debugging (slow)                                  : no
 Enable GCC build optimization                            : yes
 Code coverage support                                    : no
 Unicode backend                                          : icu
 Font backend                                             : freetype
 Optimized memory allocator                               : yes
Features:
 3D Transforms                                            : no
 Blob.slice support                                       : no
 Fast Mobile Scrolling                                    : no
 JIT compilation                                          : yes
 Filters support                                          : yes
 Geolocation support                                      : no
 JavaScript debugger/profiler support                     : yes
 MathML support                                           : no
 HTML5 offline web applications support                   : yes
 HTML5 channel messaging support                          : yes
 HTML5 client-side session and persistent storage support : yes
 HTML5 client-side database storage support               : yes
 HTML5 ruby support                                       : yes
 HTML5 sandboxed iframe support                           :
 HTML5 server-sent events support                         : yes
 HTML5 video element support                              : yes
 Icon database support                                    : yes
 SharedWorkers support                                    : yes
 SVG support                                              : yes
 SVG animation support                                    : yes
 SVG fonts support                                        : yes
 SVG foreign object support                               : yes
 SVG as image support                                     : yes
 SVG use element support                                  : yes
 WML support                                              : no
 Web Sockets support                                      : no
 Web Workers support                                      : yes
 XHTML-MP support                                         : no
 XPATH support                                            : yes
 XSLT support                                             : yes
GTK+ configuration:
 GDK target                                               : x11
 Hildon UI extensions                                     : no
 Introspection support                                    : no

>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-libs/webkit-gtk-1.2.7/work/webkit-1.2.7 ...
make -j6 -j1 XDG_DATA_HOME=/var/tmp/portage/net-libs/webkit-gtk-1.2.7/temp/.local
  GEN      stamp-webkitenumtypes.h
/usr/bin/bison -d -p jscyy ./JavaScriptCore/parser/Grammar.y -o DerivedSources/Grammar.cpp > bison_out.txt 2>&1
/usr/bin/perl -p -e 'END { if ($conflict) { unlink "Grammar.cpp"; die; } } $conflict ||= /conflict/' < bison_out.txt
cat ./DerivedSources/Grammar.hpp > ./DerivedSources/Grammar.h
rm -f ./DerivedSources/Grammar.hpp bison_out.txt
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/parser/Keywords.table > DerivedSources/Lexer.lut.h
Creating hashtable for JavaScriptCore/parser/Keywords.table
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/ArrayPrototype.cpp -i > JavaScriptCore/runtime/ArrayPrototype.lut.h
Creating hashtable for JavaScriptCore/runtime/ArrayPrototype.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/DatePrototype.cpp -i > JavaScriptCore/runtime/DatePrototype.lut.h
Creating hashtable for JavaScriptCore/runtime/DatePrototype.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/JSONObject.cpp -i > JavaScriptCore/runtime/JSONObject.lut.h
Creating hashtable for JavaScriptCore/runtime/JSONObject.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/MathObject.cpp -i > JavaScriptCore/runtime/MathObject.lut.h
Creating hashtable for JavaScriptCore/runtime/MathObject.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/NumberConstructor.cpp -i > JavaScriptCore/runtime/NumberConstructor.lut.h
Creating hashtable for JavaScriptCore/runtime/NumberConstructor.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/RegExpConstructor.cpp -i > JavaScriptCore/runtime/RegExpConstructor.lut.h
Creating hashtable for JavaScriptCore/runtime/RegExpConstructor.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/RegExpObject.cpp -i > JavaScriptCore/runtime/RegExpObject.lut.h
Creating hashtable for JavaScriptCore/runtime/RegExpObject.cpp
/usr/bin/perl JavaScriptCore/create_hash_table JavaScriptCore/runtime/StringPrototype.cpp -i > JavaScriptCore/runtime/StringPrototype.lut.h
Creating hashtable for JavaScriptCore/runtime/StringPrototype.cpp
/usr/bin/perl JavaScriptCore/pcre/dftables JavaScriptCore/pcre/chartables.c
rm -f ./DerivedSources/CSSGrammar.cpp.h ./DerivedSources/CSSGrammar.hpp
/usr/bin/bison -d -p cssyy WebCore/css/CSSGrammar.y -o ./DerivedSources/CSSGrammar.cpp
touch ./DerivedSources/CSSGrammar.cpp.h ./DerivedSources/CSSGrammar.hpp
echo '#ifndef CSSGrammar_h' > ./DerivedSources/CSSGrammar.h
echo '#define CSSGrammar_h' >> ./DerivedSources/CSSGrammar.h
cat ./DerivedSources/CSSGrammar.cpp.h ./DerivedSources/CSSGrammar.hpp >> ./DerivedSources/CSSGrammar.h
echo '#endif' >> ./DerivedSources/CSSGrammar.h
rm -f ./DerivedSources/CSSGrammar.cpp.h ./DerivedSources/CSSGrammar.hpp
if sort ./WebCore/css/CSSPropertyNames.in ./WebCore/css/SVGCSSPropertyNames.in  | uniq -d | grep -E '^[^#]'; then echo 'Duplicate value!'; exit 1; fi
cat ./WebCore/css/CSSPropertyNames.in ./WebCore/css/SVGCSSPropertyNames.in  > CSSPropertyNames.in
/usr/bin/perl "./WebCore/css/makeprop.pl"
mv CSSPropertyNames.* ./DerivedSources
/usr/bin/perl -ne 'print lc' ./WebCore/css/CSSValueKeywords.in ./WebCore/css/SVGCSSValueKeywords.in > CSSValueKeywords.in
if sort CSSValueKeywords.in | uniq -d | grep -E '^[^#]'; then echo 'Duplicate value!'; exit 1; fi
/usr/bin/perl "./WebCore/css/makevalues.pl"
mv CSSValueKeywords.* ./DerivedSources
  GEN      DerivedSources/HTMLElementFactory.cpp
Can't locate Switch.pm in @INC (you may need to install the Switch module) (@INC contains: ./WebCore/bindings/scripts /etc/perl /usr/local/lib64/perl5/5.20.2/x86_64-linux /usr/local/lib64/perl5/5.20.2 /usr/lib64/perl5/vendor_perl/5.20.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.20.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.20.2/x86_64-linux /usr/lib64/perl5/5.20.2 .) at WebCore/dom/make_names.pl line 38.
BEGIN failed--compilation aborted at WebCore/dom/make_names.pl line 38.
GNUmakefile:28209: recipe for target 'DerivedSources/HTMLElementFactory.cpp' failed
make: *** [DerivedSources/HTMLElementFactory.cpp] Error 2
emake failed


I'm thinking maybe one of the options listed as "no"? If so, which one? If not, how can I fix this?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Tue Nov 17, 2015 10:00 am    Post subject: Reply with quote

Not sure how/why you want Web Workers without Web Sockets; afair the latter is needed for the former.

Though I'd expect the configure script to throw a hissy about it, too, so check with ##workingset
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Tue Nov 17, 2015 3:55 pm    Post subject: Reply with quote

I tried installing libwebsockets; this made no difference. Anyway, I don't know anything about web workers or web sockets, and I'm not sure that has anything to do with the fatal error. (But I wouldn't know that for sure!)

As an experiment, I also tried webkit-gtk-1.1.1, the earliest available 1.0 series, and it failed with "'DerivedSources/HTMLNames.cpp' failed". While not the same, it's similar. I'm wondering where HTMLNames and HTMLElementFactory come from in Portage.

(I don't need 1.2.7. The package I'm trying to install insists on 1.0, and I found in another post somewhere that 1.2.7 was the latest webkit that worked for this package.)
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43571
Location: 56N 3W

PostPosted: Tue Nov 17, 2015 8:27 pm    Post subject: Reply with quote

audiodef,

At face value
Code:
Can't locate Switch.pm in @INC (you may need to install the Switch module) (@INC contains:

That usually means you need to install dev-perl/Switch but it should really be installed as a dependency.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Tue Nov 17, 2015 10:10 pm    Post subject: Reply with quote

Hi Neddy,

Thanks for the suggestion. I installed Switch, but webkit-gtk-1.2.7 continues to fail with the same error.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Nov 20, 2015 2:08 pm    Post subject: Reply with quote

Mind telling us what that "package I'm trying to install" is, cause potentially you might just be misreading the deps.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Nov 20, 2015 2:39 pm    Post subject: Reply with quote

http://sourceforge.net/projects/guitarix/

0.33 doesn't require old webkit, all of a sudden 0.34 does. It's not the ebuild that requires it, but guitarix-0.34 itself. It complains that webkit-1.0 is missing.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri Nov 20, 2015 3:06 pm    Post subject: Reply with quote

audiodef wrote:
I tried installing libwebsockets; this made no difference. Anyway, I don't know anything about web workers or web sockets, and I'm not sure that has anything to do with the fatal error. (But I wouldn't know that for sure!)

No, I think you're right: it's the perl Switch thing. Might try #gentoo-perl on IRC. (newcomers: chat.freenode.net or .org.)

Though I'd check perl-cleaner --really-all -p first.

WRT websockets, you might come against it later; installing it makes no odds if it's been configured to No/disabled/without.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Nov 20, 2015 3:24 pm    Post subject: Reply with quote

But... I installed Switch and that made no difference. Did I miss something?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Nov 20, 2015 4:58 pm    Post subject: Reply with quote

So, anyway, guitarix uses that abomination called waf for a build system...

Yet in this particular case, it's not as obfuscated as it tends to be.
Going by the content of wscript file, slot 2 of in-tree webkit-gtk should meet the reqs.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7101

PostPosted: Sat Nov 21, 2015 9:45 am    Post subject: Reply with quote

audiodef wrote:
But... I installed Switch and that made no difference. Did I miss something?

Because you keep assuming you only need Switch install.

While the message is not telling you Switch is missing, it is only telling you it cannot find it (of course, when missing, it's logic it cannot find it, but even install, it may not find it if it doesn't look at the right place).

And you don't really need to guess the right place, as it gave you clue of its location
Code:
@INC contains: ./WebCore/bindings/scripts /etc/perl /usr/local/lib64/perl5/5.20.2/x86_64-linux /usr/local/lib64/perl5/5.20.2 /usr/lib64/perl5/vendor_perl/5.20.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.20.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.20.2/x86_64-linux /usr/lib64/perl5/5.20.2 .) at WebCore/dom/make_names.pl line 38.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum