Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Error emerging gentoo-sources
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 21 Nov 2015
Posts: 1

PostPosted: Sat Nov 21, 2015 7:10 pm    Post subject: [Solved] Error emerging gentoo-sources Reply with quote

I am unsure why this is failing. I just installed everything the exact same way (through the handbook) a few hours ago in a Virtual Machine and now I am installing on my desktop.

I started to download the kernel with emerge -av gentoo-sources

This is the output I get from the command


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-devel/bc-1.06.95-r1::gentoo  USE="readline -libedit -static" 284 KiB
[ebuild  N    ~] sys-kernel/gentoo-sources-4.3.0:4.3.0::gentoo  USE="-build -experimental -kdbus -symlink" 84,903 KiB

Total: 2 packages (2 new), Size of downloads: 85,187 KiB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 2) sys-devel/bc-1.06.95-r1::gentoo
 * Fetching files in the background. To view fetch progress, run
 * `tail -f /var/log/emerge-fetch.log` in another terminal.
 * bc-1.06.95.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...               [ ok ]
>>> Unpacking source...
>>> Unpacking bc-1.06.95.tar.bz2 to /var/tmp/portage/sys-devel/bc-1.06.95-r1/work
>>> Source unpacked in /var/tmp/portage/sys-devel/bc-1.06.95-r1/work
>>> Preparing source in /var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95 ...
 * Applying bc-1.06.95-void_uninitialized.patch ...                      [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95 ...
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64 --with-readline --without-libedit
checking for a BSD-compatible install... /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95/config.log
econf failed
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95 ...
make -j9 AR=x86_64-pc-linux-gnu-ar
make: *** No targets specified and no makefile found.  Stop.
emake failed
 * ERROR: sys-devel/bc-1.06.95-r1::gentoo failed (compile phase):
 *   (no error message)
 * Call stack:
 *, line  93:  Called src_compile
 *   environment, line 2223:  Called die
 * The specific snippet of code:
 *       emake AR="$(tc-getAR)" || die
 * If you need support, post the output of `emerge --info '=sys-devel/bc-1.06.95-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/bc-1.06.95-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/bc-1.06.95-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/bc-1.06.95-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95'
 * S: '/var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95'

>>> Failed to emerge sys-devel/bc-1.06.95-r1, Log file:

>>>  '/var/tmp/portage/sys-devel/bc-1.06.95-r1/temp/build.log'

 * Messages for package sys-devel/bc-1.06.95-r1:

 * ERROR: sys-devel/bc-1.06.95-r1::gentoo failed (compile phase):
 *   (no error message)
 * Call stack:
 *, line  93:  Called src_compile
 *   environment, line 2223:  Called die
 * The specific snippet of code:
 *       emake AR="$(tc-getAR)" || die
 * If you need support, post the output of `emerge --info '=sys-devel/bc-1.06.95-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/bc-1.06.95-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-devel/bc-1.06.95-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/bc-1.06.95-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95'
 * S: '/var/tmp/portage/sys-devel/bc-1.06.95-r1/work/bc-1.06.95'

As suggested by the error, here is the output of emerge --info '=sys-devel/bc-1.06.95-r1::gentoo'

Portage (python 2.7.10-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r1, 4.2.0-1-amd64 x86_64)
                         System Settings
System uname: Linux-4.2.0-1-amd64-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.2
KiB Mem:    16334924 total,  11085380 free
KiB Swap:    3939324 total,   3939324 free
Timestamp of repository gentoo: Sat, 21 Nov 2015 18:30:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p39::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000

CFLAGS="-O2 -march=bdver2 -mprefer-avx129 -mvzeroupper -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=bdver2 -mprefer-avx129 -mvzeroupper -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv jpeg lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl seccomp session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Thank you :-)

edit: Problem was with my cflags, I used avx129 instead of avx128 :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum