Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] gentoo-sources failed (unpack phase)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 23, 2015 11:30 am    Post subject: [SOLVED] gentoo-sources failed (unpack phase) Reply with quote

Hi,
I just wanted to update my system, when this error message poped up:

Code:
Calculating dependencies... done!
>>> Recording sys-kernel/gentoo-sources in "world" favorites file...

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-kernel/gentoo-sources-4.1.12::gentoo
 * linux-4.1.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                    [ ok ]
 * genpatches-4.1-16.base.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                       [ ok ]
 * genpatches-4.1-16.extras.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                     [ ok ]
>>> cfg-update-1.8.2-r1: Checksum index is up-to-date ...
>>> Preparing to unpack ...
>>> Unpacking source...
>>> Unpacking linux-4.1.tar.xz to /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work
>>> Unpacking genpatches-4.1-16.base.tar.xz to /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/patches
>>> Unpacking genpatches-4.1-16.extras.tar.xz to /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/patches
>>> Unpacking genpatches-4.1-16.experimental.tar.xz to /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/patches
 * ERROR: sys-kernel/gentoo-sources-4.1.12::gentoo failed (unpack phase):
 *   unpack: genpatches-4.1-16.experimental.tar.xz does not exist
 *
 * Call stack:
 *               ebuild.sh, line   93:  Called src_unpack
 *             environment, line 3553:  Called kernel-2_src_unpack
 *             environment, line 1936:  Called unipatch '  /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.base.tar.xz /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.extras.tar.xz /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.experimental.tar.xz '
 *             environment, line 4121:  Called unpack 'genpatches-4.1-16.experimental.tar.xz'
 *        phase-helpers.sh, line  304:  Called __helpers_die 'unpack: genpatches-4.1-16.experimental.tar.xz does not exist'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=sys-kernel/gentoo-sources-4.1.12::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/gentoo-sources-4.1.12::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/patches'
 * S: '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/linux-4.1.12-gentoo'

>>> Failed to emerge sys-kernel/gentoo-sources-4.1.12, Log file:

>>>  '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/temp/build.log'

 * Messages for package sys-kernel/gentoo-sources-4.1.12:

 * ERROR: sys-kernel/gentoo-sources-4.1.12::gentoo failed (unpack phase):
 *   unpack: genpatches-4.1-16.experimental.tar.xz does not exist
 *
 * Call stack:
 *               ebuild.sh, line   93:  Called src_unpack
 *             environment, line 3553:  Called kernel-2_src_unpack
 *             environment, line 1936:  Called unipatch '  /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.base.tar.xz /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.extras.tar.xz /var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/genpatches-4.1-16.experimental.tar.xz '
 *             environment, line 4121:  Called unpack 'genpatches-4.1-16.experimental.tar.xz'
 *        phase-helpers.sh, line  304:  Called __helpers_die 'unpack: genpatches-4.1-16.experimental.tar.xz does not exist'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=sys-kernel/gentoo-sources-4.1.12::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/gentoo-sources-4.1.12::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/patches'
 * S: '/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/work/linux-4.1.12-gentoo'


Any ideas?


Last edited by chi86 on Tue Nov 24, 2015 8:51 am; edited 1 time in total
Back to top
View user's profile Send private message
nickyim
n00b
n00b


Joined: 06 Feb 2015
Posts: 7

PostPosted: Mon Nov 23, 2015 12:04 pm    Post subject: Reply with quote

unpack: genpatches-4.1-16.experimental.tar.xz does not exist
maybe download fail, retry again?
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Mon Nov 23, 2015 12:27 pm    Post subject: Reply with quote

Same here. It's got nothing to do with failed download. When I look into portage/distfiles the file genpatches-experimental is missing and therefore can't be extracted to the work directories in /tmp.
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Mon Nov 23, 2015 12:40 pm    Post subject: Reply with quote

Same here. It's got nothing to do with failed download. When I look into portage/distfiles the file genpatches-experimental is missing and therefore can't be extracted to the work directories in /tmp.
Back to top
View user's profile Send private message
McGee23
n00b
n00b


Joined: 04 Nov 2013
Posts: 3

PostPosted: Mon Nov 23, 2015 12:47 pm    Post subject: Reply with quote

Hi,

have the same error too. I tried again, but there was no "genpatches-4.1.16.experimental.tar.xz" in "/usr/portage/distfiles" nor an error message regarding the download.
I downloaded the file from https://dev.gentoo.org/~mpagano/genpatches/tarballs/ but had no success, since it isn't copied to "/var/tmp/portage/sys-kernel/gentoo-sources-4.1.12/distdir/".

Within the ebuild-file I only found
Code:
K_DEBLOB_AVAILABLE="0"
IUSE="experimental"

instead of
Code:
K_DEBLOB_AVAILABLE="1"
IUSE="deblob experimental"

like in 4.0.9 but no differences that would explain the error.

Any hint?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2613

PostPosted: Mon Nov 23, 2015 12:59 pm    Post subject: Reply with quote

McGee23 wrote:
Any hint?

See bug 566600.
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 23, 2015 1:06 pm    Post subject: Reply with quote

charles17 wrote:
See bug 566600.

There it is said that : Reverting kernel-2.eclass fixes the issue

How do I do that?
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Mon Nov 23, 2015 1:36 pm    Post subject: Reply with quote

Same here. I'd like to know how to fix this

BTW it also happens on a fresh install (no additional kernels installed)
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon Nov 23, 2015 2:08 pm    Post subject: Reply with quote

chi86 wrote:
charles17 wrote:
See bug 566600.

There it is said that : Reverting kernel-2.eclass fixes the issue How do I do that?

chi86 ... given the eclass is part of the tree then you either wait for it to be fixed, or you fix it in an overlay ... so, as you have to ask I'd guess the later is not something you're familiar with and/or might struggle to 'revert' (meaning, tracking down the commit and reverting to its prior state).

best ... khay
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Nov 23, 2015 2:29 pm    Post subject: Reply with quote

khayyam wrote:
so, as you have to ask I'd guess the later is not something you're familiar with and/or might struggle to 'revert' (meaning, tracking down the commit and reverting to its prior state).


You are right and if I have time I look into it otherwise i wait!

Thx!
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Mon Nov 23, 2015 7:44 pm    Post subject: Reply with quote

Wait? How long? Just doing a fresh install :)
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon Nov 23, 2015 7:55 pm    Post subject: Reply with quote

Tolstoi wrote:
Wait? How long? Just doing a fresh install :)

Tolstoi ... until it's fixed in tree ... or until you've reverted the change in a local overlay (if in fact the issue is as reported in the above bug).

best ... khay
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Tue Nov 24, 2015 8:15 am    Post subject: Reply with quote

Wow that support is sad. This is not some shitty desktop application. Its the gentoo kernel. That should have some priority, right?
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Tue Nov 24, 2015 8:26 am    Post subject: Reply with quote

bastibasti wrote:
Wow that support is sad. This is not some shitty desktop application. Its the gentoo kernel. That should have some priority, right?


I think the support is awesome because it is already fixed!!!! :)
Back to top
View user's profile Send private message
McGee23
n00b
n00b


Joined: 04 Nov 2013
Posts: 3

PostPosted: Tue Nov 24, 2015 8:45 am    Post subject: Reply with quote

chi86 wrote:
I think the support is awesome because it is already fixed!!!! :)


I second that. Bug 566600 is solved and emerge works fine.
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Tue Nov 24, 2015 9:34 am    Post subject: Reply with quote

Yes, everything fine here as well.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum