Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-lang/python-2.7.10-r1 fails during install phase [solved
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1543

PostPosted: Sun Nov 29, 2015 1:13 pm    Post subject: dev-lang/python-2.7.10-r1 fails during install phase [solved Reply with quote

Trying to upgrade 2.7.10 to 2.7.10-r1

Code:

# emerge -Du world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/python-2.7.10-r1:2.7::gentoo [2.7.10:2.7::gentoo] USE="ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml (-berkdb) -build -doc -examples -gdbm -hardened -tk -wininst" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB
[...]


Everything appears to be going along fine, until:

Code:

[...]

/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/pydoc_data/__init__.py /usr/lib64/python2.7/pydoc_data
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/pydoc_data/topics.py /usr/lib64/python2.7/pydoc_data
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/plat-linux2/CDROM.py /usr/lib64/python2.7/plat-linux2
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/plat-linux2/DLFCN.py /usr/lib64/python2.7/plat-linux2
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/plat-linux2/IN.py /usr/lib64/python2.7/plat-linux2
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/plat-linux2/TYPES.py /usr/lib64/python2.7/plat-linux2
/usr/bin/install -c /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Lib/plat-linux2/regen /usr/lib64/python2.7/plat-linux2
/usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/LICENSE /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/
lib64/python2.7/LICENSE.txt
if test -d /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/distutils/tests; then \
    /usr/bin/install -c -m 644 /var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10/Modules/xxmodule.c \
        /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/distutils/tests ; \
fi
PYTHONPATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7  LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_6
4-pc-linux-gnu \
    ./python -E -Wi -tt /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/compileall.py \
    -d /usr/lib64/python2.7 -f \
    -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
    /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7
Listing /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7 ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/BaseHTTPServer.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/Bastion.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/CGIHTTPServer.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/ConfigParser.py ...

[...]

Listing /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/__init__.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/_exceptions.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/expatreader.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/handler.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/saxutils.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xml/sax/xmlreader.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xmllib.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/xmlrpclib.py ...
Compiling /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/zipfile.py ...
PYTHONPATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7  LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu \
    ./python -E -Wi -t /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/compileall.py \
    -d /usr/lib64/python2.7/site-packages -f \
    -x badsyntax /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/site-packages
Listing /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/site-packages ...
PYTHONPATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu \
    ./python -E -Wi -t -O /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/compileall.py \
    -d /usr/lib64/python2.7/site-packages -f \
    -x badsyntax /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/site-packages
Listing /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/site-packages ...
PYTHONPATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu \
    ./python -E -m lib2to3.pgen2.driver /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/Grammar.txt
Generating grammar tables from /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/Grammar.txt
Writing grammar tables to /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/Grammar2.7.10.final.0.pickle
PYTHONPATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu \
    ./python -E -m lib2to3.pgen2.driver /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/PatternGrammar.txt
Generating grammar tables from /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/PatternGrammar.txt
Writing grammar tables to /var/tmp/portage/dev-lang/python-2.7.10-r1/image//usr/lib64/python2.7/lib2to3/PatternGrammar2.7.10.final.0.pickle
if test "xno" != "xno"  ; then \
    case no in \
        upgrade) ensurepip="--altinstall --upgrade --no-default-pip" ;; \
        install|*) ensurepip="--altinstall --no-default-pip" ;; \
    esac; \
    LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu ./python -E -m ensurepip \
        $ensurepip --root=/var/tmp/portage/dev-lang/python-2.7.10-r1/image// ; \
fi
 * ERROR: dev-lang/python-2.7.10-r1::gentoo failed (install phase):
 *   python_do* and python_new* helpers are banned in EAPIs older than 5.
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4170:  Called python_domodule 'epython.py'
 *   environment, line 3344:  Called die
 * The specific snippet of code:
 *           die "python_do* and python_new* helpers are banned in EAPIs older than 5.";
 *
 * If you need support, post the output of `emerge --info '=dev-lang/python-2.7.10-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/python-2.7.10-r1::gentoo'`.
 * The complete build log is located at '/var/log/portage/dev-lang:python-2.7.10-r1:20151129-124910.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-lang/python-2.7.10-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.7.10-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/python-2.7.10-r1/work/x86_64-pc-linux-gnu'
 * S: '/var/tmp/portage/dev-lang/python-2.7.10-r1/work/Python-2.7.10'


Does anyone have any idea what is going on? Thank you in advance.


Last edited by curmudgeon on Mon Nov 30, 2015 12:49 am; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 2:29 pm    Post subject: Reply with quote

curmudgeon ...

the issue is the same as I reponded to in this post.

best ... khay
Back to top
View user's profile Send private message
Pednick
n00b
n00b


Joined: 19 Nov 2014
Posts: 19

PostPosted: Sun Nov 29, 2015 2:32 pm    Post subject: Reply with quote

Seems all versions of python are failing, I tried first the basic with no modified make.conf and with ACCEPT_KEYWORDS="~x86" which gets the newest version. Looks like not a good time to do a new gentoo install.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 3:00 pm    Post subject: Reply with quote

Pednick wrote:
Seems all versions of python are failing, I tried first the basic with no modified make.conf and with ACCEPT_KEYWORDS="~x86" which gets the newest version. Looks like not a good time to do a new gentoo install.

Pednick ... there really is no need for a reinstall ... read the link I provided above, the issue is likely to be fixed shortly.

best ... khay
Back to top
View user's profile Send private message
Pednick
n00b
n00b


Joined: 19 Nov 2014
Posts: 19

PostPosted: Sun Nov 29, 2015 3:13 pm    Post subject: Reply with quote

khayyam wrote:
Pednick wrote:
Seems all versions of python are failing, I tried first the basic with no modified make.conf and with ACCEPT_KEYWORDS="~x86" which gets the newest version. Looks like not a good time to do a new gentoo install.

Pednick ... there really is no need for a reinstall ... read the link I provided above, the issue is likely to be fixed shortly.

best ... khay


Actually I need to do a new install because I don't have any on right now but thanks for the info, I guess I'll have to wait.
Back to top
View user's profile Send private message
Pearlseattle
Apprentice
Apprentice


Joined: 04 Oct 2007
Posts: 162
Location: Switzerland

PostPosted: Sun Nov 29, 2015 5:21 pm    Post subject: Reply with quote

Same problem for me:
Code:
emerge portage

 * IMPORTANT: 25 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 6) dev-lang/python-3.4.3::gentoo
 * Python-3.4.3.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...                                           [ ok ]
 * python-gentoo-patches-3.4.3-0.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...
etc....



Code:

...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/dom/expatbuilder.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/dom/minicompat.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/dom/minidom.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/dom/pulldom.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/dom/xmlbuilder.py'...
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree/ElementInclude.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree/ElementPath.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree/ElementTree.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree/__init__.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/etree/cElementTree.py'...
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/parsers'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/parsers/__init__.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/parsers/expat.py'...
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/__init__.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/_exceptions.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/expatreader.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/handler.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/saxutils.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xml/sax/xmlreader.py'...
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xmlrpc'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xmlrpc/__init__.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xmlrpc/client.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/xmlrpc/server.py'...
Compiling '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/zipfile.py'...
PYTHONPATH=/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4  LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu \
   ./python -E -Wi /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/compileall.py \
   -d /usr/lib64/python3.4/site-packages -f \
   -x badsyntax /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/site-packages
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/site-packages'...
PYTHONPATH=/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu \
   ./python -E -Wi -O /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/compileall.py \
   -d /usr/lib64/python3.4/site-packages -f \
   -x badsyntax /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/site-packages
Listing '/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/site-packages'...
PYTHONPATH=/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu \
   ./python -E -m lib2to3.pgen2.driver /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/Grammar.txt
Generating grammar tables from /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/Grammar.txt
Writing grammar tables to /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/Grammar3.4.3.final.0.pickle
PYTHONPATH=/var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4 LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu \
   ./python -E -m lib2to3.pgen2.driver /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/PatternGrammar.txt
Generating grammar tables from /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/PatternGrammar.txt
Writing grammar tables to /var/tmp/portage/dev-lang/python-3.4.3/image//usr/lib64/python3.4/lib2to3/PatternGrammar3.4.3.final.0.pickle
if test "xno" != "xno"  ; then \
   case no in \
      upgrade) ensurepip="--altinstall --upgrade" ;; \
      install|*) ensurepip="--altinstall" ;; \
   esac; \
   LD_LIBRARY_PATH=/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu ./python -E -m ensurepip \
      $ensurepip --root=/var/tmp/portage/dev-lang/python-3.4.3/image// ; \
fi
 * ERROR: dev-lang/python-3.4.3::gentoo failed (install phase):
 *   python_do* and python_new* helpers are banned in EAPIs older than 5.
 *
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 4091:  Called python_domodule 'epython.py'
 *   environment, line 3277:  Called die
 * The specific snippet of code:
 *           die "python_do* and python_new* helpers are banned in EAPIs older than 5.";
 *
 * If you need support, post the output of `emerge --info '=dev-lang/python-3.4.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lang/python-3.4.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lang/python-3.4.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-3.4.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lang/python-3.4.3/work/x86_64-pc-linux-gnu'
 * S: '/var/tmp/portage/dev-lang/python-3.4.3/work/Python-3.4.3'


What worries me the most is this (worked perfectly before - not sure what I did that made this error message appear, but I didn't do much):
Code:

# emerge --sync
>>> Synchronization of repository 'gentoo' located in '/usr/portage'...
!!! /usr/portage appears to be under revision control (contains .git).
!!! Aborting rsync sync.


FYI:
Code:

# eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *

Code:

# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.7.3
 [2] x86_64-pc-linux-gnu-4.8.3 *

(I think that I tried all python/gcc combinations)

EDIT 20151129 - 1823 CET
Same issue with the "--sync" here: https://forums.gentoo.org/viewtopic-p-7848038.html?sid=f7d5c775c602829cd9f2bb5cac6e0bb6.

EDIT 20151129 - 1828 CET
Issue with "emerge --sync" solved by "rm -R /usr/portage/.git".
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Nov 29, 2015 5:28 pm    Post subject: Reply with quote

Pearlseattle wrote:
What worries me the most is this (worked perfectly before - not sure what I did that made this error message appear, but I didn't do much):

Pearlseattle ... you didn't do anything, please read the link I provided above for the explanation.

best ... khay
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 251

PostPosted: Sun Nov 29, 2015 11:05 pm    Post subject: Reply with quote

khayyam wrote:
Pearlseattle wrote:
What worries me the most is this (worked perfectly before - not sure what I did that made this error message appear, but I didn't do much):

Pearlseattle ... you didn't do anything, please read the link I provided above for the explanation.

best ... khay
So....resync and hope for the best? ;-)
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1543

PostPosted: Mon Nov 30, 2015 12:52 am    Post subject: Reply with quote

After solving the "emerge --sync" issue (good thing I checked on that and learned how to fix it - I almost thought "oh that will get fixed soon," which would have left me waiting for a long time), and syncing, the package installed as it should.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1803
Location: Here and Away Again

PostPosted: Tue Dec 22, 2015 10:33 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of Python-3.4.3 fail in install phase.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum