Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pulseaudio not powersaving features
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Vandr0iy
n00b
n00b


Joined: 30 May 2015
Posts: 30

PostPosted: Thu Nov 19, 2015 9:55 am    Post subject: Pulseaudio not powersaving features Reply with quote

Hi, ladies and gentoomen!
I got a weird audio issue: my speakers are mute and, if I plug any 3.5 jack in I get some powerful whitenoise with crackling.
All of this goes on until I start pavucontrol. While it is in execution, everything works fine.
Furthermore, all of this started to happen after I installed laptop-mode-tools and powertop, so I believe that it relates to some powersaving setting.
More info:
lsmod output: http://sprunge.us/JJDW
aplay -l output:
Code:
**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC3226 Analog [ALC3226 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

pacmd list-sinks: http://sprunge.us/hGWL

Thank you in advance.

P.S. I had to rewrite this because after I finished instead of submitting the form the site redirected me to the login screen, again (more than one time), which made me enrage. Is it normal behavior, or my browsers fault?
Back to top
View user's profile Send private message
Vandr0iy
n00b
n00b


Joined: 30 May 2015
Posts: 30

PostPosted: Tue Nov 24, 2015 11:43 am    Post subject: Reply with quote

bump...
Help me, please, - it's pretty obnoxious having to open pavucontrol on every boot.

Thank you in advance.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Tue Nov 24, 2015 9:13 pm    Post subject: Reply with quote

Well, have you try to disable laptop-mode-tools service and see if this white noise occur again (after a shutdown)? You may have to check in laptop-mode-tools configuration files what it does to powersave the sound card.

If powersaving is in cause, you can try to disable disable the powersaving for the sound card in laptop-mode-tools. This feature can be disable too in the Intel sound card module with the parameter

Code:
echo 'options snd_hda_intel power_save=0' > /etc/modprobe.d/snd_hda_intel.conf


Reboot or unload and reload the snd_hda_intel related modules.

There may have a better solution I ignore in Pulseaudio configuration. The prior is more a try to workaround the problem. Maybe just unmute the sound card with Alsa mixer boot script before plug the jack in can resolv the problem.
_________________
Paul
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5879

PostPosted: Tue Dec 01, 2015 12:09 am    Post subject: Reply with quote

What you have there is a common symptom of crappy HDA-Intel hardware: when your card goes into low power mode it doesn't actually bother to power off the DAC correctly, and it starts acting as an AM radio receiver for whatever RF noise your laptop's spewing out.

If the modprobe method doesn't help, here's a suitably crappy workaround to keep the card alive, throw it in an autostart script or whatever:
Code:
pacat --rate=100 /dev/zero
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum