Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No SMBIOS - DMI not present or invalid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
covin
n00b
n00b


Joined: 03 Dec 2015
Posts: 2

PostPosted: Thu Dec 03, 2015 9:19 pm    Post subject: No SMBIOS - DMI not present or invalid Reply with quote

Hello Gentoo Community!

For a couple of days I have been running into trouble getting my new system running. The short story: My kernel detects just one out of twelve cores and round about 1.8GB RAM of 32GB.

Here the hardware facts:
CPU - Intel XEON E5 2620 v3
Motherboard - SuperMicro X10SRL-F
RAM - 4x8 GB DDR4 ECC memory
Disk - NVMe Intel 750 Series SSD

Boot loaders tried: Grub2-2.02_beta2-r7 (EFI) and rEFInd-0.10.0
Current kernel: Hardened Gentoo 4.2.6 r6

My .config looks like [1]. It is minimal not my final config, since trial and error kernel compiling on a single core is time consuming :|

I've tracked down the problem to the first 'dmesg lines' [2]. It seems to me, that my system is unable to locate SMBIOS memory address(?)
Code:

...
[    0.000000] efi: EFI v2.31 by American Megatrends
[!>>>0.000000] efi:  ACPI=0x79a70000  ACPI 2.0=0x79a70000  ESRT=0x7babca98
[    0.000000] esrt: Reserving ESRT space from 0x000000007babca98 to 0x000000007babcad0.
[!>>>0.000000] DMI not present or invalid.
...
[    0.000000] smpboot: Allowing 1 CPUs, 0 hotplug CPUs
...
[    0.034566] smpboot: weird, boot CPU (#0) not listed by the BIOS
[    0.034582] TSC deadline timer enabled
[    0.034584] smpboot: CPU0: Intel(R) Xeon(R) CPU E5-2620 v3 @ 2.40GHz (fam: 06, model: 3f, stepping: 02)
[    0.034605] Performance Events: PEBS fmt2+, 16-deep LBR, Haswell events, full-width counters, Intel PMU driver.
[    0.034627] ... version:                3
[    0.034629] ... bit width:              48
[    0.034632] ... generic registers:      4
[    0.034634] ... value mask:             0000ffffffffffff
[    0.034636] ... max period:             0000ffffffffffff
[    0.034639] ... fixed-purpose events:   3
[    0.034641] ... event mask:             000000070000000f
[    0.034780] x86: Booted up 1 node, 1 CPUs
[    0.034783] smpboot: Total of 1 processors activated (4799.95 BogoMIPS)


and of course /sys/firmware/efi/systab does not show a SMBIOS entry.

Other kernel versions produced similar output. But in contrast the Gentoo LiveDVD (zfs support needed) with Linux 3.15.x kernel detects everything like charm. However, I couldn't figure out the significant difference betweent LiveDVD Kernel and my kernel config. It feels like having compiled all kernel configurations of any relevant combination of ACPI, EFI and CPU related options.

This is my first (U)EFI system, so my knowledge about EFI mechanics is limited. Is it possible that problem is with EFI boot loader images and not my kernel configuration? Just a guess...

Does anybody have an idea?


[1] kernel config: https://bpaste.net/show/6e68a41a7e63
[2] first dmesg lines: https://bpaste.net/show/04f486672a75
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Thu Dec 03, 2015 10:54 pm    Post subject: Reply with quote

Hello,

the Linux kernel have several parameters you can use to help it to see the cpu number and the amount of memory correctly. You can pass to it the maxcpus=12 and mem=32G parameters and see if it resolv the problem.

One other thing you can do is to use a .config file from a working kernel version 4 as the base of your own one and do an
Code:
make oldconfig

on it and then adapt it to your material with care. Why not try the gentoo-sources first?

You can try a recent live cd/dvd/sd/usb with version 4 of the Linux kernel and boot it in Bios mode and then in Efi mode to see if the cpu number and the amount of memory differ.

You may need to check your Bios/Efi configuration to be sure it is not the cause of the wrong cpu number and amount of memory detection.
_________________
Paul
Back to top
View user's profile Send private message
covin
n00b
n00b


Joined: 03 Dec 2015
Posts: 2

PostPosted: Fri Dec 04, 2015 8:30 am    Post subject: Reply with quote

Hi Paul,

actually I have already tried gentoo-sources with different versions. Every time the same result.

Well, I followed your suggestion to test other live meda. They worked mostly fine. The bottom line is, that I have examined their EFI/ESP setup, which shows some major difference to mine. My ESP is structured like this:

/EFI/grub/grubx64.efi
/EFI/refind/refind_x64.efi
/EFI/gentoo/<stub-kernel and initramfs> (for rEFInd)

whereas live meda had their *.efi file located at

/EFI/boot/bootx64.efi

So I copied my grubx64.efi to the location above. After reboot my board auto detected the ESP and the kernel booted with all cores and memory. (Previously I had to select the bootable efi file within BIOS manually, as advised in some blog post. It seems to me now, that this had bypassed and consequently disabled UEFI boot mode?!)

-- Solved, thanks! --
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum