Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Non-root partitions failure to mount on boot.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Gentling
n00b
n00b


Joined: 21 Jul 2012
Posts: 16

PostPosted: Fri Dec 04, 2015 4:12 pm    Post subject: [solved] Non-root partitions failure to mount on boot. Reply with quote

I got almost through the handbook, but when booting the only things that mount are the root partition and tmp on tmpfs. Here is the output from /proc/mounts (etc/mtab didn't have anything). Also - root is mounted read only, without my specified parameters but instead as auto.
Code:
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,nosuid,relatime,size=10240k,nr_inodes=504812,mode=755 0 0
devpts /dev/pts devpts rw,relatime,gid=5,mode=620 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
/dev/sda6 / btrfs ro,relatime,noacl,space_cache 0 0
tmpfs /run tmpfs rw,nodev,relatime,size=404288k,mode=755 0 0
mqueue /dev/mqueue mqueue rw,nosuid,nodev,noexec,relatime 0 0
shm /dev/shm tmpfs rw,nosuid,nodev,noexec,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,nosuid,nodev,noexec,relatime 0 0
cgroup_root /sys/fs/cgroup tmpfs rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755 0 0
openrc /sys/fs/cgroup/openrc cgroup rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc 0 0
cpuset /sys/fs/cgroup/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset 0 0
cpu /sys/fs/cgroup/cpu cgroup rw,nosuid,nodev,noexec,relatime,cpu 0 0
cpuacct /sys/fs/cgroup/cpuacct cgroup rw,nosuid,nodev,noexec,relatime,cpuacct 0 0
freezer /sys/fs/cgroup/freezer cgroup rw,nosuid,nodev,noexec,relatime,freezer 0 0
tmpfs /tmp tmpfs rw,relatime,size=1048576k 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
/dev/sda11 /var vfat rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro 0 0


Here is my fstab. /var, /usr/portage, and the second swap partition are located on a separate drive formated as gpt. Everything else is on a mbr disk in logical partitions, bios not uefi.
Code:
# /etc/fstab: static file system information.
# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
UUID={ed5a6485-88d3-459b-b4ef-22e1aaad4b6f}       /boot      ext4      noatime   1 2
UUID={58f8aa2d-9766-46cd-96d9-cb0958992da8}       /      btrfs      noatime,space_cache,max_inline=40960,compression=zlib      0 1
UUID={b5da6f0a-06b9-4fda-b687-6dcb2f8a8878}              none      swap      sw      0 0
UUID={dd9c27b3-0ac8-4900-9bfd-0d19fe3cd7e7}      none      swap      sw      0 0
UUID={368048d3-fc77-431e-a7a8-d46325fd2503}       /usr      btrfs      autodefrag,noatime,space_cache,max_inline=40960,compression=zlib      0 2
UUID={35827e2f-aa45-40f6-9e58-9307ae411550}       /opt      btrfs      autodefrag,noatime,space_cache,max_inline=40960,compression=zlib      0 2
UUID={bd7eed95-87e6-4faf-9e02-d2490a90a391}       /home   btrfs      nosuid,autodefrag,noatime,space_cache,max_inline=40960,compression=zlib      0 2
UUID={962b654d-b31d-4e4f-b37e-edc792b7d142}       /var      btrfs      nosuid,noatime,space_cache,max_inline=40960,nocow      0 2
UUID={65a2b9fc-449d-44f6-bbcb-524c50fb7291}      /usr/portage   btrfs      autodefrag,noatime,space_cache,max_inline=40960,compression=zlib      0 2

tmpfs         /tmp      tmpfs      size=1g      0 0
tmpfs         /var/tmp   tmpfs      size=75%   0 0

/dev/cdrom      /mnt/cdrom   auto      noauto,ro   0 0
/dev/fd0      /mnt/floppy   auto      noauto      0 0


I wasn't sure if the booting text log is available somewhere, but I wrote down the relevant section.

>> Determining root device...
>> Detected real_root=/dev/sda6
>> mounting /dev/sda6 as root...
>> using mount -t auto -O ro
>> mounting UUID={368048d3-fc77-431e-a7a8-d46325fd2503} as /usr:
mount -t btrfs -O autodefrag,noatime,space_cache,max_inline=40960,compression=zlib,ro
UUID={368048d3-fc77-431e-a7a8-d46325fd2503} /newroot/usr
mountpoint /netroot/usr doesn't exist

Initramfs (made with genkernel) loads after this.
Let me know if there's anything else that would be helpful to include. Thanks for looking my problem over.


Last edited by Gentling on Sat Dec 05, 2015 5:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Fri Dec 04, 2015 4:54 pm    Post subject: Reply with quote

Gentling,

Code:
UUID={368048d3-fc77-431e-a7a8-d46325fd2503} /newroot/usr
mountpoint /netroot/usr doesn't exist


That's significant. As you have copy typed this, its not clear if /netroot/usr doesn't exist or /newroot/usr doesn't exist.
Whatever, your separate /usr is not being mounted because its mount point has a problem then its all down hill from there.

That's in the initrd.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Gentling
n00b
n00b


Joined: 21 Jul 2012
Posts: 16

PostPosted: Sat Dec 05, 2015 5:28 pm    Post subject: silly syntax, {} are for kids Reply with quote

It turns out curly brackets {} shouldn't be used for the uuid.

Thank you for your time. I'll mark this one as solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum