Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems about First Emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Seira
n00b
n00b


Joined: 05 Dec 2015
Posts: 2
Location: China

PostPosted: Sat Dec 05, 2015 6:43 am    Post subject: [SOLVED] Problems about First Emerge Reply with quote

i 've configured eth0, resolve.conf, and I can use wget to download files from website, but if I use "emerge" to install something, there is a problem:
Code:

>>> Verifying ebuild manifests                                                 
                                                                               
>>> Emerging (1 of 16) sys-libs/libseccomp-2.1.1::gentoo                       
 * Fetching files in the background. To view fetch progress, run               
 * `tail -f /var/log/emerge-fetch.log` in another terminal.                     
>>> Downloading 'http://mirrors.163.com/gentoo/distfiles/libseccomp-2.1.1.tar.gz
'                                                                               
--2015-12-05 14:29:01--  http://mirrors.163.com/gentoo/distfiles/libseccomp-2.1.
1.tar.gz                                                                       
Resolving mirrors.163.com... failed: Temporary failure in name resolution.     
wget: unable to resolve host address 'mirrors.163.com'                         
>>> Downloading 'http://mirrors.xmu.edu.cn/gentoo/distfiles/libseccomp-2.1.1.tar
.gz'                                                                           
--2015-12-05 14:29:01--  http://mirrors.xmu.edu.cn/gentoo/distfiles/libseccomp-2
.1.1.tar.gz                                                                     
Resolving mirrors.xmu.edu.cn... failed: Temporary failure in name resolution.   
wget: unable to resolve host address 'mirrors.xmu.edu.cn'                       
>>> Downloading 'http://tcpdiag.dl.sourceforge.net/libseccomp/libseccomp-2.1.1.t
ar.gz'                                                                         
--2015-12-05 14:29:01--  http://tcpdiag.dl.sourceforge.net/libseccomp/libseccomp
-2.1.1.tar.gz                                                                   
Resolving tcpdiag.dl.sourceforge.net... failed: Temporary failure in name resolu
tion.                                                                           
wget: unable to resolve host address 'tcpdiag.dl.sourceforge.net'               
>>> Downloading 'http://ncu.dl.sourceforge.net/libseccomp/libseccomp-2.1.1.tar.g
z'                                                                             
--2015-12-05 14:29:01--  http://ncu.dl.sourceforge.net/libseccomp/libseccomp-2.1
.1.tar.gz                                                                       
Resolving ncu.dl.sourceforge.net... failed: Temporary failure in name resolution
.                                                                               
wget: unable to resolve host address 'ncu.dl.sourceforge.net'                   
>>> Downloading 'http://optimate.dl.sourceforge.net/libseccomp/libseccomp-2.1.1.
tar.gz'                                                                         
--2015-12-05 14:29:01--  http://optimate.dl.sourceforge.net/libseccomp/libseccom
p-2.1.1.tar.gz                                                                 
Resolving optimate.dl.sourceforge.net... failed: Temporary failure in name resol
ution.                                                                         
wget: unable to resolve host address 'optimate.dl.sourceforge.net'             
>>> Downloading 'http://aarnet.dl.sourceforge.net/libseccomp/libseccomp-2.1.1.ta
r.gz'                                                                           
--2015-12-05 14:29:01--  http://aarnet.dl.sourceforge.net/libseccomp/libseccomp-
2.1.1.tar.gz                                                                   
Resolving aarnet.dl.sourceforge.net... failed: Temporary failure in name resolut
ion.                                                                           
wget: unable to resolve host address 'aarnet.dl.sourceforge.net'     

here is ifconfig:
Code:

localhost ~ # ifconfig -a                                                       
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500                     
        inet 192.168.10.49  netmask 255.255.255.0  broadcast 192.168.10.255     
        inet6 2001:da8:100e:ca9d:200:ffff:feff:0  prefixlen 64  scopeid 0x0<glob
al>                                                                             
        inet6 fe80::200:ffff:feff:0  prefixlen 64  scopeid 0x20<link>           
        ether 00:00:ff:ff:00:00  txqueuelen 1000  (Ethernet)                   
        RX packets 47317  bytes 3654835 (3.4 MiB)                               
        RX errors 0  dropped 136  overruns 0  frame 0                           
        TX packets 439  bytes 35961 (35.1 KiB)                                 
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0             

here is the resolv.conf:
Code:

localhost ~ # cat /etc/resolv.conf                                             
nameserver 192.168.10.1                                                         
nameserver 10.0.80.11                                                           
nameserver 10.0.80.12                                                           
nameserver 114.114.114.114   

here is the make.conf:
Code:

localhost ~ # cat /etc/portage/make.conf                                       
# These settings were set by the catalyst build script that automatically       
# built this stage.                                                             
# Please consult /usr/share/portage/config/make.conf.example for a more         
# detailed example.                                                             
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp"           
CXXFLAGS="${CFLAGS}"                                                           
# WARNING: Changing your CHOST is not something that should be done lightly.   
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="armv7a-softfp-linux-gnueabi"                                             
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.                                                   
USE="bindist"                                                                   
PORTDIR="/usr/portage"                                                         
DISTDIR="${PORTDIR}/distfiles"                                                 
PKGDIR="${PORTDIR}/packages"                                                   
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://mirrors.xmu.edu.cn/gentoo/"


Last edited by Seira on Sat Dec 05, 2015 8:09 am; edited 1 time in total
Back to top
View user's profile Send private message
Seira
n00b
n00b


Joined: 05 Dec 2015
Posts: 2
Location: China

PostPosted: Sat Dec 05, 2015 7:33 am    Post subject: Reply with quote

add
Code:
FEATURES=“-userfetch”
to make.conf and solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum