Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ACPI troubles with new laptop (MSI GE72 6QF)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Sleris
n00b
n00b


Joined: 26 Jan 2015
Posts: 5

PostPosted: Tue Dec 15, 2015 10:01 pm    Post subject: ACPI troubles with new laptop (MSI GE72 6QF) Reply with quote

Hello gentoo users,

Something in my previous laptop burnt after 4 years of intensive use (RIP), and therefor I had to change it a bit sooner than I wanted (well normally I change it every 2 years, but because of health trouble last 2 years, I didn't had the money).
As my two previous laptop was from MSI, and I was quite satisfied, I choose the new one from them also.
I'm a researcher in computer science and use a lot of parallel code including CUDA, I needed a quite recent hardware that would not be outdated next year, so I choose an MSI GE72 6QF.
It is based on an intel i7 6700HQ, which use the new skylake architecture.
I checked if this architecture (and the networks and sound cards) was supported by Linux, and it was added in 4.3 and gentoo has put 4.3 in stable, so I was hopping everything would be more or less fine.
I expected some trouble with ACPI as I had with all my previous laptop (ans was able to fix by myself), but with the new one it's quite a big mess and ACPI has become much more complex during the last 4 years.
So I'm looking for some help because I submitted a new bug on the Linux bugzilla last week (https://bugzilla.kernel.org/show_bug.cgi?id=109081) but got no answer for now.

For a quick description, Linux freezes as soon as it boots if I use no options, I just have the time to see Tux and a bunch of log lines and then everything goes dark and the only thing I can do is an hard shutdown.
I tried with 4.3.0-gentoo, 4.4-rc3 and now 4.4-rc5 and I put the latest bios and EC firmware available from MSI.
To boot I neeed to use either acpi=off or nolapic, I tried many other options also (especially acpi=ht, acpi=strict, acpi=noirq, pci=noacpi, pnpacpi=off) but none of them worked.
Using nolapic and the 4.4 kernels, I was able to retrieve some interesting logs and the ACPI tables to take a look at them.
I think I might have been able to narrow the search of the problem (see the bugzilla), but I'm unable to fix it by myself.
If someone with a good knowledge on ACPI and the kernel would give it a try, I could provide logs files, and test any idea or patch to solve this problem (as long as it seems safe enought ^^).

Thank in advance for any help !
Have a nice day (or nigth) :)
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Dec 16, 2015 4:54 am    Post subject: Reply with quote

You did the right thing to instantly open a kernel.bug

I have similiar issues with ACPI, but my hardware is 2-3 years old now. I bought it second hand in october 2015 and I did not expect that linux kernel / asus / nvidia blob is such worse. (last time i buy any nvidia hardware !)

One intel guy responded to my bug request quite fast but after that intial response to ask which i already provided, and some response after it, it is quiet.

A bit off topic advice, when you bought the hardware via online shopping and you are in the return period, if i were you I would return it.
Back to top
View user's profile Send private message
timofonic
n00b
n00b


Joined: 13 Sep 2005
Posts: 16

PostPosted: Thu Jan 12, 2017 2:13 pm    Post subject: Reply with quote

I have random freezes with a MSI GE62 2QD. Some of them are recoverable, others don't. It's quite annoying.

I also have issues configuring Optimus and not sure what to do. I was writing a post about it, but the freezes made the text to be thrown away (now I'm from time to time typing it on Gmail and sometimes under Windows 10, no freezes there).

Could this be related?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum