Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solv]problems mounting a partition on a LUKS encrypted disk
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
zhak
n00b
n00b


Joined: 04 May 2015
Posts: 21

PostPosted: Sat Dec 19, 2015 12:33 pm    Post subject: [solv]problems mounting a partition on a LUKS encrypted disk Reply with quote

Hi guys, could anyone help me with the following, please?

I'm trying to install gentoo with encryption - LUKS without LVM:
boot partition - USB
root partition - SSD

So, I encrypted the whole sda drive, not only partition:
Code:
cryptsetup luksFormat /dev/sda
cryptsetup luksOpen /dev/sda drive

Then I created GPT on a newly mapped drive, added a partition and formatted as ext4. Then I shut the system down to continue later.

When I decrypt sda now, I see only drive itself in /dev/mapper and I don't know how to access and mount a partition on that drive.
Almost each and every tutorial on Internet describes how to encrypt and access partitions. Even titles like "Full drive encryption" show how to encrypt partitions. Almost no info about drives, unfortunately


Last edited by zhak on Sun Dec 20, 2015 11:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
zhak
n00b
n00b


Joined: 04 May 2015
Posts: 21

PostPosted: Sun Dec 20, 2015 11:06 pm    Post subject: Reply with quote

Well, I found the solution myself. It goes like hot plugging a device, so partprobe {device} command should be issued to read partitions
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum