Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nvidia proprietary driver glx problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
est921
n00b
n00b


Joined: 20 Dec 2015
Posts: 28

PostPosted: Sun Dec 20, 2015 3:39 pm    Post subject: Nvidia proprietary driver glx problem Reply with quote

Hi, i'm new to gentoo, and simply can't get X to work. I'm trying to use the proprietary Nvidia drivers along with a gnome setup. When I start gdm I instantly get the "something went wrong screen", no login screen. I found these lines

Quote:
" 1592.314] (II) Module "ramdac" already built-in
[ 1592.314] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 1592.314] (==) NVIDIA(0): RGB weight 888
[ 1592.314] (==) NVIDIA(0): Default visual is TrueColor
[ 1592.314] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 1592.315] (**) NVIDIA(0): Enabling 2D acceleration
[ 1592.315] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[ 1592.315] (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
[ 1592.315] (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
[ 1592.315] (EE) NVIDIA(0): you continue to encounter problems, Please try
[ 1592.315] (EE) NVIDIA(0): reinstalling the NVIDIA driver.
[ 1592.803] (II) NVIDIA: Allocated GPU:0 (GPU-50426338-a182-aa1b-e820-ce4d6aac4078) @
[ 1592.803] (II) NVIDIA: PCI:0000:01:00.0
"
[/code]

in my Xorg.0.log, but haven't figured out how to solve it. Reinstalling the driverd did not help. Any suggestions?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43209
Location: 56N 3W

PostPosted: Sun Dec 20, 2015 4:27 pm    Post subject: Reply with quote

est921,

Welcome to gentoo.

You need to select the nvidia opengl. Play with
Code:
eselect opengl

Also make friends with wgetpaste. Whole logs are much easier to work with that just the error message.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
est921
n00b
n00b


Joined: 20 Dec 2015
Posts: 28

PostPosted: Sun Dec 20, 2015 9:11 pm    Post subject: Reply with quote

NeddySeagoon wrote:
est921,

Welcome to gentoo.

You need to select the nvidia opengl. Play with
Code:
eselect opengl

Also make friends with wgetpaste. Whole logs are much easier to work with that just the error message.


Hey, and thanks for your reply. I had already set opengl and opencl to nvidia with eselect.

Here's my entire Xorg.0.log:

https://bpaste.net/show/2deae1778883
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43209
Location: 56N 3W

PostPosted: Sun Dec 20, 2015 10:45 pm    Post subject: Reply with quote

est921,

Code:
Linux localhost 4.1.12-gentoo #4 SMP Sun Dec 20 15:32:05 2015 x86_64

Tells that you have had four goes at building the kernel and the runnitg kernel was built today.

Code:
[     9.952] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
The Xorg part loaded.

I was expecting to see a section like
Code:
[    42.651] (II) LoadModule: "glx"
[    42.653] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    42.663] (II) Module glx: vendor="X.Org Foundation"
[    42.663]    compiled for 1.17.4, module version = 1.0.0
[    42.663]    ABI class: X.Org Server Extension, version 9.0
[    42.663] (==) AIGLX enabled

You have
Code:
[     9.775] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"

The nvidia glx module should be there.

It gets worse.
Code:
[    51.403] (EE) Segmentation fault at address 0x0
Something tried to access memory it doesn't own.
There's several causes. The same gcc not being used for the kernel and its modules - including the nvidia binary blob.
Some major kernel config change and the kernel not being rebuilt starting with make clean.
The /usr/src/linux symlink not pointing to the kernel you are running, here 4.1.12-gentoo.

Get all your ducks in a row. Check that /usr/src/linux points to the right place.
Rebuild and reinstall the kernel starting with
Code:
cd   /usr/src/linux
make clean
so there are no binaries to be reused.
Code:
emerge -1 nvidia-drivers

Reboot to test.

Now we know its a clean build, all made with the same gcc. It will be #5.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
est921
n00b
n00b


Joined: 20 Dec 2015
Posts: 28

PostPosted: Sun Dec 20, 2015 11:35 pm    Post subject: Reply with quote

I have now rebuilt the kernel (again), and the nvidia driver, which got rid of the segmentation fault. My original problem persists, though.

Thank you for trying to help!

Xorg.0.log: https://bpaste.net/show/a8966c5a877a
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43209
Location: 56N 3W

PostPosted: Mon Dec 21, 2015 12:11 am    Post subject: Reply with quote

est921,

The nvidia glx module should be in on of these dir,
Code:
[    10.133] (**) ModulePath set to "/usr/lib64/opengl/nvidia,/usr/lib64/xorg/modules"
is it?

It should be loaded automatically but if not, add

Code:
Section "Module"
# This loads the GLX module
    Load       "glx"
EndSection
to your xorg.conf.

If you already have a Section "Module", check that it does not contain
Code:
Disable "glx"
and add in the Load statement.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
est921
n00b
n00b


Joined: 20 Dec 2015
Posts: 28

PostPosted: Mon Dec 21, 2015 3:11 am    Post subject: Reply with quote

Quote:

It should be loaded automatically but if not, add

Code:
Section "Module"
# This loads the GLX module
    Load       "glx"
EndSection
to your xorg.conf.


That did it, Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum