Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[beendet] woher JDK 1.6.0.45 nehmen?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Dec 24, 2015 11:30 am    Post subject: [beendet] woher JDK 1.6.0.45 nehmen? Reply with quote

Hallo zusammen,

zuerst einmal:

Schöne Feiertage und ein ruhiges und gesundes Hinübergleiten nach 2016 Euch allen. An dieser Stelle auch nochmal ganz herzlichen Dank an all für die freudnliche und kompetnte Unterstützung über meine gesamte "Gentoo-Zeit". Ohne Euch wäre ich vermutlich längst bei Ubuntu oder zurück zu Suse....

Über die feiertage will ich an meiner Kiste ein paar Dinge in ordnung bringen... Unter anfderem möchte ich den RAW-Konverter LightZone installieren und habe dabei das folgende Problem:

Code:
* Fetch failed for 'dev-java/sun-jdk-1.6.0.45', Log file:
 *  '/var/tmp/portage/dev-java/sun-jdk-1.6.0.45/temp/build.log'
 *
 * Due to Oracle no longer providing the distro-friendly DLJ bundles, the package
 * has become fetch restricted again. Alternatives are switching to
 * dev-java/icedtea-bin:6 or the source-based dev-java/icedtea:6
 *
 * Oracle requires you to download the needed files manually after
 * accepting their license through a javascript capable web browser.
 *
 * Download the following files:
 *   jdk-6u45-linux-x64.bin
 * at 'http://www.oracle.com/technetwork/java/javase/downloads/jdk6downloads-1902814.html'
 * and move them to '/usr/portage/distfiles'


Ist icedtea für LightZone ok? Oder kann ich ein aktuelles JDK verwenden? Icedtea-bin ist eigentlich schon da:
Code:
dev-java/icedtea-bin
     Available versions: 
     (6)    6.1.13.8-r1^s 6.1.13.9^s
     (7)    *7.2.5.6-r1^s 7.2.6.2^s 7.2.6.3^s
       {+alsa +awt cjk +cups doc examples +gtk headless-awt nsplugin nss pulseaudio selinux source webstart}
     Installed versions:  7.2.6.3(7)^s(22:09:09 15.12.2015)(alsa cups doc gtk -cjk -examples -headless-awt -nsplugin -nss -pulseaudio -selinux -source -webstart)
     Homepage:            http://icedtea.classpath.org
     Description:         A Gentoo-made binary build of the IcedTea JDK


uhai
[code]
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Mon Jan 04, 2016 8:58 am; edited 4 times in total
Back to top
View user's profile Send private message
hafgan
n00b
n00b


Joined: 27 Sep 2012
Posts: 39

PostPosted: Thu Dec 24, 2015 1:08 pm    Post subject: Reply with quote

Hi,

er sagt ja, wo du sie dir holen sollst. Allerdings würde mir die aktuelle 8u66 holen. Aber da ist aber keine .bin sondern ich hab die .tar.gz genommen:

http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

und dann wie er schon schreibt kopieren nach:
/usr/portage/distfiles

(So wie ich die Ausgabe verstehe, kannst du eben alterntiv zu icedtea:6 wechseln. Dann brauchst du wohl diesen Download nicht und kannst den jdk enternen. - Aber hier würde ich nochmal auf die Profis warten! ;) )

Gruß und frohe Weihnachten
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Thu Dec 24, 2015 1:21 pm    Post subject: Reply with quote

icedtea habe ich ja schon, warum will er das dann nochmal?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
hafgan
n00b
n00b


Joined: 27 Sep 2012
Posts: 39

PostPosted: Thu Dec 24, 2015 1:36 pm    Post subject: Reply with quote

Hm, ich kann jetzt bloß vermuten:

- Du hast icedtea Version 7, die braucht den JDK (außer Du wechselst zur Version 6)
https://packages.gentoo.org/packages/dev-java/icedtea

- Du hast aufgrund einer früheren Installation von icedtea:7 auch die ältere JDK 1.6 installiert

- Die 1.6 ist aber nicht mehr im stable Zweig:
https://packages.gentoo.org/packages/dev-java/oracle-jdk-bin

Meine Interpretation. Bin da aber nicht sooo sattelfest! ;) Vielleicht kann das nochmal jemand bestätigen, der Ahnung hat.

Gruß
hafgan
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Fri Dec 25, 2015 8:31 pm    Post subject: Reply with quote

So, habe die VM jetzt entsprchend gesetzt:

Code:
 eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7
  [2]   icedtea-bin-7
  [3]   oracle-jdk-bin-1.8
  [4]   sun-jdk-1.6  system-vm
  [5]   sun-jre-bin-1.6

und die Installation läuft durch. Leider startet LightZone nicht:

Code:
 /usr/bin/LightZone
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.4/gjl", line 115, in <module>
    vm = get_vm(pkg)
  File "/usr/lib/python-exec/python3.4/gjl", line 33, in get_vm
    return verman.get_vm(pkg.query('VM'))
  File "/usr/lib64/python3.4/site-packages/java_config_2/VersionManager.py", line 237, in get_vm
    low = self.get_lowest(atoms) # Lowest vm version we can use
  File "/usr/lib64/python3.4/site-packages/java_config_2/VersionManager.py", line 184, in get_lowest
    lowest = self.get_lowest_atom(atoms)
  File "/usr/lib64/python3.4/site-packages/java_config_2/VersionManager.py", line 180, in get_lowest_atom
    raise Exception("Couldn't find a VM dep")
Exception: Couldn't find a VM dep
Couldn't get needed information


Das ist aber kein Java-Problem, oder?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Dec 28, 2015 4:20 pm    Post subject: Reply with quote

Ich habe ein wenig mehr recherchiert....

Hier meinen ide Kollegen, ein ebuild würde isch nicht lohnen, da das Java-basiert eigentlich "ohne installation" laufen müsste....:

https://forums.gentoo.org/viewtopic-t-964040-highlight-lightzone.html

Was meint Ihr? Wäre das nicht auch ein "an portage vorbei"-böser-Fehler?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Dec 29, 2015 8:31 am    Post subject: Reply with quote

Nö, nicht unbedingt. Sofern es nur ein Jar ist, kannst du es einfach nach /usr/local/lib kopieren und in /usr/local/bin den Aufruf anlegen. Ein Ebuild wäre natürlich trotzdem nicht verkehrt.

Java-Software, bei der ein Ebuild keinen Sinn macht: JDownloader, Eclipse.

Was mich im anderen Thread wundert, ist die Notwendigkeit einer 32bit-Java-Installation bzw. der Emul-Libs.

Hier steht was anderes. Es sollte also auch problemlos funktionieren mit:
  • icedtea:7
  • 64 bit
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Tue Dec 29, 2015 10:08 am    Post subject: Reply with quote

Ich habe ein Archiv gezogen, das enthält folgende Datenstruktur:

/usr/bin/lightzone - Bash-Skript für den Start
/usr/lib/lightzone/ - diverse lib*.so, darunter auch libDCRaw.so
/usr/share/applications/lightzone.desktop - Desktop-Verknüpfung
/usr/share/icons/.... - Icon-Dateien
/usr/share/java/lightzone/*.jar & 2 binäre Dateien

Icedtea7 habe ich:

Code:
 eselect java-vm list
Available Java Virtual Machines:
  [1]   icedtea-7  system-vm
  [2]   icedtea-bin-7
  [3]   oracle-jdk-bin-1.8
  [4]   sun-jdk-1.6
  [5]   sun-jre-bin-1.6


Gibt es ein Tool, das ebuilds aus rpm oder deb erstellen kann? Ich habe von ebuilds (noch) überhaupt keine Ahnung....

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Wed Dec 30, 2015 8:32 am    Post subject: Reply with quote

uhai wrote:
Gibt es ein Tool, das ebuilds aus rpm oder deb erstellen kann?

Äußerst unwahrscheinlich bis unmöglich. rpm und deb haben eine komplett andere Aufgabe.

uhai wrote:
Ich habe von ebuilds (noch) überhaupt keine Ahnung....

https://devmanual.gentoo.org/ebuild-writing/

Wieso brauchst du eigentlich soviele Java-VMs? Icedtea-7, d.h. Deine System-VM sollte eigentlich komplett ausreichen. Die anderen würde ich runterschmeißen.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Wed Dec 30, 2015 9:45 am    Post subject: Reply with quote

die sind gewachsen, weil. LightZone nicht laufen wollte....
Die Anleitung habe ich schon gefunden, knabbere aber noch am Inhalt.
uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum