Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fstab for uefi
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2549

PostPosted: Thu Dec 31, 2015 7:21 pm    Post subject: Reply with quote

emerge wgetpaste parted
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 7:28 pm    Post subject: Reply with quote

LOL dude, how do you think I wgetpaste [url]https://bpaste.net/show/27879084cefd [/url]

:P
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2549

PostPosted: Thu Dec 31, 2015 7:37 pm    Post subject: Reply with quote

Sorry I just reflexively put in every command in the pipe.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 7:43 pm    Post subject: Reply with quote

Holy effen shit I just booted into my system.

I need to fix my graphics though, just a black screen. Weird though, I had the login screen to slim.


Last edited by FrankRizz0 on Thu Dec 31, 2015 7:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2549

PostPosted: Thu Dec 31, 2015 7:44 pm    Post subject: Reply with quote

So can you show us the output of df -h?

I thought there were more partitions than your output suggests and I need to know exactly what's mounted where.

Thanks.
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2549

PostPosted: Thu Dec 31, 2015 7:46 pm    Post subject: Reply with quote

I think I said almost exactly that (parental filter disabled) when I finally got mine to work. :)
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 7:48 pm    Post subject: Reply with quote

LOL. Yeah but video no workie. I have to fix that in me kernel me thinks.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 8:00 pm    Post subject: Reply with quote

I'm at a loss now, I can't find the right firmware blob.

BeaverCreek [Radeon HD 6520G]
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 8:05 pm    Post subject: Reply with quote

I think (hope) I found the right one - radeon/R600_rlc.bin radeon/R600_uvd.bin
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 8:07 pm    Post subject: Reply with quote

Also, thanks Donahue and 1clue :D
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 8:12 pm    Post subject: Reply with quote

Guess not:

make[1]: *** No rule to make target 'firmware/radeon/R600_rlc.bin', needed by 'firmware/radeon/R600_rlc.bin.gen.o'. Stop.
Makefile:947: recipe for target 'firmware' failed
make: *** [firmware] Error 2

CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/R600_uvd.bin"

:cry:
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 8:52 pm    Post subject: Reply with quote

So after fixing CONFIG_EXTRA_FIRMWARE_DIR="firmware" to CONFIG_EXTRA_FIRMWARE_DIR="/lib/firmware/" and re-adding CONFIG_EXTRA_FIRMWARE="radeon/R600_rlc.bin radeon/R600_uvd.bin" I rebooted my system and the kernel did not load, it just hung at gentoo 4.1.12
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Dec 31, 2015 8:59 pm    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/Radeon#Firmware says to use:
Quote:
SUMO HD6290, HD6320, HD6480G, HD6520G, HD6620G radeon/SUMO_me.bin radeon/SUMO_pfp.bin radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin
as the extra firmware: radeon/SUMO_me.bin radeon/SUMO_pfp.bin radeon/SUMO_rlc.bin radeon/SUMO_uvd.bin
/lib/firmware is ok

Edit: correcting link
_________________
Defund the FCC.


Last edited by DONAHUE on Thu Dec 31, 2015 10:55 pm; edited 3 times in total
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 9:10 pm    Post subject: Reply with quote

Incorrect link Donahue

Edit: Kernel no longer got hung up, but I'm still staring at a black screen. I'm using slim coupled with fluxbox
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Thu Dec 31, 2015 9:37 pm    Post subject: Reply with quote

Code:
X -retro
will produce a stippled black and white window with a movable mouse cursor if X is ok but the GUI is not. if you get a login screen but no gui after login fluxbox is likely problem.
Code:
ls /etc/X11/Sessions
fluxbox listed?
Code:
nano /etc/env.d/90xsession
Does XSESSION="Fluxbox" where fluxbox spelling matches that in /etc/X11/Sessions?
Code:
wgetpaste -t /var/log/Xorg.0.log
post url; may get a clue. BTW is the box a dual video laptop?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
FrankRizz0
l33t
l33t


Joined: 29 Nov 2006
Posts: 617

PostPosted: Thu Dec 31, 2015 10:05 pm    Post subject: Reply with quote

Well, I got into fluxbox. I installed lightdm and *poof* she decided to work. No mouse pad right now, I have the keyboard, right and left click and I added "mouse keyboard" to INPUT_DEVICES and I'm expecting that to get it going. Tried to start up xterm and that isn't working, but I think there's more to fluxbox than just installing something and she's ready to go. If I remember correctly I have to configure the desktop or something? I have no wallpaper and I think I'm supposed to install something. I'll jump on the fluxbox page, the forums and the irc chan. If anyone has any pointers for me for fluxbox that would be great, and thanks guys for all your help. I really appreciate.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum