Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
digitalnote: boost_coroutine and boost_context [SOLVED..?]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 530
Location: Cape Town, South Africa

PostPosted: Sun Dec 27, 2015 3:11 pm    Post subject: digitalnote: boost_coroutine and boost_context [SOLVED..?] Reply with quote

hi

Am trying to install DigitalNote (http://digitalnote.org/) from Source on github (not .deb from their site) (as I thought that would be safer).

Make dies thusly:

Code:

trooper digitalnote-master # make
mkdir -p build/release
cd build/release && cmake -D CMAKE_BUILD_TYPE=Release ../..
CMake Error at /usr/share/cmake/Modules/FindBoost.cmake:1286 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.56.0

  Boost include path: /usr/include

  Could not find the following Boost libraries:

          boost_coroutine
          boost_context

  Some (but not all) of the required Boost libraries were found.  You may
  need to install these additional Boost libraries.  Alternatively, set
  BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
  to the location of Boost.
Call Stack (most recent call first):
  CMakeLists.txt:93 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/ian/downloads/soft/digitalnote-master/build/release/CMakeFiles/CMakeOutput.log".
Makefile:16: recipe for target 'cmake-release' failed
make: *** [cmake-release] Error 1


Only references to coroutine and context I can find are in the boost package, but can't find them named as requested above.

Is this fixable on my end?

thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM


Last edited by iandoug on Sun Dec 27, 2015 7:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1701

PostPosted: Sun Dec 27, 2015 5:37 pm    Post subject: Reply with quote

from what it looks like from a debain bug report mentioning boost_context, says that module isn't available in boost till >=1.59.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=807483

As of yet, the devs haven't added an ebuild for boost 1.60 (newest version upstream) to portage. Version bump for 1.60
I have no clue if an overlay has an ebuild, as I don't use any overlays.
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 530
Location: Cape Town, South Africa

PostPosted: Sun Dec 27, 2015 7:11 pm    Post subject: Reply with quote

ct85711 wrote:
from what it looks like from a debain bug report mentioning boost_context, says that module isn't available in boost till >=1.59.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=807483

As of yet, the devs haven't added an ebuild for boost 1.60 (newest version upstream) to portage. Version bump for 1.60
I have no clue if an overlay has an ebuild, as I don't use any overlays.


Thanks. The binary in the .deb version of their software runs, does have some connectivity issues but I don't know if that is my firewall blocking some ports or some library not being found at runtime.

Thanks for your help.

Cheers, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1358

PostPosted: Sun Dec 27, 2015 7:46 pm    Post subject: Reply with quote

The requested modules (boost_coroutine and boost_context) are availables in boost-1.57 if it is built with "context" use flag, at least for x86_64 architecture.
Back to top
View user's profile Send private message
iandoug
Guru
Guru


Joined: 11 Feb 2005
Posts: 530
Location: Cape Town, South Africa

PostPosted: Mon Dec 28, 2015 1:14 pm    Post subject: Reply with quote

quilosaq wrote:
The requested modules (boost_coroutine and boost_context) are availables in boost-1.57 if it is built with "context" use flag, at least for x86_64 architecture.


So noted, thanks. I'm still on 1.56 stable.

I see Portage auto-adds the context flag.

Thanks, Ian
_________________
Asus Sabertooth P990, AMD FX-8150, GeForce GTX 560, 16GB Ram | Asus M3A78 64, X2 6000+, PX9800 GT, 4GB Ram | Asus M4A77TD PRO, X2 245, HD4350, 4GB RAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum