Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] kde-apps/kontact: Update trotz package.mask?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
sprittwicht
l33t
l33t


Joined: 04 Dec 2003
Posts: 644

PostPosted: Sat Jan 02, 2016 7:06 pm    Post subject: [gelöst] kde-apps/kontact: Update trotz package.mask? Reply with quote

Anscheinend wurden neulich ein paar KDE-Pakete sinnlos umbenannt von kde-base/* nach kde-apps/*, und jetzt ist bei mir das Chaos ausgebrochen.
Meine package.mask nach der Anpassung:
Code:

>=kde-apps/akregator-4.5
>=kde-apps/kaddressbook-4.5
>=kde-apps/kdepim-icons-4.5
>=kde-apps/kdepim-runtime-4.5
>=kde-apps/kjots-4.5
>=kde-apps/kleopatra-4.5
>=kde-apps/kmail-4.5
>=kde-apps/knotes-4.5
>=kde-apps/kontact-4.5
>=kde-apps/korganizer-4.5
>=kde-apps/libkdepim-4.5
>=kde-apps/libkleo-4.5
>=kde-apps/libkpgp-4.5

Wenn ich nun emerge -puvD world ausführe möchte er kontact auf Version 4.14.8 anheben. WARUM?!
Ich dachte die Ursache sehe ich vielleicht mit der "--tree"-Option:
Code:

emerge -puvD --tree world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U #] kde-apps/kontact-4.14.8:4/4.14::gentoo [4.4.2015.06:4/4.4::gentoo] USE="handbook (-aqua) -debug" 14.235 KiB
[ebuild  N     ]  kde-apps/kdepim-common-libs-4.14.8:4/4.14::gentoo  USE="(-aqua) -debug" 0 KiB
[ebuild  N     ]   kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal" 143 KiB
[ebuild  N     ]    kde-base/kfilemetadata-4.14.3:4/4.14::gentoo  USE="exif ffmpeg pdf (-aqua) -debug -epub -mobi -taglib" 36 KiB
[ebuild  N    #]   kde-apps/kdepim-runtime-4.14.8:4/4.14::gentoo  USE="(-aqua) -debug -facebook -google -kolab" 1.147 KiB
[ebuild  N    #]    kde-apps/kdepim-icons-4.14.8:4/4.14::gentoo  USE="(-aqua)" 0 KiB
[ebuild  N     ]   dev-libs/grantlee-0.4.0::gentoo  USE="-debug -doc {-test}" 1.144 KiB
[nomerge       ] kde-base/baloo-4.14.3:4/4.14::gentoo  USE="(-aqua) -debug -minimal"
[ebuild  N     ]  dev-libs/xapian-1.2.19::gentoo  USE="brass chert inmemory -doc -static-libs" CPU_FLAGS_X86="sse sse2" 3.101 KiB
[blocks B      ] kde-apps/libkleo:4 ("kde-apps/libkleo:4" is blocking kde-apps/kdepim-common-libs-4.14.8)
[blocks B      ] kde-apps/libkpgp:4 ("kde-apps/libkpgp:4" is blocking kde-apps/kdepim-common-libs-4.14.8)
[blocks B      ] kde-apps/libkdepim:4 ("kde-apps/libkdepim:4" is blocking kde-apps/kdepim-common-libs-4.14.8)

Total: 8 packages (1 upgrade, 7 new), Size of downloads: 19.803 KiB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kdepim-common-libs-4.14.8:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kdepim-common-libs-4.14.3:4[aqua=] (>=kde-apps/kdepim-common-libs-4.14.3:4[-aqua]) required by (kde-apps/kontact-4.14.8:4/4.14::gentoo, ebuild scheduled for merge)

  (kde-apps/libkpgp-4.4.2015.06:4/4.4::gentoo, installed) pulled in by
    >=kde-apps/libkpgp-4.4.2015:4[aqua=] (>=kde-apps/libkpgp-4.4.2015:4[-aqua]) required by (kde-apps/kmail-4.4.2015.06:4/4.4::gentoo, installed)

  (kde-apps/libkleo-4.4.2015.06:4/4.4::gentoo, installed) pulled in by
    >=kde-apps/libkleo-4.4.2015:4[aqua=] (>=kde-apps/libkleo-4.4.2015:4[-aqua]) required by (kde-apps/kaddressbook-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkleo-4.4.2015:4[aqua=] (>=kde-apps/libkleo-4.4.2015:4[-aqua]) required by (kde-apps/kmail-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkleo-4.4.2015:4[aqua=] (>=kde-apps/libkleo-4.4.2015:4[-aqua]) required by (kde-apps/kleopatra-4.4.2015.06:4/4.4::gentoo, installed)

  (kde-apps/libkdepim-4.4.2015.06:4/4.4::gentoo, installed) pulled in by
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/akregator-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.11.1-r1:4[aqua=] (>=kde-apps/libkdepim-4.4.11.1-r1:4[-aqua]) required by (kde-apps/kmail-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/kleopatra-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/kaddressbook-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/knotes-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/korganizer-4.4.2015.06:4/4.4::gentoo, installed)
    >=kde-apps/libkdepim-4.4.2015:4[aqua=] (>=kde-apps/libkdepim-4.4.2015:4[-aqua]) required by (kde-apps/kjots-4.4.2015.06:4/4.4::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by kde-apps/kdepim-runtime-4.14.8::gentoo
# required by kde-apps/kdepim-common-libs-4.14.8::gentoo
# required by kde-apps/kontact-4.14.8::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-apps/kdepim-icons-4.14.8
# required by kde-apps/kdepim-common-libs-4.14.8::gentoo
# required by kde-apps/kontact-4.14.8::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-apps/kdepim-runtime-4.14.8
# required by kde-apps/kaddressbook-4.4.2015.06::gentoo[kontact]
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=kde-apps/kontact-4.14.8

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.


Ich raff's nicht, woher kommt dieser Drang mir ein maskiertes Paket aufzuzwängen?


Last edited by sprittwicht on Sat Jan 02, 2016 8:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
sprittwicht
l33t
l33t


Joined: 04 Dec 2003
Posts: 644

PostPosted: Sat Jan 02, 2016 8:40 pm    Post subject: Reply with quote

kontact-USE-Flag entfernt und nicht mehr benutzte Programme deinstalliert, nun geht's wieder...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum