Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No sound from M5A97 PLUS [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Sun Jan 03, 2016 6:24 am    Post subject: No sound from M5A97 PLUS [solved] Reply with quote

No sound from the audio output on motherboard.

Motherboard:
Manufacturer: ASUSTeK COMPUTER INC.
Product Name: M5A97 PLUS
Version: Rev X.0x

lspci -k
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
Subsystem: ASUSTeK Computer Inc. SBx00 Azalia (Intel HDA)
Kernel driver in use: snd_hda_intel

Gnome3 Setting>ASound shows Dummy output.

uname -a
Linux ciclo 4.1.12-gentoo #7 SMP Sat Jan 2 12:37:20 2016 x86_64 AMD FX(tm)-4350 Quad-Core Processor AuthenticAMD GNU/Linux
ciclo linux #

I followed the pulseaudio directions. https://wiki.gentoo.org/wiki/PulseAudio

I've installed Gnome3 with systemd and thought I set up the kernel.

Code:

# cat /usr/src/linux/.config | grep HDA
CONFIG_SND_HDA=y
CONFIG_SND_HDA_INTEL=y
CONFIG_SND_HDA_PREALLOC_SIZE=2048
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_PATCH_LOADER=y
# CONFIG_SND_HDA_CODEC_REALTEK is not set
# CONFIG_SND_HDA_CODEC_ANALOG is not set
# CONFIG_SND_HDA_CODEC_SIGMATEL is not set
# CONFIG_SND_HDA_CODEC_VIA is not set
# CONFIG_SND_HDA_CODEC_HDMI is not set
CONFIG_SND_HDA_I915=y
# CONFIG_SND_HDA_CODEC_CIRRUS is not set
# CONFIG_SND_HDA_CODEC_CONEXANT is not set
# CONFIG_SND_HDA_CODEC_CA0110 is not set
# CONFIG_SND_HDA_CODEC_CA0132 is not set
# CONFIG_SND_HDA_CODEC_CMEDIA is not set
# CONFIG_SND_HDA_CODEC_SI3054 is not set
# CONFIG_SND_HDA_GENERIC is not set
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0
CONFIG_SND_HDA_CORE=y
# CONFIG_SENSORS_HDAPS is not set




Any ideas?
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Sun Jan 03, 2016 3:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Sun Jan 03, 2016 8:41 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-6339697.html#6339697
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3954
Location: Dallas area

PostPosted: Sun Jan 03, 2016 10:58 am    Post subject: Reply with quote

CONFIG_SND_HDA=m
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_CODEC_REALTEK=m
CONFIG_SND_HDA_GENERIC=m
CONFIG_SND_HDA_CORE=m
CONFIG_SND_HDA_PREALLOC_SIZE=64

I've got an M5a99fx board, same audio chipset
I think that you need to set the realtek codec "on"
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
cwc
Veteran
Veteran


Joined: 20 Mar 2006
Posts: 1107
Location: Tri-Cities, WA USA

PostPosted: Sun Jan 03, 2016 3:17 pm    Post subject: Reply with quote

Thank you so much for the help!

I got the hdmi audio to work and the line out on my motherboard. Nice. (I'm using an old hdmi Toshiba)

I installed realtek as part of my kernel .


Code:

$ cat /proc/asound/card0/codec#0 | head
Codec: Realtek ALC887-VD
Address: 0
AFG Function Id: 0x1 (unsol 1)
Vendor Id: 0x10ec0887
Subsystem Id: 0x10438576
Revision Id: 0x100302
No Modem Function Group found
Default PCM:
    rates [0x5f0]: 32000 44100 48000 88200 96000 192000
    bits [0xe]: 16 20 24

cwc@ciclo ~ $ cat /proc/asound/card1/codec#0 | head
Codec: Nvidia ID 1c
Address: 0
AFG Function Id: 0x1 (unsol 0)
Vendor Id: 0x10de001c
Subsystem Id: 0x19da6222
Revision Id: 0x100100
No Modem Function Group found
Default PCM:
    rates [0x0]:
    bits [0x0]:
cwc@ciclo ~ $




_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum