Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]postfix-SMTP authentication (SASL)-Cut off username
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kingfame_147
Apprentice
Apprentice


Joined: 11 Oct 2008
Posts: 171

PostPosted: Tue Jan 05, 2016 4:46 pm    Post subject: [SOLVED]postfix-SMTP authentication (SASL)-Cut off username Reply with quote

Hi,

it's hard to describe the problem in only one line (topic).

I've setup a postfix server using courier for IMAP which works just fine.

I'm having problems with the SMTP authentication. Whenever I try to authenticate (my usernames are like "firstlast@domain.com") SASL is using "firstlast" as a username, so it cuts of the @domain.com, which leads to the problem that the user is not found and therefore the authentication fails. I changed the login name to only "firstlast" and the authentication works without any problems. Do you have any idea at which step the @domain could get cut off?

I'm using sasld via pam_mysql. Here is a log sample:

Code:

Jan  5 17:43:37 d_mail postfix/smtpd[132]: xsasl_cyrus_server_first: decoded initial response
Jan  5 17:43:37 d_mail saslauthd[27]: rel_accept_lock : released accept lock
Jan  5 17:43:37 d_mail saslauthd[13]: get_accept_lock : acquired accept lock
Jan  5 17:43:37 d_mail saslauthd[27]: pam_mysql - SELECT returned no result.
Jan  5 17:43:37 d_mail saslauthd[27]: pam_mysql - SELECT returned no result.
Jan  5 17:43:37 d_mail saslauthd[27]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module
Jan  5 17:43:37 d_mail saslauthd[27]: do_auth         : auth failure: [user=webmaster] [service=smtp] [realm=domain.com] [mech=pam] [reason=PAM auth error]
Jan  5 17:43:37 d_mail postfix/smtpd[132]: warning: SASL authentication failure: Password verification failed
Jan  5 17:43:37 d_mail postfix/smtpd[132]: warning: static.xxx.clients.your-server.de[136.243.xxx.xxx]: SASL PLAIN authentication failed: authentication failure
Jan  5 17:43:37 d_mail postfix/smtpd[132]: > static.xxx.clients.your-server.de[136.243.xxx.xxx]: 435 4.7.8 Error: authentication failed: authentication failure


The username I did the authentication with was "webmaster@domain.com". I changed my domain to domain.com ofc, for obv. reasons.

Any ideas?

I've to run to get to a meeting, I will post the config files within the next 2 hours, sorry for that.


Thanks,
Felix


Last edited by kingfame_147 on Tue Jan 05, 2016 6:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 467
Location: Somewhere in Denmark

PostPosted: Tue Jan 05, 2016 5:02 pm    Post subject: Reply with quote

I've found a few suggestions of starting saslauthd with -r

http://sourceforge.net/p/pam-mysql/discussion/17691/thread/795a3188/?limit=25

http://lists.freebsd.org/pipermail/freebsd-questions/2004-July/054117.html

dunno if that helps?
Back to top
View user's profile Send private message
kingfame_147
Apprentice
Apprentice


Joined: 11 Oct 2008
Posts: 171

PostPosted: Tue Jan 05, 2016 6:36 pm    Post subject: Reply with quote

You are the man!

I totally overlooked that option. I was searching in like all 100 different config files for bad SQL queries, etc. My google skills were not on point I guess.

Thanks a million!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum