Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound in headphones work 10% of the time
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Elv13
Guru
Guru


Joined: 13 Nov 2005
Posts: 388
Location: Socialist land of North America

PostPosted: Tue Jan 05, 2016 11:13 pm    Post subject: Sound in headphones work 10% of the time Reply with quote

Hello, this is a strange one,

I am using ALSA (without pulse). When I play music, it always work in the laptop speaker. However, when I plug the headphone, it only work 10% of the time. When it doesn't work, I may have to reboot up to 5 time until it work (seem random). I do hear a "click" in the headphone when the sound is activated, but it is not playing. If I unplug the headphone, it will play in the speaker without issue (so it is not related to a sound card lock).

Unpluging the headphone will send the music to the speaker as expected.

Once it work, it will keep working, even if I stop and restart music.

If I keep plugging and unplugging the headphone, _sometime_ it will eventually start working, but it is very, very rare.

Alsamixer show no muted device or channel, dmesg show nothing when plugging headphones (as expected)

I keep thinking this might be an UEFI problem as I can't find an actual driver for the process. However, I can't find anybody else with the issue. the laptop is a Lenovo W540.

Any idea?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6313
Location: /usr/lib64/lv2

PostPosted: Sun Jan 24, 2016 5:57 pm    Post subject: Reply with quote

My first thought is faulty hardware. Does your headphone jack work consistently if you boot with any kind of livecd?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum