Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mounting an exFAT USB stick as user fails with fuse
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1181
Location: Stuttgart, Germany

PostPosted: Fri Jan 08, 2016 8:40 pm    Post subject: mounting an exFAT USB stick as user fails with fuse Reply with quote

probably a dumb problem, but here goes:

I have a USB stick I formatted to exFAT (for carrying around videos of my sick kung-fu moves and skateboard tricks DON'T JUDGE ME). AFAICT, mounting exFAT requires the fuse kernel module, yes? When I try to mount the stick as a user, I get
Code:
 $ mount /mnt/usb
FUSE exfat 1.2.3
ERROR: failed to open '/dev/sdd1': Permission denied.

If I try to mount it as root, I get a successful mount. If I try fusermount, I get
Code:
 $ fusermount /mnt/usb
fusermount: old style mounting not supported


So what am I doing wrong here?

Cheers,

EE
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sun Jan 10, 2016 3:30 pm    Post subject: Reply with quote

Maybe your user is not allowed to access the device? Does your fstab contain the "user" or "users" option for /dev/sdd1?
Can that user mount other fuse filesystems, e.g. sshfs?
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1181
Location: Stuttgart, Germany

PostPosted: Sun Jan 10, 2016 3:36 pm    Post subject: Reply with quote

fstab for the stick reads:

Code:
/dev/sdd1               /mnt/usb        auto            user,user,users,exec,noauto,noatime     0 0


I have just for this one purpose installed the fuse kernel module. I don't think I have any other fuse filesystems.

Am I doing something wrong here?

Cheers,

EE
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sun Jan 10, 2016 3:48 pm    Post subject: Reply with quote

fstab looks ok

What are the permissions of /dev/fuse? Do you have CONFIG_TMPFS_POSIX_ACL enabled in your kernel?
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1181
Location: Stuttgart, Germany

PostPosted: Sun Jan 10, 2016 4:07 pm    Post subject: Reply with quote

Code:
 # grep CONFIG_TMPFS_POSIX_ACL /usr/src/linux/.config
CONFIG_TMPFS_POSIX_ACL=y
# ls -l /dev/fuse
crw-rw-rw- 1 root root 10, 229  8. Jan 21:29 /dev/fuse


Should I change the group on that so regular users have access to it?

Cheers,

EE
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Sun Jan 10, 2016 4:40 pm    Post subject: Reply with quote

The fuse device node is world rw, so every user can already access it.

Maybe copying /usr/portage/sys-fs/fuse-exfat/files/99-exfat.rules to /etc/udev/rules.d/ and then reloading udev rules will help.
Back to top
View user's profile Send private message
Kalin
Tux's lil' helper
Tux's lil' helper


Joined: 22 Dec 2002
Posts: 122
Location: Germany

PostPosted: Wed Jan 20, 2016 12:19 pm    Post subject: Re: mounting an exFAT USB stick as user fails with fuse Reply with quote

ExecutorElassus wrote:
probably a dumb problem, but here goes:

I have a USB stick I formatted to exFAT (for carrying around videos of my sick kung-fu moves and skateboard tricks DON'T JUDGE ME). AFAICT, mounting exFAT requires the fuse kernel module, yes? When I try to mount the stick as a user, I get
Code:
 $ mount /mnt/usb
FUSE exfat 1.2.3
ERROR: failed to open '/dev/sdd1': Permission denied.

So what are the permissions on /dev/sdd1 then?
Code:

ls -lsa /dev/sdd1
whoami
groups

When debugging permission problems, running the command under strace usually helps.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1181
Location: Stuttgart, Germany

PostPosted: Wed Jan 20, 2016 12:44 pm    Post subject: Reply with quote

Code:
 $ ls -lsa /dev/sdd1
0 brw-rw---- 1 root disk 8, 49 20. Jan 13:35 /dev/sdd1
I'll add my user to the "disk" group, and try…
--LATER--
okay, now I can mount it, but I get
Code:
$ mount /mnt/usb
FUSE exfat 1.2.3
fusermount: user has no write access to mountpoint /mnt/usb

even though /mnt/usb has "user,users" as options in /etc/fstab. Does fusermount manage those options differently somehow?

Cheers,

EE
Back to top
View user's profile Send private message
Kalin
Tux's lil' helper
Tux's lil' helper


Joined: 22 Dec 2002
Posts: 122
Location: Germany

PostPosted: Wed Jan 20, 2016 1:01 pm    Post subject: Reply with quote

chgrp disk /mnt/usb && chmod 775 /mnt/usb
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1181
Location: Stuttgart, Germany

PostPosted: Wed Jan 20, 2016 1:13 pm    Post subject: Reply with quote

did that, now I have this sequence:

Code:
 $ mount /mnt/usb
FUSE exfat 1.2.3
fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
elassus@domo-kun ~ $ su
Password:
domo-kun elassus # nano /etc/fuse.conf
domo-kun elassus # exit
exit
elassus@domo-kun ~ $ mount /mnt/usb
FUSE exfat 1.2.3
fusermount: option blkdev is privileged
I only see answers for mounting ntfs systems; I'm not sure what this error means in my case. What's my next step?

Cheers,

EE
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Jan 20, 2016 4:20 pm    Post subject: Reply with quote

you may post your

/etc/fuse.conf

or check for a man-page for that fuse.conf and especially that setting the other user suggested.

deactivated option
Quote:
cat /etc/fuse.conf
# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
#user_allow_other


Usually a # at the start is a comment. so in your case you probably have the same config file and you should change it to something like this

Should be:

Code:
cat /etc/fuse.conf
# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#
#mount_max = 1000

# Allow non-root users to specify the 'allow_other' or 'allow_root'
# mount options.
#
user_allow_other
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum