Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot fetch qtcore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Wed Jan 13, 2016 12:49 pm    Post subject: Cannot fetch qtcore Reply with quote

I've decided to try KDE 5 / Plasma, and have been following the instructions at https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade
Resolving the resulting multiple dependencies has led me to poppler (seems poppler breaks every emerge ...), and resolving that seems to show that qtcore cannot be fetched (see below).

Thoughts?

Code:
# emerge --backtrack=99 --verbose-conflicts --oneshot =app-text/poppler-0.39.0:0/58 net-print/cups-filters app-text/texlive-core

 * IMPORTANT: 19 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 6) dev-qt/qtcore-5.9999::qt
>>> Unpacking source...
 * Fetching git://gitorious.org/qt/qtbase.git ...
git fetch git://gitorious.org/qt/qtbase.git +refs/heads/dev:refs/heads/dev
fatal: unable to connect to gitorious.org:
gitorious.org[0: 2a02:c0:1014::1]: errno=Connection timed out
gitorious.org[1: 109.107.38.78]: errno=No route to host

 * Fetching https://git.gitorious.org/qt/qtbase.git ...
git fetch https://git.gitorious.org/qt/qtbase.git +refs/heads/dev:refs/heads/dev
fatal: repository 'https://git.gitorious.org/qt/qtbase.git/' not found
 * ERROR: dev-qt/qtcore-5.9999::qt failed (unpack phase):
 *   Unable to fetch from any of EGIT_REPO_URI
 *
 * Call stack:
 *     ebuild.sh, line   90:  Called src_unpack
 *   environment, line 3049:  Called qt5-build_src_unpack
 *   environment, line 2777:  Called git-r3_src_unpack
 *   environment, line 1933:  Called git-r3_src_fetch
 *   environment, line 1927:  Called git-r3_fetch
 *   environment, line 1849:  Called die
 * The specific snippet of code:
 *       [[ -n ${success} ]] || die "Unable to fetch from any of EGIT_REPO_URI";
 *
 * If you need support, post the output of `emerge --info '=dev-qt/qtcore-5.9999::qt'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-5.9999::qt'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-5.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-5.9999/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtcore-5.9999/work'
 * S: '/var/tmp/portage/dev-qt/qtcore-5.9999/work/qtcore-5.9999'

>>> Failed to emerge dev-qt/qtcore-5.9999, Log file:

>>>  '/var/tmp/portage/dev-qt/qtcore-5.9999/temp/build.log'
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Jan 13, 2016 2:57 pm    Post subject: Reply with quote

The Plasma-5 upgrade guide did not advise you to unmask qt-5.9999 - why do you have the qt overlay installed at all?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Wed Jan 13, 2016 3:05 pm    Post subject: Reply with quote

Ah that was it - I must have left that last time I tried QT5.

Overlay removed, it's working now - thanks!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Wed Jan 13, 2016 3:08 pm    Post subject: Reply with quote

Also check your package.keywords and package.unmask files, you must have some dev-qt/* ** unmask lingering around. Just to be safe in the future. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Thu Jan 14, 2016 7:36 pm    Post subject: Reply with quote

Hm, still no bueno. It took a *lot* of individual unmerging of conflicting packages to get everything all emerged correctly - especially libdbusmenu-qt - and it just reinstalled all the kde4 stuff anyway ...

I'm a bit confused - all the version 5 seemed to install, but kdm is still running kdeinit4, dbus still not attached, none of the WMs work (still using awesome), and all the configs seem to still be KDE4 - is there a separate process to install and configure the actual session/window manager?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Jan 14, 2016 8:26 pm    Post subject: Reply with quote

Did you miss the 'Installation' part?

What was the problem with libdbusmenu-qt, exactly? I can only think of a blocker in case you were still using 0.9.3_pre20140619, while 0.9.3_pre20140619-r1 is already stable which does not have a REQUIRED_USE anymore.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Thu Jan 14, 2016 8:51 pm    Post subject: Reply with quote

Nope:

Code:
# emerge kde-plasma/plasma-meta
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) kde-plasma/plasma-meta-5.5.3::kde
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/work
>>> Preparing source in /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/work ...
>>> Source compiled.
>>> Test phase [not enabled]: kde-plasma/plasma-meta-5.5.3

>>> Install plasma-meta-5.5.3 into /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/image/ category kde-plasma
>>> Completed installing plasma-meta-5.5.3 into /var/tmp/portage/kde-plasma/plasma-meta-5.5.3/image/


>>> Installing (1 of 1) kde-plasma/plasma-meta-5.5.3::kde
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


You are correct, the -r1 version conflicted with the KDE5 dependency on the non -r1 version because of a qt5 use.

The X greeter seems to be new, but nothing other than "awesome" works (not even Failsafe). Various other oddness, and konsole is gone, too (did KDE5 rename the terminal app?):

Code:
# cat /var/log/kdm.log
********************************************************************************
Note that your system uses syslog. All of kdm's internally generated messages
(i.e., not from libraries and external programs/scripts it uses) go to the
daemon.* syslog facility; check your syslog configuration to find out to which
file(s) it is logged. PAM logs messages related to authentication to authpriv.*.
********************************************************************************

kdmgreet(29777) KdmPixmap::definePixmap: Cannot find wallpaper "Elarun"
klauncher(29783) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(29777)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server"

kdmgreet(29777)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
xiombarg ~ # /etc/runlevels/default/dbus status
 * status: started
xiombarg ~ # ps -ef | grep dbus
message+  1100     1  0 Jan01 ?        00:00:07 /usr/bin/dbus-daemon --system
root     14562 13421  0 15:33 pts/1    00:00:00 grep --colour=auto dbus
urmane   30380     1  0 14:14 ?        00:00:00 /usr/bin/dbus-launch --sh-syntax --exit-with-session
urmane   30381     1  0 14:14 ?        00:00:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
xiombarg ~ # which konsole
which: no konsole in (/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/i686-pc-linux-gnu/gcc-bin/4.9.3)
xiombarg ~ # emerge -s konsole
 
[ Results for search key : konsole ]
Searching...

*  kde-apps/konsole
      Latest version available: 4.14.3
      Latest version installed: 4.14.3
      Size of files: 445 KiB
      Homepage:      https://www.kde.org/applications/system/konsole https://konsole.kde.org
      Description:   X terminal for use with KDE
      License:       GPL-2

*  kde-apps/konsolekalendar
      Latest version available: 4.14.8
      Latest version installed: [ Not Installed ]
      Size of files: 14235 KiB
      Homepage:      https://www.kde.org/ https://userbase.kde.org/KonsoleKalendar
      Description:   A command line interface to KDE calendars
      License:       GPL-2

*  kde-apps/konsolepart [ Masked ]
      Latest version available: 4.14.3
      Latest version installed: [ Not Installed ]
      Size of files: 445 KiB
      Homepage:      https://www.kde.org/applications/system/konsole https://konsole.kde.org
      Description:   X terminal kpart for use by konsole and other KDE applications
      License:       GPL-2

*  kde-misc/quadkonsole [ Masked ]
      Latest version available: 0.4.4-r1
      Latest version installed: [ Not Installed ]
      Size of files: 67 KiB
      Homepage:      http://kb.ccchl.de/quadkonsole4/
      Description:   Grid of Konsole terminals
      License:       GPL-2

# equery f konsole
 * Searching for konsole ...
 * Contents of kde-apps/konsole-4.14.3:
/usr
/usr/bin
/usr/lib
/usr/lib/kde4
/usr/lib/kde4/libkonsolepart.so
/usr/lib/libkdeinit4_konsole.so
/usr/lib/libkonsoleprivate.so
/usr/share
/usr/share/applications
/usr/share/applications/kde4
/usr/share/applications/kde4/konsole.desktop
/usr/share/apps
/usr/share/apps/kconf_update
/usr/share/apps/kconf_update/konsole-2.10.0-remove-menuindex-from-profiles.sh
/usr/share/apps/kconf_update/konsole-2.9.0-colorscheme-bold-key.sh
/usr/share/apps/kconf_update/konsole-2.9.0-global-options.sh
/usr/share/apps/kconf_update/konsole.upd
/usr/share/apps/kconf_update/konsole_remove_background_mode.upd
/usr/share/apps/konsole
/usr/share/apps/konsole/BlackOnLightYellow.colorscheme
/usr/share/apps/konsole/BlackOnRandomLight.colorscheme
/usr/share/apps/konsole/BlackOnWhite.colorscheme
/usr/share/apps/konsole/BlueOnBlack.colorscheme
/usr/share/apps/konsole/DarkPastels.colorscheme
/usr/share/apps/konsole/GreenOnBlack.colorscheme
/usr/share/apps/konsole/Linux.colorscheme
/usr/share/apps/konsole/README.KeyTab
/usr/share/apps/konsole/RedOnBlack.colorscheme
/usr/share/apps/konsole/Shell.profile
/usr/share/apps/konsole/Solarized.colorscheme
/usr/share/apps/konsole/SolarizedLight.colorscheme
/usr/share/apps/konsole/WhiteOnBlack.colorscheme
/usr/share/apps/konsole/default.keytab
/usr/share/apps/konsole/konsole.notifyrc
/usr/share/apps/konsole/konsoleui.rc
/usr/share/apps/konsole/linux.keytab
/usr/share/apps/konsole/partui.rc
/usr/share/apps/konsole/sessionui.rc
/usr/share/apps/konsole/solaris.keytab
/usr/share/doc
/usr/share/doc/konsole-4.14.3
/usr/share/doc/konsole-4.14.3/README.bz2
/usr/share/kde4
/usr/share/kde4/services
/usr/share/kde4/services/ServiceMenus
/usr/share/kde4/services/ServiceMenus/konsolehere.desktop
/usr/share/kde4/services/ServiceMenus/konsolerun.desktop
/usr/share/kde4/services/konsolepart.desktop
/usr/share/kde4/servicetypes
/usr/share/kde4/servicetypes/terminalemulator.desktop
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Jan 14, 2016 8:57 pm    Post subject: Reply with quote

OK, in case of libdbusmenu-qt it might just have been portage not properly getting the depgraph (maybe too low backtrack value) since the (available) upgrade would have been the solution to the conflict.

Hmm the upgrade wiki doesn't mention it, but KDM is obsolete. There won't be any more updates. It does tell you to configure sddm though, which by default comes with installation of plasma-meta. Look up 'Displaymanager' part of the guide.

konsole:5, kwrite:5 and dolphin:5 are currently not pulled in automatically after the upgrade, this is going to be solved soon. Please upgrade to kdebase-meta-4.14.3-r2 in case you use that package (you will probably need to unmask it, as a stable user), you will continue to work with konsole:4 until an updated kdebase-meta:5 hits the tree.

Please note that KDE4-based packages are going to stay on your system for some time.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Thu Jan 14, 2016 9:49 pm    Post subject: Reply with quote

It's odd you say that - kdebase-meta-4 had to be removed to get a successful "emerge world" (which just put it back anyway), and now "emerge --depclean" is removing 200+ of the KDE4 packages....

I'll go through another round of emerge -uDN @world and emerge --depclean and see how it goes. Thanks for you help so far, genstorm.
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Thu Jan 14, 2016 9:50 pm    Post subject: Reply with quote

Yes, it does say to install sddm, but it's not worded well - my bad for not reading carefully.

Fixed, but I'm going to make sure emerge is happy and things look good before I log out of X :-)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Thu Jan 14, 2016 9:55 pm    Post subject: Reply with quote

jimniemira wrote:
It's odd you say that - kdebase-meta-4 had to be removed to get a successful "emerge world" (which just put it back anyway), and now "emerge --depclean" is removing 200+ of the KDE4 packages....

That's happening because you are coming from a stable system. KDE4 needs one last round of stabilisation, until all the packages are in place that will enable a painless upgrade. :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Fri Jan 15, 2016 1:58 am    Post subject: [SOLVED] Cannot fetch qtcore / Plasma hangs on login Reply with quote

Ok, I've got it running now. KDE5 / Plasma was freezing / hanging on login, and the only clue I could find was this in my .xsession-errors:

Code:
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Unrecognized OpenGL version
Unrecognized OpenGL version


Other GL programs like glxgears caused the same thing. Some google research pointed me at the nvidia libs - I reinstalled the nvidia-drivers, no dice, but then saw that I was using /usr/lib/libGL.so, instead of /usr/lib/opengl/nvidia/lib/libGL.so.

That last is in /etc/env.d/000opengl, but it looks like LDPATH doesn't make it to /etc/profile.env, so my shells don't see that path.

It is first in /etc/ld.so.cache, though - verified with an env-update and a 'strings /etc/ld.so.cache | grep libGL.so', so zeroing out my own LD_LIBRARY_PATH allowed glxgears to work, commenting out LD_LIBRARY_PATH in my .bashrc allows Plasma to start up correctly from login.

Thanks for all your help genstorm!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Fri Jan 15, 2016 8:56 am    Post subject: Reply with quote

One thing that is likely needed is you adding the sddm user to the video group. Wrt nvidia-drivers I can't help much, but I recall there was some conflicts wrt recent xorg-server or mesa updates.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
jimniemira
n00b
n00b


Joined: 13 Jan 2016
Posts: 9

PostPosted: Fri Jan 15, 2016 4:16 pm    Post subject: Reply with quote

sddm was in video group, yes - the issue appears to be that Mesa adds /usr/lib/libGL.so which, if you have nvidia-drivers, does not work - /usr/lib/opengl/nvidia/lib/libGL.so must be found first, whether via ld.so.cache or by manipulating your LD_LIBRARY_PATH.

WRT konsole, I cannot go back to kdebase-meta-4, as it's blocked by wallpapers and checkpass - request your thoughts on how to proceed, don't want to break a now-working Plasma :-)

Code:
# emerge -p kdebase-meta

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-base/kdebase-pam-9
..... <lots of other packages listed here> .......
[ebuild  N     ] kde-apps/konsole-4.14.3  USE="minimal (-aqua) -debug -handbook {-test}"
[ebuild  N     ] kde-apps/plasma-apps-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-base/libplasmaclock-4.11.19  USE="kdepim (-aqua) -debug"
[ebuild  N     ] kde-apps/kdebase-data-4.14.3-r1  USE="wallpapers (-aqua)"
[ebuild  N     ] kde-apps/plasma-runtime-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-apps/konqueror-4.14.3  USE="bookmarks handbook svg (-aqua) -debug"
[ebuild  N     ] kde-apps/baloo-widgets-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-apps/nsplugins-4.14.3  USE="(-aqua) -debug"
[ebuild  N     ] kde-apps/dolphin-4.14.3  USE="handbook semantic-desktop (-aqua) -debug -thumbnail"
[ebuild  N     ] kde-apps/konq-plugins-4.14.3  USE="(-aqua) -debug -tidy"
[ebuild  N     ] kde-apps/kdebase-runtime-meta-4.14.3  USE="handbook minimal (-aqua) -crash-reporter"
[ebuild  N     ] kde-apps/kdebase-meta-4.14.3  USE="display-manager minimal wallpapers (-aqua)"
[blocks B      ] <kde-apps/kde-wallpapers-15.08.3[-minimal(-)] ("<kde-apps/kde-wallpapers-15.08.3[-minimal(-)]" is blocking kde-plasma/plasma-workspace-wallpapers-5.5.3)
[blocks B      ] <kde-base/kcheckpass-4.11.22-r1:4 ("<kde-base/kcheckpass-4.11.22-r1:4" is blocking kde-plasma/kscreenlocker-5.5.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-apps/kde-wallpapers-4.14.3:4/4.14::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-apps/kde-wallpapers-4.14.3:4[aqua=] (>=kde-apps/kde-wallpapers-4.14.3:4[-aqua]) required by (kde-apps/kdebase-data-4.14.3-r1:4/4.14::gentoo, ebuild scheduled for merge)
    >=kde-apps/kde-wallpapers-4.11:4[aqua=] (>=kde-apps/kde-wallpapers-4.11:4[-aqua]) required by (kde-apps/kdebase-meta-4.14.3:4/4::gentoo, ebuild scheduled for merge)

  (kde-base/kcheckpass-4.11.19:4/4.11::gentoo, ebuild scheduled for merge) pulled in by
    >=kde-base/kcheckpass-4.11:4[aqua=] (>=kde-base/kcheckpass-4.11:4[-aqua]) required by (kde-apps/kdebase-meta-4.14.3:4/4::gentoo, ebuild scheduled for merge)
    >=kde-base/kcheckpass-4.11.19:4[aqua=] (>=kde-base/kcheckpass-4.11.19:4[-aqua]) required by (kde-base/kscreensaver-4.11.19:4/4.11::gentoo, ebuild scheduled for merge)

  (kde-plasma/plasma-workspace-wallpapers-5.5.3:5/5::kde, installed) pulled in by
    >=kde-plasma/plasma-workspace-wallpapers-5.5.3:5 required by (kde-plasma/plasma-meta-5.5.3:5/5::kde, installed)

  (kde-plasma/kscreenlocker-5.5.3:5/5::kde, installed) pulled in by
    >=kde-plasma/kscreenlocker-5.5.3:5 required by (kde-plasma/plasma-meta-5.5.3:5/5::kde, installed)
    >=kde-plasma/kscreenlocker-5.5.3:5 required by (kde-plasma/plasma-workspace-5.5.3:5/5::kde, installed)
    >=kde-plasma/kscreenlocker-5.5.3:5 required by (kde-plasma/kwin-5.5.3:5/5::kde, installed)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Fri Jan 15, 2016 4:49 pm    Post subject: Reply with quote

genstorm wrote:
Please upgrade to kdebase-meta-4.14.3-r2 in case you use that package (you will probably need to unmask it, as a stable user)

;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum