Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems with grub and efivars
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 12 Jan 2016
Posts: 2

PostPosted: Tue Jan 12, 2016 5:30 pm    Post subject: [SOLVED] Problems with grub and efivars Reply with quote

I'm having problems with sys-libs/efivar-0.21 during grub install, i get "linux.c:25:24: fatal error: linux/nvme.h: No such file or directory".

It happens during grub install, in a fresh install, in chroot enviroment, i can't install the bootloader, i can't start up my new system.... I'm very thanks for help.

emerge --info '=sys-libs/efivar-0.21::gentoo:
System uname: Linux-3.13.0-74-generic-x86_64-Intel-R-_Core-TM-_i5-3230M_CPU_@_2.60GHz-with-gentoo-2.2
KiB Mem: 7989636 total, 1152784 free
KiB Swap: 1998844 total, 1998556 free
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
ccache version 3.2.4 [enabled]
app-shells/bash: 4.3_p42-r1::gentoo
dev-lang/perl: 5.22.1::gentoo
dev-lang/python: 2.7.11-r2::gentoo
dev-util/ccache: 3.2.4::gentoo
dev-util/cmake: 3.4.1::gentoo
dev-util/pkgconfig: 0.29::gentoo
sys-apps/baselayout: 2.2::gentoo
sys-apps/openrc: 0.19.1::gentoo
sys-apps/sandbox: 2.10-r1::gentoo
sys-devel/autoconf: 2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake: 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r1::gentoo
sys-devel/binutils: 2.25.1-r1::gentoo
sys-devel/gcc: 5.3.0::gentoo
sys-devel/gcc-config: 1.8::gentoo
sys-devel/libtool: 2.4.6-r1::gentoo
sys-devel/make: 4.1-r1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc: 2.22-r1::gentoo

location: /usr/portage
sync-type: git
priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=ivybridge -mtune=ivybridge -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=ivybridge -mtune=ivybridge -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 bindist branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cxx dbus dri dts dvd dvdr encode exif fam flac fortran gdbm gif glamor gpm gticonv gtk iconv ipv6 jpeg lcms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio readline sdl seccomp session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pt_BR" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 pythoon3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"


Last edited by demiank on Fri Jan 15, 2016 12:05 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 09 Dec 2006
Posts: 7593
Location: Goose Creek SC

PostPosted: Thu Jan 14, 2016 4:45 pm    Post subject: Reply with quote

problem linux-headers-4.4
I find same problem attempting to emerge efivar-0.21 with gcc-5.3 and linux-headers-4.4 on a machine that already has a working copy of efivar-0.21.
I do not have the same problem on another machine that has not been "upgraded" to gcc-5.3 or linux-headers-4.4; emerge efivar-0.21 works nicely. This is true even after removing efivar directory from /usr/portage/sys-libs and efivar-0.21.tar.bz2 from /usr/portage/distfiles and running emerge --sync and emerge efivar to use a fresh ebuild and source file. emerge linux-headers-4.4 followed by emerge efivar on the good machine produces the problem.

Choices: file a bug (already done: ) and wait for a fix or add ' sys-kernel/linux-headers amd64 ' to /etc/portage/keywords, then emerge linux-headers and emerge efivar This will revert to linux-headers-3.18 and allow efivar-0.21 to install.
Defund the FCC.
Back to top
View user's profile Send private message

Joined: 12 Jan 2016
Posts: 2

PostPosted: Fri Jan 15, 2016 12:04 am    Post subject: Solved Reply with quote

Unninstalling linux-headers-4.4 and masking it, installing 4.3 version, solved the problem.....
Thanks. DONAHUE.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum