Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unixODBC GUI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Thu Jan 14, 2016 2:27 am    Post subject: unixODBC GUI Reply with quote

Hi, ALL,
I am trying to see where is the packet for the unixODBC GUI.

It looks like this is what I need but it's package version is 9999.
Also it would be nice if there will be a "gui" USE-flag for "unixODBC" in order to install GUI...

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Thu Jan 14, 2016 11:54 am    Post subject: Reply with quote

Moreover, it looks like layman does not know anything about such overlay:

Code:

IgorDellGentoo lib # layman -L | grep qt-overlay
IgorDellGentoo lib #


Any idea how to get that?

Thyank you.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1740
Location: Here and Away Again

PostPosted: Thu Jan 14, 2016 2:33 pm    Post subject: ><)))°€ Reply with quote

The qt-overlay there looks like an old copy of a qt-overlay (last changes are from 2012), indeed not available via layman.

It is possible to add such overlays, but I believe it would make more sense to add only that single ebuild (into a local overlay), and see if it still works. I did a quick test run here, but it fails during linking phase, with lots of SQL-related undefined references (I don't have any mysql (or equivalent) packages installed, which I guess might explain it).

There are some even older ebuilds around at Zugaina for example, but those go so far back as Qt3...
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Thu Jan 14, 2016 5:08 pm    Post subject: Reply with quote

Hi, Chiitoo,

I will trey to add this ebuild into my rainyday overlay and check. It shouldn't depend on any DB, you only need to have unixODBC installed.

I will try that tonight and report back.

Thank you.

P.S.: Maybe it will make sense to introduce the "gui" USE-flag to unixODBC and merge this packet in the unixODBC ebuuild?
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1740
Location: Here and Away Again

PostPosted: Thu Jan 14, 2016 7:38 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
I will trey to add this ebuild into my rainyday overlay and check. It shouldn't depend on any DB, you only need to have unixODBC installed.

Hm. That's somewhat surprising. No idea about the linking failure then, though I did take only a quick look after all (I did install dev-db/unixODBC first).

Quote:
P.S.: Maybe it will make sense to introduce the "gui" USE-flag to unixODBC and merge this packet in the unixODBC ebuuild?

It definitely seems like something that would make sense, if things work, and if we find someone to push it to the tree. ^^
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Thu Jan 14, 2016 9:10 pm    Post subject: Reply with quote

I believe "Michael Palimaka" is kensington, though I might be wrong; either way kensington's a helpful developer, who hangs out with others in #gentoo-desktop on IRC: chat.freenode.net or .org.

If you want an updated ebuild in-tree, or merged, perhaps under USE=qt, then that's where I'd start.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1740
Location: Here and Away Again

PostPosted: Thu Jan 14, 2016 11:37 pm    Post subject: Reply with quote

steveL, I believe you're correct!

Also... moved from Portage & Programming to Unsupported Software, as this is (at least for the time being) discussion about an ebuild not in Portage (yet).
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2769

PostPosted: Fri Jan 15, 2016 4:38 am    Post subject: Reply with quote

Hi, guys,

Code:

IgorDellGentoo unixODBC-GUI-QT # ls -la
total 12
drwxr-xr-x 2 root root 4096 Jan 15 00:35 .
drwxr-xr-x 7 root root 4096 Jan 15 00:35 ..
-rw-r--r-- 1 root root  243 Jan 15 00:41 metadata.xml
-rw-r--r-- 1 root root  441 Jan 15 00:34 unixODBC-GUI-QT-9999.ebuild
IgorDellGentoo unixODBC-GUI-QT # ebuild digest unixODBC-GUI-QT-9999.ebuild
ebuild: digest: does not end with '.ebuild'
IgorDellGentoo unixODBC-GUI-QT # pwd
/var/lib/layman/rainyday/dev-db/unixODBC-GUI-QT
IgorDellGentoo unixODBC-GUI-QT #


What am I doing wrong?

Thank you.
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1696

PostPosted: Fri Jan 15, 2016 5:46 am    Post subject: Reply with quote

Code:
IgorDellGentoo unixODBC-GUI-QT # ebuild digest unixODBC-GUI-QT-9999.ebuild
ebuild: digest: does not end with '.ebuild'


wrong order, ebuild file then digest
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum