Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Configuring the network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Thu Jan 14, 2016 8:32 pm    Post subject: Configuring the network Reply with quote

i have followed all the previous steps, and now i'm at the "Configuring the network" stage in the install handbook, where i get this..

Code:
# emerge --ask --noreplace net-misc/netifrc
setlocale: unsupported locale setting
!!! SYNC setting found in make.conf.
    This setting is Deprecated and no longer used.  Please ensure your 'sync-type' and 'sync-uri' are set correctly in /etc/portage/repos.conf/gentoo.conf
setlocale: unsupported locale setting
!!! '--ask --noreplace' is not a valid package atom.
!!! Please check ebuild(5) for full details.


i did a search and it seems like i have that installed. but i can't seem to make sense of the output.[/code]
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu Jan 14, 2016 9:22 pm    Post subject: Reply with quote

josephg ...

there are a couple of issues there ... first the locale. I assume you've edited /etc/locale.gen, run 'locale-gen', and run 'eselect locale set {n}' (where '{n}' is number provided by 'eselect locale list'). Subsequently you've run 'env-update && source /etc/profile' ... correct? If yes, then please provide the output of 'locale' and 'locale -a'.

Secondly, you have 'SYNC' in make.conf ... this is now obsolete, comment it and add the following gentoo.conf (create the directory if it doesn't exist):

/etc/portage/repos.conf/gentoo.conf:
[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
sync-type = rsync
sync-uri = rsync://rsync.{COUNTRY_ID_HERE}.gentoo.org/gentoo-portage

... where '{COUNTRY_ID_HERE}' would be as you have in the now obsolete SYNC, ie 'us', 'de', or what-have-you.

HTH & best ... khay
Back to top
View user's profile Send private message
josephg
l33t
l33t


Joined: 10 Jan 2016
Posts: 783
Location: usually offline

PostPosted: Thu Jan 14, 2016 9:31 pm    Post subject: Reply with quote

thank you khay
those have been resolved in another thread.

/etc/portage/repos.conf/gentoo.conf:
[DEFAULT]
main-repo = gentoo

[gentoo]
location = /usr/portage
sync-type = git
sync-uri = https://github.com/gentoo-mirror/gentoo
auto-sync = yes


also i chroot in another terminal, and forgot to source /etc/profile

my concern was about these
Code:
!!! '--ask --noreplace' is not a valid package atom.
!!! Please check ebuild(5) for full details.

_________________
"Growth for the sake of growth is the ideology of the cancer cell." Edward Abbey
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum