Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound card lost after installing new graphics card
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sliwowitz
Apprentice
Apprentice


Joined: 21 Jan 2005
Posts: 197
Location: Europe/Prague

PostPosted: Sun Jan 17, 2016 8:31 am    Post subject: Sound card lost after installing new graphics card Reply with quote

I have an SB Audigy (emu10k1) soundcard in a machine which also has an integrated Intel HD audio, and a USB camera attached. The Audigy is my main sound card, but occasionally I would use one of others for some specific task. This setup has been working for many years with the snd_emu10k1 being set in /etc/modprobe.d at slot 0 with index 0, the snd_hda_intel at slot 1 index 1, and the usb driver somehow magically appearing at slot 2, no conflicts, everyone happy.

Code:
excerpts from /etc/modprobe.d/alsa.conf:

...
alias snd-card-0 snd-emu10k1
alias sound-slot-0 snd-emu10k1
options snd-emu10k1 index=0
...
alias snd-card-1 snd-hda-intel
alias sound-slot-1 snd-hda-intel
options snd-hda-intel index=1


Yesterday my old graphics card went to the silicon heaven so I installed an NVidia GTX 750. Since then my Audigy won't load.

Code:
thor etc # dmesg|grep snd
[    9.846603] snd_hda_intel 0000:01:00.1: Disabling MSI
[   10.084472] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC888: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
... (snip hda ins/outs details) ...
[   10.533454] snd_emu10k1 0000:08:02.0: cannot find the slot for index 0 (range 0-1), error: -16
[   10.534936] snd_emu10k1: probe of 0000:08:02.0 failed with error -16
[   11.479224] usbcore: registered new interface driver snd-usb-audio


It turns out slot 0 is occupied by the NVidia card (I presume this has to do with the HDMI port which was absent on the old card)
Code:
thor etc # cat /proc/asound/cards
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe87c000 irq 17
 1 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfcff8000 irq 33
 2 [Camera         ]: USB-Audio - USB 2.0 Camera
                      Sonix Technology Co., Ltd. USB 2.0 Camera at usb-0000:00:1d.7-4, high speed


Googling around seems to suggest two possible problems which I don't know how to solve:

A) I should correctly assign the slots/indexes
- I don't know how to do this since both the motherboard and the nvidia soundcards use snd_hda_intel which is already assigned to slot 1
B) I might have an IRQ conflict
- if this were the case I couldn't find any information on how to actually solve it

I can workaround this by disabling the motherboard soundcard in BIOS - the NVidia is then assigned slot 1 and my Audigy loads correctly. But I would like to have the onboard card enabled (I use its mic input for skype and occasionally I would route all VoIP through it when the audigy is hooked to jackd)
_________________
The question of whether Machines Can Think... is about as relevant as the question of whether Submarines Can Swim.
-- Edsger Dijkstra
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 504
Location: /dev/x0

PostPosted: Sun Jan 17, 2016 11:15 am    Post subject: Reply with quote

Quote:
aegis2 ~ # cat /proc/asound/cards
0 [Loopback ]: Loopback - Loopback
Loopback 1
1 [NVidia_1 ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xbeec4000 irq 21
2 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xbef7c000 irq 18


I have Nvidia Nforce controller and Nvidia GeForce VGA card with hdmi output. After installing card i just change output device in mate-volume-control that's all...
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum