Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
can't compile Xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 1:30 pm    Post subject: can't compile Xorg Reply with quote

I've installed the Kernel on my Levnovo-X201 without using the Genkernel but when I try, I can't compile the Xorg.

This is what I get :

* Error: circular dependencies:

(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) depends on
(virtual/opengl-7.0-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)
(media-libs/mesa-11.0.6:0/0::gentoo, ebuild scheduled for merge) (runtime)
(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) (buildtime_slot_op)

what do I need to do?
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sun Jan 17, 2016 2:04 pm    Post subject: Reply with quote

PsykoNerd,

You need to read the rest of the message.

It usually continues with some suggestions about temporarally disabling a USE flag or two.
This allows the build to continue but it won't be the way you asked for.
When you redo the build, it will work with all your USE flags.
Only packages affected by the USE flag changes will be rebuilt.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 3:38 pm    Post subject: Reply with quote

ok heres the whole message I recieved :'


* Error: circular dependencies:

(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) depends on
(virtual/opengl-7.0-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)
(media-libs/mesa-11.0.6:0/0::gentoo, ebuild scheduled for merge) (runtime)
(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) (buildtime_slot_op)

It might be possible to break this cycle
by applying any of the following changes:
- media-libs/mesa-11.0.6 (Change USE: -vaapi)
- x11-libs/libva-1.6.2 (Change USE: -opengl)

I've tried to compile both, but it didn't work.
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sun Jan 17, 2016 4:57 pm    Post subject: Reply with quote

PsykoNerd

Code:
emerge wgetpaste


Then do
Code:
wgetpaste -c "emerge <command-that-failed>"

This will put the entire emerge output on the web.

Post the link.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 5:41 pm    Post subject: Reply with quote

https://bpaste.net/show/02efc591fe65
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 5:46 pm    Post subject: wait a mitute Reply with quote

I believe I need to do some more actions before I emerge Xorg, I'll try this first. Then I'll get back at you :-)
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 5:48 pm    Post subject: forget the last remark, I still need your help Reply with quote

..
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 5:51 pm    Post subject: I repeat ... Reply with quote

This was what I recieved from you command
https://bpaste.net/show/02efc591fe65
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43210
Location: 56N 3W

PostPosted: Sun Jan 17, 2016 6:00 pm    Post subject: Reply with quote

PsykoNerd,

That's better. You should not be installing x11-base/xorg-drivers yourself, which is what
Code:
emerge --ask --verbose x11-base/xorg-drivers
does.

Instead, you set your INPUT_DEVICES and VIDEO_CARDS in make.conf then
Code:
emerge x11-base/xorg-server

This will pull in x11-base/xorg-drivers with only the drivers you asked for.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 6:13 pm    Post subject: still :-( Reply with quote

**************************************************************
This is the error I get when emerge x11-base/xorg-server
**************************************************************

* Error: circular dependencies:

(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) depends on
(virtual/opengl-7.0-r1:0/0::gentoo, ebuild scheduled for merge) (buildtime)
(media-libs/mesa-11.0.6:0/0::gentoo, ebuild scheduled for merge) (runtime)
(x11-libs/libva-1.6.2:0/0::gentoo, ebuild scheduled for merge) (buildtime_slot_op)

It might be possible to break this cycle
by applying any of the following changes:
- media-libs/mesa-11.0.6 (Change USE: -vaapi)
- x11-libs/libva-1.6.2 (Change USE: -opengl)

Note that this change can be reverted, once the package has been installed.

*************************
This is my make.conf
*************************
USE="
alsa audio bindist dbus gtk mmx python sse sse2 sse3 udev vaapi xfce4 X
"

CFLAGS="-march=corei7 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS=-j5

VIDEO_CARDS="intel i965"
INPUT_DEVICES="evdev synaptics"


What's wrong ?
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
PsykoNerd
n00b
n00b


Joined: 20 Dec 2011
Posts: 16
Location: There !

PostPosted: Sun Jan 17, 2016 7:58 pm    Post subject: proble solved Reply with quote

Hi I've solved my problem, but thank you for your help
_________________
#############################
The next EARTH is pretty far AWAY.......THINK !!! (please)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum