Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Backlight hotkeys not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sun Jan 17, 2016 5:55 pm    Post subject: Backlight hotkeys not working Reply with quote

Hi!
i have a new Asus Zenbook UX305, a pretty nice ultrabook with an intel video card (broadwell-u).

I can control backlight with xbacklight or, generically, via /sys/class/backlight. But the two dedicated function keys (FN+F5 and FN+F6) do not work.

I have checked with xev, the F5 and F6 keys works, but if i press FN+F5/F6 absolutely NO event is generated.

I tried to add come conbinations of:
Code:

acpi_osi= acpi_backlight=intel"
pcie_aspm=force acpi_osi=linux acpi_backlight=vendor"
acpi_backlight=vendor acpi_osi=


and similar, but with absolutely no luck. All the "function" keys works (even sleep!), but not the two brightness keys.

Does anybody have any idea?
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Sun Jan 17, 2016 6:25 pm    Post subject: Reply with quote

If you don't already have these you might try compiling a kernel with the following menuconfig items:
Quote:
Device Drivers --->
[*] X86 Platform Specific Device Drivers --->
<M> Asus Laptop Extras
<M> WMI
<M> Intel Oaktrail Platform Extras (NEW)
<M> Intel Rapid Start Technology Driver (NEW)
<M> Intel Smart Connect disabling driver (NEW)
<M> Intel PMC IPC Driver (NEW)

_________________
Defund the FCC.
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sun Jan 17, 2016 7:38 pm    Post subject: Reply with quote

I actually did not had these drivers loaded, but even if i recompiled, they don't help.

Th asus laptop module does not even load (no such device).
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Sun Jan 17, 2016 8:05 pm    Post subject: Reply with quote

might google 'asus laptop forum' See if you can find a linux Asus Zenbook UX305 user with an answer
might see if the keys work in ubuntu or redhat and if they do see what they use

https://wiki.archlinux.org/index.php/extra_keyboard_keys#Asus_M_series
https://wiki.gentoo.org/wiki/Keyboard_layout_switching
_________________
Defund the FCC.
Back to top
View user's profile Send private message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 274
Location: Italy, Torino

PostPosted: Sun Jan 17, 2016 8:48 pm    Post subject: Reply with quote

I did some research and found a few answers, but none for this model. No solution would work for me.

My best guess at the moment is that for some reason the brightness function keys are wired trough ACPI in some ways, and the kernel is not picking them up. This is because those keys does not give any feedback trough the input layer nor the ACPI events layer.

An intermediate solution, since the backlight works, i will probably map ALT+F5/F6 to xbacklight, which is not idea but quite effective. Then will try again with a newer kernel, maybe a 4.4.0.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum