Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Circular dependencies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 277
Location: Kenzingen, Germany

PostPosted: Tue Jan 19, 2016 11:48 am    Post subject: Circular dependencies Reply with quote

I have got the following problem (after not updating for about 10 months):

quote:
i7 ~ # emerge --ask portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-apps/install-xattr-0.5
[ebuild N ] dev-python/packaging-15.3-r2 USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5"
[ebuild U ] dev-python/setuptools-19.2 [12.0.5] PYTHON_TARGETS="python3_4* -python3_3* -python3_5%"
[ebuild N ] dev-python/certifi-2015.11.20.1 PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5"
[ebuild N ] dev-python/pyxattr-0.5.5 USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3"
[ebuild U ] sys-apps/portage-2.2.27 [2.2.18] USE="xattr*" PYTHON_TARGETS="python3_4* -python3_3* -python3_5%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-apps/portage:0

(sys-apps/portage-2.2.27:0/0::gentoo, ebuild scheduled for merge) pulled in by
sys-apps/portage (Argument)

(sys-apps/portage-2.2.18:0/0::gentoo, installed) pulled in by
sys-apps/portage[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/layman-2.3.0:0/0::gentoo, installed)

sys-apps/portage[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (app-portage/gentoolkit-0.3.0.9-r2:0/0::gentoo, installed)


dev-python/setuptools:0

(dev-python/setuptools-19.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_pypy(-)?,python_targets_pypy3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)


(dev-python/setuptools-12.0.5:0/0::gentoo, installed) pulled in by
dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/cryptography-0.8.1:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/pytz-2015.2:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_pypy(-)?,python_targets_pypy3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/cssutils-0.9.10-r1:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- app-emulation/aranym-0.9.16::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (06 Jan 2016)
# Fails to build, bug #529434. Removal in a month.

- virtual/python-imaging-2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Justin Lecher <jlec@gentoo.org> (10 Nov 2015)
# Compatibility virtual for transition from
# dev-python/imaging to dev-python/pillow
# obsolete now #508266

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

i7 ~ #
end of quote

How would you solve this?
*Backtrack=30 does not solve it
*Masking one package leads to autounmask asking for unmask
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 277
Location: Kenzingen, Germany

PostPosted: Tue Jan 19, 2016 11:53 am    Post subject: Slot conflict Reply with quote

Maybe the thread title should be renamed 'slot conflict" and moved to the portage threads?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Jan 19, 2016 3:12 pm    Post subject: Reply with quote

I would try, for starters:
Code:
emerge --unmerge layman gentoolkit
emerge portage
emerge layman gentoolkit
emerge install-xattr
emerge python-updater
python-updater

_________________
Defund the FCC.
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 277
Location: Kenzingen, Germany

PostPosted: Tue Jan 19, 2016 4:49 pm    Post subject: Reply with quote

Unmerging layman and gentoolkit did not change the situation.
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 277
Location: Kenzingen, Germany

PostPosted: Tue Jan 19, 2016 4:55 pm    Post subject: Reply with quote

It now looks like this:

i7 ~ # emerge --ask portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild N ] sys-apps/install-xattr-0.5
[ebuild N ] dev-python/packaging-15.3-r2 USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5"
[ebuild U ] dev-python/setuptools-19.2 [12.0.5] PYTHON_TARGETS="python3_4* -python3_3* -python3_5%"
[ebuild N ] dev-python/certifi-2015.11.20.1 PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3 -python3_5"
[ebuild N ] dev-python/pyxattr-0.5.5 USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_3"
[ebuild U ] sys-apps/portage-2.2.27 [2.2.18] USE="xattr*" PYTHON_TARGETS="python3_4* -python3_3* -python3_5%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

(dev-python/setuptools-19.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_pypy(-)?,python_targets_pypy3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/certifi-2015.11.20.1:0/0::gentoo, ebuild scheduled for merge)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/pyxattr-0.5.5:0/0::gentoo, ebuild scheduled for merge)


(dev-python/setuptools-12.0.5:0/0::gentoo, installed) pulled in by
dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/pytz-2015.2:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-),python_targets_python3_3(-),-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/cryptography-0.8.1:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-)] required by (dev-python/numpy-1.9.2:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_pypy(-)?,python_targets_pypy3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)] required by (dev-python/chardet-2.3.0:0/0::gentoo, installed)

dev-python/setuptools[python_targets_python2_7(-)?,python_targets_python3_3(-)?,python_targets_python3_4(-)?,python_targets_pypy(-)?,-python_single_target_python2_7(-),-python_single_target_python3_3(-),-python_single_target_python3_4(-),-python_single_target_pypy(-)] required by (dev-python/cssutils-0.9.10-r1:0/0::gentoo, installed)



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- virtual/python-imaging-2::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Justin Lecher <jlec@gentoo.org> (10 Nov 2015)
# Compatibility virtual for transition from
# dev-python/imaging to dev-python/pillow
# obsolete now #508266

- app-emulation/aranym-0.9.16::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (06 Jan 2016)
# Fails to build, bug #529434. Removal in a month.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

i7 ~ #


So it did change in respect to portage but installation is still not possible.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7550
Location: Goose Creek SC

PostPosted: Tue Jan 19, 2016 5:18 pm    Post subject: Reply with quote

Are you able to:
Code:
emerge install-xattr
emerge python-updater
python-updater
emerge wgetpaste
if wgetpaste and/or python-updater are installed already, emerge not needed.
Code:
emerge -pv portage | wgetpaste
and post the url returned here will give complete result without cluttering the thread.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 277
Location: Kenzingen, Germany

PostPosted: Fri Jan 29, 2016 8:13 pm    Post subject: Result Reply with quote

The procedure allowed me to emerge portage. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum