Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Bunter Prompt bei Root ist weg.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Jan 23, 2016 5:28 pm    Post subject: [gelöst] Bunter Prompt bei Root ist weg. Reply with quote

Ok, da ich aktuell bei mir viel umgebaut habe, kann ich absolut nicht nachvollziehen, an was es liegt. Aber auf einmal ist es so.

Bislang habe ich immer einen bunten, oder sagen wir, andersfarbigen Prompt bekommen, wenn ich in der Konsole mit su zu Root gewechselt bin. Und seit ein paar Tagen ändert sich da nichts mehr. Ist wie beim normalen User. Das nervt, weil ich vorher sofort gesehen habe, Root oder nicht. Man hat sich halt dran gewöhnt.

Jemand eine Ahnung, an was das liegt?


Last edited by Klaus Meier on Sat Jan 23, 2016 10:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jan 23, 2016 6:36 pm    Post subject: Reply with quote

Welche Shell?
Bei nem etc-update nicht aufgepasst und eine eigene config einfach überschrieben?
Vielleicht hat sich die die mitgelieferte default-config geändert?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sat Jan 23, 2016 6:55 pm    Post subject: Reply with quote

Das hängt sehr wahrscheinlich mit diesem Bug zusammen:
Die Gentoo bashrc benutzt eine üble Heuristik, um festzustellen, ob das Terminal Farben kennt, und da /etc/DIR_COLORS neuerdings ein erweitertes Format hat, geht dieser Heuristik-Hack schief.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Jan 23, 2016 7:22 pm    Post subject: Reply with quote

Hm, ich hab her seit zwei Tagen auch coreutils-8.25 installiert, und hier gab es bezüglich der Terminalfarben keine änderung - weder in der Textkonsole, noch in kde-apps/konsole, und zudem hab ich es grad noch kurz im xterm getestet - tut alles fein. (ich nutze hier die bash)
In dem Bugreport wird gnome-terminal erwähnt, daher frage ich mich ob es eventuell nur das gnome-terminal betrifft?

/edit: Klaus, magst es mal im xterm testen?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Jan 23, 2016 10:13 pm    Post subject: Reply with quote

Ja, ich nutzt das Gnome-Terminal. Habe es mal auf der Console getestet, da tritt das Problem nicht auf. Mit dem Patch aus dem Bugreport funktioniert es wieder.

Danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum