Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TBS6280 DVB-T2 card (SOLVED)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
andrewwalker27
l33t
l33t


Joined: 27 Jun 2005
Posts: 650

PostPosted: Sun Jan 24, 2016 11:55 am    Post subject: TBS6280 DVB-T2 card (SOLVED) Reply with quote

I'm trying to get my TBS6280 TV card working but I can't find how to do it. The official driver is a binary blob and the official channels only seem interested in Ubuntu, but I have found some open source drivers in git.

http://www.linuxtv.org/wiki/index.php/TBS_driver_installation

I've tried installing as suggested but I get the following error
Code:

PhenomIIx6 media_build # make dir DIR=../media
make -C linux/ dir DIR="../../media"
make[1]: Entering directory '/root/tbs/media_build/linux'
rm -rf drivers firmware include sound .patches_applied .linked_dir .git_log.md5 git_log kernel_version.h
/bin/sh: lsdiff: command not found
Makefile:123: recipe for target 'dir' failed
make[1]: *** [dir] Error 127
make[1]: Leaving directory '/root/tbs/media_build/linux'
Makefile:32: recipe for target 'dir' failed
make: *** [dir] Error 2

Is there a 'proper' way of installing this with Gentoo so that it will install and upgrade using the normal methods? Is there an ebuild somewhere I can use?
I'm running kernel 4.1.12 on ~x86_64 if that is relevant.
Any help would be appreciated as I don't really know where to start with this.


Last edited by andrewwalker27 on Sun Jan 24, 2016 4:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Jan 24, 2016 2:28 pm    Post subject: Reply with quote

Try installing dev-util/patchutils
Back to top
View user's profile Send private message
andrewwalker27
l33t
l33t


Joined: 27 Jun 2005
Posts: 650

PostPosted: Sun Jan 24, 2016 4:33 pm    Post subject: Reply with quote

Cheers, that's the bit I was missing. I also needed to add the perl module ProcessTable if anyone else was following this.
Code:
cpan Proc::ProcessTable


Now works like a dream!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum