Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
redémarrage post installation, écran noir (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Sun Jan 24, 2016 3:56 pm    Post subject: redémarrage post installation, écran noir (résolu) Reply with quote

Bonjour,

Je viens de faire l'installation de base de Gentoo avec un profile Systemd/Gnome, mais lors du redémarrage, pour finir mon instalation, une fois que j'ai choisi mon noyau dans grub2, le message m'informant du chargement du noyau s'affiche puis ce brouille aussitôt et plus rien...

Donc je ne sais pas si c'est du à la configuration manuelle du noyau ou autre ??
Je ne suis pas contre un peu d'aide s'il vous plaît. :wink:

Mon ordianteur est un macbook alu version 8,1, si il vous plus d'information n'hésister pas.
FSTAB : https://bpaste.net/show/0cb03b73831f
GRUB.CFG : https://bpaste.net/show/84c05509b48e
CONFIG KERNEL : https://bpaste.net/show/a35e0cf0d1cb
LSPCI : https://bpaste.net/show/d123f17625e6

Code:
emerge --info
Portage 2.2.26 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.21-r1, 3.18.25-std471-amd64 x86_64)
=================================================================
System uname: Linux-3.18.25-std471-amd64-x86_64-Intel-R-_Core-TM-_i5-2415M_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     8085516 total,   7445512 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 23 Jan 2016 16:45:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.fr.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv infinality introspection ipv6 jpeg lcms ldap libnotify libsecret mad mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support readline sdl seccomp session spell sse sse2 ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Last edited by slym on Mon Jan 25, 2016 4:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 863
Location: Switzerland

PostPosted: Sun Jan 24, 2016 4:54 pm    Post subject: Reply with quote

Hello,

Il semble que tu sois en installation UEFI sans refind, refit ou autre?
A vue de nez je pointerais sur ta configuration du noyau.
Nos configurations ne sont pas très loin par conséquent tu peux tenter avec ma configuration que tu trouves sur mon Github

Au feeling j'aurais dit un problème avec le framebuffer.
Si tu chroot sous ta gentoo via systemrescuecd ou autre tu peux aussi voir ce que te dises les logs. (/var/log/messages)

Egalement au niveau du grub tu peux tenter d'ajouter
Quote:
intel_iommu=igfx_off

dans la rubrique GRUB_CMDLINE_LINUX_DEFAULT=
Toujours au niveau de grub as-tu bien défini que tu utilisais systemd en non pas openrc
Quote:
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd"

_________________
Macbook Pro Unibody 9.1 - Kernel 4.4.6 - Awesome 3.5
Back to top
View user's profile Send private message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Sun Jan 24, 2016 7:45 pm    Post subject: Reply with quote

Bonsoir Gulivert et merci pour ta réponse. :wink:

J'ai effectuer les changements au niveau de grub, sans changement... :(

J'en ai aussi profiter pour regarder le dmesg (arrg oublier de faire un wgetpaste), mais là seul erreur que j'ai vu est :
Code:
Warning: unable to open an initial console

En cherchant un peu, je n'ai pas trouvé grand chose, si ce n'est ce lien qui donne une solution, je verrais ça demain, idem pour la configuration du noyau.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Mon Jan 25, 2016 8:17 am    Post subject: Reply with quote

Bonjour,

Le lien qui demande de créer /dev/null et /dev/console devrait corriger ce message.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Mon Jan 25, 2016 10:08 am    Post subject: Reply with quote

Bonjour,

Effectivement, le message qui indique le chargement du noyau s'affiche correctement suite à la manipulation effectuer à partir du lien, mais au deuxième redémarrage, même soucis, donc je suis revenu au point de départ. :evil:
Je vous met en lien une copie du fichier dmesg (je n'ai pas de fichier messages dans /var/log, est ce normal ?), comme je suis débutant, vous verrez peut-être quelques chose qui m'a échapper. En attendant, je vais relire le handbook pour vérifier que je n'ai pas oublier une étape.

DMESG : https://bpaste.net/show/473881452175
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8131
Location: ~Brussels - Belgique

PostPosted: Mon Jan 25, 2016 11:00 am    Post subject: Reply with quote

As-tu bien ajouté le paramètre du noyau pour démarrer systemd "init=/usr/lib/systemd/systemd" ? Par défaut, c'est openrc qui est lancé.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Mon Jan 25, 2016 11:19 am    Post subject: Reply with quote

Oui, ajouter dans /etc/default/grub puis j'ai executer
Code:
grub2-mkconfig -o /boot/grub/grub.cfg

Là, je recompile le noyau.. je croise les doigts, parce que je ne sais plus quoi faire après ! :(
Back to top
View user's profile Send private message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Mon Jan 25, 2016 11:35 am    Post subject: Reply with quote

Bon, toujours le même soucis malgré la vérification de la configuration et la re-compilation du noyau.

EDIT J'ai tenter la configuration de gulivert avec quelques modification et avec les gentoo-sources en ~ amd64, ça fonctionne. En attendant c'est parfait et je peux continuer mon installation ! :mrgreen:
Back to top
View user's profile Send private message
gulivert
l33t
l33t


Joined: 17 Jun 2004
Posts: 863
Location: Switzerland

PostPosted: Mon Jan 25, 2016 4:11 pm    Post subject: Reply with quote

OK alors ce que j'en vois c'est que tu as une installation en UEFI d'après ceci,
Quote:
[ 0.000000] efi: EFI v1.10 by Apple
[ 0.000000] efi: ACPI=0x8ad8e000 ACPI 2.0=0x8ad8e014 SMBIOS=0x8ad3b000


Si j'ai juste, c'est très bien mais ce qui est mal c'est ça :
Quote:
915 0000:00:02.0: fb0: inteldrmfb frame buffer device


Tu devrais pour une installation EFI plutot utiliser le framebuffer EFI comme ceci
Quote:

[ 1.259296] efifb: probing for efifb
[ 1.259309] efifb: framebuffer at 0x90020000, mapped to 0xffffc90002000000, using 8448k, total 8448k
[ 1.259311] efifb: mode is 1680x1050x32, linelength=8192, pages=1
[ 1.259311] efifb: scrolling: redraw
[ 1.259313] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0


Il faut par conséquent recompiler ton noyau en changeant les options suivantes :
Code:
Device Drivers -> Graphics support -> Frame Buffer devices


tout retirer et ne garder que :
Code:
Support for frame buffer devices
Enable Video Mode Handling Helpers
Enable Tile Blitting Support
EFI-based Framebuffer Support


C'est bien un noyau configuré à la mano par tes soins ?

Je ne vois que ça et j'espère que c'est suffisant, tu es pas loin du bout :) et bienvenu sur Gentoo :)

EDIT: LOL grillé... tu as édité ton post quand j'écrivais celui-ci haha
_________________
Macbook Pro Unibody 9.1 - Kernel 4.4.6 - Awesome 3.5
Back to top
View user's profile Send private message
slym
n00b
n00b


Joined: 24 Jan 2016
Posts: 6

PostPosted: Mon Jan 25, 2016 4:21 pm    Post subject: Reply with quote

Oui, c'était bien un noyau configuré à la main.
Je prend note de tes remarques concernant les options a configurer pour la prochaine fois, en tout cas encore merci, parce que grâce a toi, j'ai pu avancer ! :wink:

Encore une fois, merci a tous d'avoir le temps de m'aider. :D
J'espère ne plus avoir de soucis d'ici la fin de l'installation. ^^
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum