Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201601-02 ] WebKitGTK+
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Tue Jan 26, 2016 8:26 pm    Post subject: [ GLSA 201601-02 ] WebKitGTK+ Reply with quote

Gentoo Linux Security Advisory

Title: WebKitGTK+: Multiple vulnerabilities (GLSA 201601-02)
Severity: normal
Exploitable: remote
Date: January 26, 2016
Bug(s): #536234
ID: 201601-02

Synopsis

Multiple vulnerabilities have been found in WebKitGTK+, allowing
remote attackers to execute arbitrary code or cause a Denial of Service
condition.


Background

WebKitGTK+ is a full-featured port of the WebKit rendering engine.

Affected Packages

Package: net-libs/webkit-gtk
Vulnerable: < 2.4.9
Unaffected: >= 2.4.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in WebKitGTK+. Please
review the CVE identifiers referenced below for details.


Impact

A remote attack can use multiple vectors to execute arbitrary code or
cause a denial of service condition.


Workaround

There is no known workaround at this time.

Resolution

All WebKitGTK+ 3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.4.9:3"
   
All WebKitGTK+ 2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=net-libs/webkit-gtk-2.4.9-r200:2"
   


References

CVE-2014-1344
CVE-2014-1384
CVE-2014-1385
CVE-2014-1386
CVE-2014-1387
CVE-2014-1388
CVE-2014-1389
CVE-2014-1390
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum