Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201601-05 ] OpenSSL
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2189

PostPosted: Sat Jan 30, 2016 12:26 am    Post subject: [ GLSA 201601-05 ] OpenSSL Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Multiple vulnerabilities (GLSA 201601-05)
Severity: normal
Exploitable: remote
Date: January 29, 2016
Updated: February 26, 2016
Bug(s): #572854
ID: 201601-05

Synopsis

Multiple vulnerabilities have been found in OpenSSL, allowing
remote attackers to disclose sensitive information and complete weak
handshakes.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.0.2f
Unaffected: >= 1.0.2f
Unaffected: >= 1.0.1r < 1.0.2
Unaffected: >= 1.0.1s < 1.0.2
Unaffected: >= 1.0.1t < 1.0.2
Unaffected: >= 0.9.8z_p8 < 0.9.9
Unaffected: >= 0.9.8z_p9 < 0.9.9
Unaffected: >= 0.9.8z_p10 < 0.9.9
Unaffected: >= 0.9.8z_p11 < 0.9.9
Unaffected: >= 0.9.8z_p12 < 0.9.9
Unaffected: >= 0.9.8z_p13 < 0.9.9
Unaffected: >= 0.9.8z_p14 < 0.9.9
Unaffected: >= 0.9.8z_p15 < 0.9.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in OpenSSL. Please review
the upstream advisory and CVE identifiers referenced below for details.
Note that the list includes CVE identifiers for an older OpenSSL Security
Advisory (3 Dec 2015) for which we have not issued a GLSA before.


Impact

A remote attacker could disclose a server’s private DH exponent, or
complete SSLv2 handshakes using ciphers that have been disabled on the
server.


Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.2f"
   


References

CVE-2015-1794
CVE-2015-3193
CVE-2015-3194
CVE-2015-3195
CVE-2015-3196
CVE-2015-3197
CVE-2016-0701
OpenSSL Security
Advisory [28th Jan 2016]


Last edited by GLSA on Sat Feb 27, 2016 4:17 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum