Joined: 12 May 2004
|Posted: Sat Jan 30, 2016 12:26 am Post subject: [ GLSA 201601-05 ] OpenSSL
|Gentoo Linux Security Advisory
Title: OpenSSL: Multiple vulnerabilities (GLSA 201601-05)
Date: January 29, 2016
Updated: February 26, 2016
Multiple vulnerabilities have been found in OpenSSL, allowing
remote attackers to disclose sensitive information and complete weak
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
Vulnerable: < 1.0.2f
Unaffected: >= 1.0.2f
Unaffected: >= 1.0.1r < 1.0.2
Unaffected: >= 1.0.1s < 1.0.2
Unaffected: >= 1.0.1t < 1.0.2
Unaffected: >= 0.9.8z_p8 < 0.9.9
Unaffected: >= 0.9.8z_p9 < 0.9.9
Unaffected: >= 0.9.8z_p10 < 0.9.9
Unaffected: >= 0.9.8z_p11 < 0.9.9
Unaffected: >= 0.9.8z_p12 < 0.9.9
Unaffected: >= 0.9.8z_p13 < 0.9.9
Unaffected: >= 0.9.8z_p14 < 0.9.9
Unaffected: >= 0.9.8z_p15 < 0.9.9
Architectures: All supported architectures
Multiple vulnerabilities have been discovered in OpenSSL. Please review
the upstream advisory and CVE identifiers referenced below for details.
Note that the list includes CVE identifiers for an older OpenSSL Security
Advisory (3 Dec 2015) for which we have not issued a GLSA before.
A remote attacker could disclose a server’s private DH exponent, or
complete SSLv2 handshakes using ciphers that have been disabled on the
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.2f"
Advisory [28th Jan 2016]
Last edited by GLSA on Sat Feb 27, 2016 4:17 am; edited 2 times in total