Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Updated genkernel config file - gentoo not booting anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ebnerjoh
Tux's lil' helper
Tux's lil' helper


Joined: 27 Oct 2006
Posts: 83

PostPosted: Sun Jan 31, 2016 9:59 am    Post subject: Updated genkernel config file - gentoo not booting anymore Reply with quote

Dear All,

I have a gentoo with Software-Raid and gparted partitions. It was running without any issues but today I wanted to update to the latest gentoo kernel.
I had some issues with running genkernel all so I reinstalled genkernel and noticed that genkernel.conf was changed.

So I used the new genkernel.conf but added "dmraid=yes, mdadm=yes, mdadm config location and bootloader=grub2.

then I was running "genkernel all" and "grub2-mkconfig -o /boot/grub/grub.conf".

After rebooting I am only getting the "grub>" command line. I have no ideas, what happend, and how I could recover the system.

Best Regards,
Johannes Ebner
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43223
Location: 56N 3W

PostPosted: Sun Jan 31, 2016 11:35 am    Post subject: Reply with quote

ebnerjoh,

grub cannot find its config file.

ebnerjoh wrote:
... grub2-mkconfig -o /boot/grub/grub.conf

Legacy grub uses grub.conf, grub2 uses grub.cfg.
You have made a grub config file with the wrong name, so at boot, grub will not find it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ebnerjoh
Tux's lil' helper
Tux's lil' helper


Joined: 27 Oct 2006
Posts: 83

PostPosted: Sun Jan 31, 2016 11:39 am    Post subject: Reply with quote

NeddySeagoon wrote:
ebnerjoh,

grub cannot find its config file.

ebnerjoh wrote:
... grub2-mkconfig -o /boot/grub/grub.conf

Legacy grub uses grub.conf, grub2 uses grub.cfg.
You have made a grub config file with the wrong name, so at boot, grub will not find it.


Hi, it was a type. I had correctly used grub.cfg

I made some tasks and now it is working again:

1) booted up with livecd and made a chroot
2) grub-install into /dev/sda and /dev/sdb
3) recompiled kernel with genkernel --mdadm all
4) reinstalled grub config file with grub2-mkconfig -o /boot/grub/grub.cfg

I am not sure if it was #2 or #3 which fixed my issue.

Br,
Johannes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum