Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Init hangs with gentoo-4.4.0-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Sun Jan 31, 2016 11:23 pm    Post subject: Init hangs with gentoo-4.4.0-r1 Reply with quote

Hello,

I recently switched to gentoo (at first the stable branch) following the excellent installation guide.
On my system, / and swap are logical volumes and /boot is on an ESP. I am using genkernel to build the kernel with the command
Code:
genkernel --lvm all
.

Everything worked until I switched to the testing branch. I updated all packages and built a kernel from the gentoo-4.4.0.r1 sources with genkernel. I emerged @module-rebuild, @x11-module-rebuild, and @preserved-rebuild. Additionally, I re-emerged lvm2 as one-shot. When booting the new kernel however, the init hangs at "Setting up Logical Volume Manager" (C-c won't skip it). Booting back into 4.1.15-r1 works fine.

I don't believe the LVM is the actual problem. Booting to init=/bin/bash shows that the logical volume is mounted and I can read the files on the disk. Proceeding from there with exec /sbin/init results in hanging after the LVM meta data daemon was successfully started. After that there is no further output and the system is frozen.

My emerge --info: http://pastebin.com/PZJg9ibC

It would be great if someone could point me into the right direction how to properly debug this problem.

Thanks,
medaron
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Sun Jan 31, 2016 11:31 pm    Post subject: Reply with quote

You sure it is LVM that hangs, not the next service after it? What is the next one?
Back to top
View user's profile Send private message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Mon Feb 01, 2016 12:14 am    Post subject: Reply with quote

No, I don't think it's the LVM. I tried a few more boots and the step at which it hangs changes each time.

It is sometimes
Code:
 * Setting hardware clock using the system clock [UTC] ...
and sometimes the subsequent step
Code:
 * Executing: /lib64/rc/sh/openrc-run.sh /lib64/rc/sh/openrc-run.sh /etc/init.d/modules start
. For some reason OpenRC does not log the failed boot attempts. The only entries in the rc.log are from booting the 4.1.15 kernel. For the successful boot attempts, the log says * Autoloaded 0 module(s) after modules start.
Back to top
View user's profile Send private message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Mon Feb 01, 2016 1:35 am    Post subject: Reply with quote

I now started OpenRC in interactive mode. It only hangs if I allow the udev-trigger service to run. I suppose the next step should be to check, which rule in /lib/udev/rules.d/ is causing the problem. Is there a convenient way to let udev load rules interactively during boot or do I need to comment out the content of each rule file one at a time?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2616

PostPosted: Mon Feb 01, 2016 10:04 am    Post subject: Reply with quote

medaron wrote:
I now started OpenRC in interactive mode. It only hangs if I allow the udev-trigger service to run.

What about completely removing that udev-trigger service from the runlevels?
I know there is https://www.gentoo.org/support/news-items/2015-06-08-udev-init-scripts-changes.html but my system runs without udev-trigger.
Back to top
View user's profile Send private message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Wed Mar 02, 2016 5:04 am    Post subject: Reply with quote

Apologies for not replying earlier. A system without udev triggers would have solved/avoided the problem, too.
Further investigation showed that the system did not freeze, only the display. Starting the SSH daemon at boot allowed my to ssh into the machine after the display froze. This occurred for the rule
Code:
/lib64/udev/rules.d/80-drivers.rules
.
I avoided the problem by compiling the Intel GPU driver into the kernel instead of as a module.

Notably, in another test I overwrote aforementioned rule and loaded the module via modprobe without problem. Should this be reported as udev bug?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2616

PostPosted: Wed Mar 02, 2016 7:43 am    Post subject: Reply with quote

medaron wrote:
I avoided the problem by compiling the Intel GPU driver into the kernel instead of as a module.

Notably, in another test I overwrote aforementioned rule and loaded the module via modprobe without problem. Should this be reported as udev bug?

I don't understand what's the benefit of having that driver as a module.
Back to top
View user's profile Send private message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Wed Mar 02, 2016 7:52 am    Post subject: Reply with quote

I previously used the default config for the gentoo-sources. I suppose that makes sense for the default config since at packaging time it is unknown what hardware the user has and compiling all drivers into the kernel would increase the memory use.
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 434

PostPosted: Wed Mar 02, 2016 5:53 pm    Post subject: Reply with quote

Funny thing, I can only build that driver as a module, dunno why it doesn't offer me a <*> , just <M> or nothing.
I'm on 4.4.3 gentoo-sources
Back to top
View user's profile Send private message
medaron
n00b
n00b


Joined: 25 Jan 2016
Posts: 16
Location: NY

PostPosted: Thu Mar 03, 2016 1:23 am    Post subject: Reply with quote

I cannot check right now but IIRC, building the driver with <*> requires another option to be set to <*>, which is <M> in the gentoo default config.
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 434

PostPosted: Thu Mar 03, 2016 9:16 am    Post subject: Reply with quote

Ah yes, DRM has to be <*> , thanks !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum