Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[S] hibernate will nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Tue Feb 02, 2016 10:52 am    Post subject: [S] hibernate will nicht Reply with quote

ich versuche hier s2disk zum Laufen zu bekommen

es wird auch ein snapshot geschrieben,
während des boot-Vorgangs bekomme ich sogar irgendwo die meldung, das die swap-partion ein suspend image enthält
aber es wird einfach ein normaler boot durchgeführt

swap partion ist /dev/sda3 aber weder mit resume=/dev/sda3 noch über UUID bekomme ich das system dazu gebracht ordentlich wieder aufzuwachen

hier mal ein Ausschnitt aus dmesg, nach erfolglosem Aufwachen

Code:

[Di Feb  2 11:38:45 2016] Command line: BOOT_IMAGE=/vmlinuz-4.1.12-gentoo root=/dev/sda4 ro resume=UUID=b89dfa72-07fd-431b-8339-e1cc0b7c31c7
....
[Di Feb  2 11:38:45 2016] PM: Checking hibernation image partition UUID=b89dfa72-07fd-431b-8339-e1cc0b7c31c7
....
[Di Feb  2 11:38:45 2016]  sda: sda1 sda2 sda3 sda4
[Di Feb  2 11:38:45 2016] sd 0:0:0:0: [sda] Attached SCSI disk
...
[Di Feb  2 11:38:45 2016] PM: Hibernation image not present or could not be loaded.

für /dev/sda3 sieht die meldung genauso aus

Wenn ich die Sequenz richtig lese, sucht er auch nach dem Image, ehe der kernel die harddisk überhaupt gefunden hat :roll:

hat jemand eine Ahnung wo ich noch nachschauen könnte?
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router


Last edited by Treborius on Wed Feb 03, 2016 2:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Feb 02, 2016 11:19 am    Post subject: Reply with quote

Hast du im Kernel die Variable "CONFIG_PM_STD_PARTITION" auf /dev/sda3 gesetzt?

Welchen Typ hat denn /dev/sda3? Mach mal ein "mkswap /dev/sda3"
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Tue Feb 02, 2016 2:36 pm    Post subject: Reply with quote

Klaus Meier wrote:
Hast du im Kernel die Variable "CONFIG_PM_STD_PARTITION" auf /dev/sda3 gesetzt?

Welchen Typ hat denn /dev/sda3? Mach mal ein "mkswap /dev/sda3"


#kernel -config
Code:

CONFIG_PM_STD_PARTITION="/dev/sda3"


#blkid
Code:

/dev/sda3: UUID="b89dfa72-07fd-431b-8339-e1cc0b7c31c7" TYPE="swap" PARTLABEL="swap" PARTUUID="62638867-6639-475a-b166-62490d4b7f6d"


edit : zu klein ist die swap partion imho auch nicht :
Code:

free -h
                   total        used       
Mem:           3,8G        581M       
Swap:          7,8G          0B       

_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Wed Feb 03, 2016 6:27 am    Post subject: Reply with quote

Wirf doch mal das ganze Resume-Geraffel aus deiner Startzeile. Wenn du es im Kernel eingetragen hast, dann brauchst du sonst nichts mehr. Bei mir wurde der Eintrag von grub2-mkconfig generiert und nicht verändert. Er sieht so aus:
Code:
/boot/vmlinuz-4.4.1-gentoo root=/dev/sda1 ro
Reicht. Mehr braucht man nicht und es funktioniert damit.
Back to top
View user's profile Send private message
Treborius
Guru
Guru


Joined: 18 Oct 2005
Posts: 582
Location: Berlin

PostPosted: Wed Feb 03, 2016 2:12 pm    Post subject: Reply with quote

ach irgendwie will s2disk bei mir nicht mit
Code:

SLEEP_MODULE="kernel"

in /etc/pm/config.d/gentoo funzt es nun,
ein einfaches
Code:

emerge -aC suspend

tuts wohl auch (ungetestet)
==> solved
_________________
Systems running gentoo :
Desktop, Laptop, ZOTAC AD-10 media-center, odroid-xu4 server / wLan-router
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum