Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Another NVidia problem - hangs after startx?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
calif
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2009
Posts: 101

PostPosted: Thu Feb 11, 2016 11:11 pm    Post subject: [Solved] Another NVidia problem - hangs after startx? Reply with quote

Hi, I haven't been using Gentoo for a while, I decided to come back when... something strange happened. :)

I'm installing Funtoo (hope that doesn't make any difference) and I'm having some problems with Xorg setup.

I set up /etc/portage/make.conf to use nvidia drivers (VIDEO_CARDS="nvidia"), blacklisted nouvouau in /etc/modprobe.d/blacklist.conf-ish added to modules="nvidia" in /etc/conf.d/modules and installed xorg-x11. nvidia-drivers-355.11-r3 has been installed back then.

Then I tried many options:
- simply, startx - hangs with not-flashing "_" sing, I cannot change tty using [Ctrl+]Alt+F1, cannot do Ctrl+Alt+Del and stuff.
- Xorg -configure - generates xorg.conf.new but it behaves like above
- nvidia-xconfig - the same

Well, I have no idea what I should do next, could you please help me with this? Sometimes it hangs on "_" char, sometimes it hangs on displaying "DisplayPort" on my monitor as my video source, what I have to do then is to push my "reboot" button. :)

Here is my emerge --info: http://bpaste.net/show/e769aff81ffe . I'm not sure what else should I paste here.

Thanks in advance

PS.
I'm sorry if this is a duplicate, I was trying to find something helpful but didn't succeed. :(


EDIT:

More info:
- I'm using debian-sources-3.19.3
- dmesg: http://bpaste.net/show/2ae09e54445c
- xorg.conf generated by nvidia-xconfig: http://bpaste.net/show/8d5281a778d4
- Xorg.log.0[.old] is empty :(


Last edited by calif on Thu Feb 18, 2016 9:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Feb 12, 2016 2:43 pm    Post subject: Reply with quote

well some hate me for that, but did you already read the gentoo wiki, and really double checked every suggestion there?

Nviida always suggests itself the highest version so

Code:
equery y nvidia-drivers
Keywords for x11-drivers/nvidia-drivers:
                |                                 |   u       | 
                | a a   a         n   p r     s   |   n       | 
                | l m   r h i m m i   p i s   p   | e u s     | r
                | p d a m p a 6 i o p c s 3   a x | a s l     | e
                | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | p e o     | p
                | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | i d t     | o
----------------+---------------------------------+-----------+-------
 [M]96.43.23-r1 | * + * * * * * * * * * * * * * + | 5 o 0/96  | gentoo
----------------+---------------------------------+-----------+-------
[M]173.14.39-r1 | * + * * * * * * * * * * * * * + | 5 o 0/173 | gentoo
----------------+---------------------------------+-----------+-------
     304.131    | * + * * * * * * * * * * * * * + | 5 o 0/304 | gentoo
     304.131-r1 | * ~ * * * * * * * * * * * * * ~ | 5 #       | gentoo
     304.131-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      340.93-r1 | * + * * * * * * * * * * * * * + | 5 # 0/340 | gentoo
      340.96    | * + * * * * * * * * * * * * * + | 5 o       | gentoo
      340.96-r4 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      346.96-r1 | * + * * * * * * * * * * * * * + | 5 o 0/346 | gentoo
      346.96-r5 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      352.63    | * + * * * * * * * * * * * * * + | 5 o 0/352 | gentoo
      352.79    | * ~ * * * * * * * * * * * * * ~ | 5 #       | gentoo
      352.79-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      355.11-r2 | * + * * * * * * * * * * * * * + | 5 o 0/355 | gentoo
      355.11-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      358.16-r1 | * + * * * * * * * * * * * * * + | 5 o 0/358 | gentoo
      358.16-r4 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      361.28    | * ~ * * * * * * * * * * * * * ~ | 5 # 0/361 | gentoo
      361.28-r1 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo


361.28-r1 version is hte way to go, use that please. your hardware is too recent to stick to older nvidia-branch.

no idea on whats supported in your funtoo ... but, you may resuse the gentoo ebuild

do not use antique kernels with future tech ... I'm using debian-sources-3.19.3
use kernel 4.4 with 361 nvidia please.

than report back, thanks
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Fri Feb 12, 2016 2:49 pm    Post subject: Reply with quote

create those two files please, i took it a year or two years ago from a guide. just take it, it even comes iwth overclocking capabilites, which you probably want on such a decent card.

Code:
cat /etc/X11/xorg.conf.d/nvidia.conf
Section "Device"
         Identifier  "nvidia"
         Driver      "nvidia"
         Option "Coolbits" "28"
         Option "NoLogo" "True"
EndSection

# This is a trailing line, it is needed so that End Section is not the last line
ASUS-G75VW roman # cat /etc/X11/xorg.conf.d/20opengl.conf
Section "Files"
   ModulePath "/usr/lib32/xorg/modules"
   ModulePath "/usr/lib64/opengl/nvidia"
   ModulePath "/usr/lib64/xorg/modules"
EndSection


and kick that junk
Quote:
- xorg.conf generated by nvidia-xconfig: http://bpaste.net/show/8d5281a778d4


e.g. google is your friend https://wiki.archlinux.org/index.php/NVIDIA

Quote:
Minimal configuration

bla bla bla ...

Quote:
modules="nvidia" in /etc/conf.d/modules


why?

Code:
cat /etc/conf.d/modules
# You can define a list modules for a specific kernel version,
# a released kernel version, a main kernel version or just a list.
# The most specific versioned variable will take precedence.
#modules_2_6_23_gentoo_r5="ieee1394 ohci1394"
#modules_2_6_23="tun ieee1394"
#modules_2_6="tun"
#modules_2="ipv6"
#modules="ohci1394"

# You can give modules a different name when they load - the new name
# will also be used to pick arguments below.
#modules="dummy:dummy1"

# Give the modules some arguments if needed, per version if necessary.
# Again, the most specific versioned variable will take precedence.
#module_ieee1394_args="debug"
#module_ieee1394_args_2_6_23_gentoo_r5="debug2"
#module_ieee1394_args_2_6_23="debug3"
#module_ieee1394_args_2_6="debug4"
#module_ieee1394_args_2="debug5"

# You should consult your kernel documentation and configuration
# for a list of modules and their options.
modules="${modules}"


everything you do which is not needed causes an error souce. I am quite sure that i did not had this in use on my nvidia boxes for over 8 years now, regarding laptops with nvidia gpus and nvidia-drivers.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5770

PostPosted: Fri Feb 12, 2016 7:46 pm    Post subject: Re: Another NVidia problem - hangs after startx? [GTX 970] Reply with quote

calif wrote:
- I'm using debian-sources-3.19.3

3.19 is years out of date. Your system's so out of date, in fact, that debian-sources isn't even in the tree any more. Get the rest of your system into a sane state first.
Back to top
View user's profile Send private message
j000
n00b
n00b


Joined: 25 Apr 2015
Posts: 8

PostPosted: Sat Feb 13, 2016 4:02 pm    Post subject: Reply with quote

I'm using gentoo-sources, GeForce GT 430.
Any drivers above 355 will freeze my pc completly on startx.
I have not tried any solutions yet, but here you go:
https://bugs.gentoo.org/show_bug.cgi?id=564096
and from there: https://devtalk.nvidia.com/default/topic/912455
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Feb 13, 2016 7:47 pm    Post subject: Reply with quote

j000 wrote:
I'm using gentoo-sources, GeForce GT 430.
Any drivers above 355 will freeze my pc completly on startx.
I have not tried any solutions yet, but here you go:
https://bugs.gentoo.org/show_bug.cgi?id=564096
and from there: https://devtalk.nvidia.com/default/topic/912455


please do not hijack threads.

your card is antique, needs legacy drivers afaik, with patches, see my other topic for the g70sg notebook which explains in detail on how to setup 9800m gts wiht kernel 4.0 branch. There was even a gentoo bug with patch attached and i also made a gentoo bug, with reference to solution.
when you had taken your time to read the release notes, ln the ebuild you would have seen that nvidia has a page with supported devices for each card, and you should stay below a certain version, as said see my other topic, or the topic regarding legacy devices. my main motivation why i ditched that 8 year old gpu!

gt 970 is newest card available

do not mix apples with bananas. thank you

GeForce GT 430 <= you may use nouveau, or patch your kernel with the patch in this forum or bgo.
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Sat Feb 13, 2016 7:51 pm    Post subject: Reply with quote

first google result

https://forums.gentoo.org/viewtopic-t-1014974-postdays-0-postorder-asc-start-25.html

Quote:
Posted: Sat Aug 22, 2015 10:30 pm Post subject:
, page 2
Back to top
View user's profile Send private message
j000
n00b
n00b


Joined: 25 Apr 2015
Posts: 8

PostPosted: Sat Feb 13, 2016 9:21 pm    Post subject: Reply with quote

I'm pretty sure my card is supported by newest drivers, not legacy ones. http://www.nvidia.com/download/driverResults.aspx/98373/en-us
Quote:
Version: 361.28
Release Date: 2016.2.9
GeForce 400 Series:
..., GeForce GT 430, ...


And sorry for hijacking thread. Screen goes black, only hard reset helps is exactly whats happening to me... Just did not have time to test solution posted in bug I linked.
Back to top
View user's profile Send private message
calif
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2009
Posts: 101

PostPosted: Tue Feb 16, 2016 8:05 pm    Post subject: Reply with quote

tw04l124 wrote:
well some hate me for that, but did you already read the gentoo wiki, and really double checked every suggestion there?

Nviida always suggests itself the highest version so

Code:
equery y nvidia-drivers
Keywords for x11-drivers/nvidia-drivers:
                |                                 |   u       | 
                | a a   a         n   p r     s   |   n       | 
                | l m   r h i m m i   p i s   p   | e u s     | r
                | p d a m p a 6 i o p c s 3   a x | a s l     | e
                | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | p e o     | p
                | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | i d t     | o
----------------+---------------------------------+-----------+-------
 [M]96.43.23-r1 | * + * * * * * * * * * * * * * + | 5 o 0/96  | gentoo
----------------+---------------------------------+-----------+-------
[M]173.14.39-r1 | * + * * * * * * * * * * * * * + | 5 o 0/173 | gentoo
----------------+---------------------------------+-----------+-------
     304.131    | * + * * * * * * * * * * * * * + | 5 o 0/304 | gentoo
     304.131-r1 | * ~ * * * * * * * * * * * * * ~ | 5 #       | gentoo
     304.131-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      340.93-r1 | * + * * * * * * * * * * * * * + | 5 # 0/340 | gentoo
      340.96    | * + * * * * * * * * * * * * * + | 5 o       | gentoo
      340.96-r4 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      346.96-r1 | * + * * * * * * * * * * * * * + | 5 o 0/346 | gentoo
      346.96-r5 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      352.63    | * + * * * * * * * * * * * * * + | 5 o 0/352 | gentoo
      352.79    | * ~ * * * * * * * * * * * * * ~ | 5 #       | gentoo
      352.79-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      355.11-r2 | * + * * * * * * * * * * * * * + | 5 o 0/355 | gentoo
      355.11-r3 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      358.16-r1 | * + * * * * * * * * * * * * * + | 5 o 0/358 | gentoo
      358.16-r4 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo
----------------+---------------------------------+-----------+-------
      361.28    | * ~ * * * * * * * * * * * * * ~ | 5 # 0/361 | gentoo
      361.28-r1 | * ~ * * * * * * * * * * * * * ~ | 5 o       | gentoo


361.28-r1 version is hte way to go, use that please. your hardware is too recent to stick to older nvidia-branch.

no idea on whats supported in your funtoo ... but, you may resuse the gentoo ebuild

do not use antique kernels with future tech ... I'm using debian-sources-3.19.3
use kernel 4.4 with 361 nvidia please.

than report back, thanks


AFAIR, I've installed latest (361) nvidia driver, but when switched to kde-plasma-5 mixin, it has been downgraded and I don't know how to upgrade it.

I try to build gentoo-sources kernel right now and have some problems with this, I will get back to this topic after solving this one:
Code:
https://forums.gentoo.org/viewtopic-p-7881268.html#7881268
Back to top
View user's profile Send private message
calif
Tux's lil' helper
Tux's lil' helper


Joined: 29 Nov 2009
Posts: 101

PostPosted: Thu Feb 18, 2016 8:10 pm    Post subject: Reply with quote

So now, I'm on Gentoo and I got 4.4.1-gentoo, did what you said (removed xorg.conf and added 20opengl.conf and nvidia.conf) and... the same thing happens.. Hangs after startx / /etc/init.d/xdm start...

What can I do now?


I got nvidia-drivers-361.28-r8 installed. I noticed that booting system lasts longer than without the drivers installed - the boot hangs for like 15 sec, and the runs further...

Does it matter?

dmesg | grep nvidia: https://bpaste.net/show/5f7902ea6feb

also nvrm returns: https://bpaste.net/show/a56ccaae0dba
Xorg.log: https://bpaste.net/show/d9d9df45d343

Sounds like a solution but I don't know what to do with this. I run on UEFI - is it a problem when it comes to nvidia? Should I get back to MBR or what? :)

@EDIT:

SOLUTION (iamben & NeddySeagoon from #gentoo):

- remove intel graphics support from kernel

Thank you very much for helping me!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum