Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Problem mit catfish
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Wed Feb 24, 2016 2:18 pm    Post subject: [gelöst] Problem mit catfish Reply with quote

Wie im Titel schon beschrieben hab ich seit länger Zeit Probleme mit Catfish.

Quote:
Hab auch schon ein Thread bei gentooforum aufgemacht hier mal der link
http://www.gentooforum.de/artikel/22002/problem-mit-catfish.html


Da hier doch etwas mehr Leute das Forum besuchen hoffe ich das ich so schneller den Fehler finden kann.

Wenn ich catfish starte kommt normal die Gui zum Vorschein aber gesucht wird leider nicht ... in der Konsole eingetippt catfish kommt diese Fehlermeldung.

Code:
#catfish
/usr/share/catfish/catfish/__init__.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk  # pylint: disable=E0611

** (catfish.py:7424): CRITICAL **: atk_object_set_description: assertion 'ATK_IS_OBJECT (accessible)' failed


Hmm ich weiß nicht genau was der GTK fehler bedeuten soll denn alle anderen Programme laufen und lassen sich problemlos installieren ?
Hoffe es findet sich jemand der mir den Fehler helfen kann zu beseitigen ...

Hier mal meine make.conf eventuell hab ich hier einen groben Fehler der mir nicht auffällt ?

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.

CFLAGS="-march=athlon64 -O2 -pipe"
CXXFLAGS="${CFLAGS}"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.

CHOST="x86_64-pc-linux-gnu"

# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

MAKEOPTS="-j9"

USE="-gnome -kde -qt4 -qt5 -libav X gtk gtk3 bindist alsa cdr dvdr pulseaudio udev gpm spell consolekit sqlite thunar icu startup-notificat xcomposite raw ffmpeg lame mms theora wavpack gcj minizip cddb scrobbler tools network-cron additions extensions nsplugin nvidia nano-syntax xinerama vpx twolame openal fontconfig gdbm

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"

#GENTOO_MIRRORS="ftp://gentoo.inode.at/source/"
#SYNC="rsync://rsync1.at.gentoo.org/gentoo-portage"

CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop"

GRUB_PLATFORMS="pc"
INPUT_DEVICES="evdev"
VIDEO_CARDS="nvidia"
LINGUAS="de"
ACCEPT_LICENSE="*"
source /var/lib/layman/make.conf

USE_PYTHON="2.7 3.4"
#PYTHON_TARGETS="python2_7 python3_4"
#PYTHON_SINGLE_TARGET="python3_4"

ABI_X86="64 32"


Falls andere Infos noch gebraucht werden bitte sagen ich werde sie dann schnellst möglich reinstellen
mfg
schatti


Last edited by Schattenschlag on Fri Feb 26, 2016 6:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 269

PostPosted: Wed Feb 24, 2016 5:10 pm    Post subject: Reply with quote

Da ist denke ich ein Bugreport fällig.
Das hier scheint die Lösung zu sein http://mednis.info/use-girequire_versiongtk-30-before-import.html

Wenn du in die Suchmaschine deiner Wahl
Quote:
PyGIWarning: Gtk was imported without specifying a version first.

eingibst, kannst du feststellen, dass es für unterschiedliche Programm dieses Problem gibt.
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 112

PostPosted: Thu Feb 25, 2016 3:51 pm    Post subject: Reply with quote

Danke für die Hilfe, hab zwar gesucht dürfte aber übersehen haben .... naja ...
Catfish läuft jetzt mal aber diese Fehlermeldungen kommen immer noch

Code:
Error creating proxy: Verbindung ist geschlossen (g-io-error-quark, 18)

** (catfish.py:3137): CRITICAL **: atk_object_set_description: assertion 'ATK_IS_OBJECT (accessible)' failed
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum